IPD - Volvo Parts SpecialistsVolvo PartsVolvo Salvage: Used Volvo Parts and Over 50 Years ExperienceSouthern Vo Vo sells genuine used Volvo parts

Please use this Amazon link ... and help keep MVS on the Web. Thank you!Amazon.com

Advertise here via Google

Login

Not part of the forums? Register. It's free.

Need help? See our Help Page.

ABS light now on after battery disconnect

Help, Advice and DIY Tutorials on Volvo's extremely popular car line -- Volvo's 1990s "bread and butter" cars -- powered by the ubiquitous and durable Volvo inline 5-cylinder engine.
1992 - 1997 850, 850 R, 850 T5-R, 850 T5, 850 GLT
1997 - 2000 S70, S70 AWD
1997 - 2000 V70, V70 AWD
1997 - 2000 V70-XC
1997 - 2004 C70

ABS light now on after battery disconnect

Postby johnnchrisr » 10 Dec 2010, 09:22

Hi again all,

I just replaced the instrument cluster bulbs in my '98 S70 and before getting started, disconnected the negative battery terminal. Upon hooking the battery back up and starting the car, I now have the ABS light illuminated constantly. I should note that I tested the bulbs without the dash back together to make sure they all worked, and when I reconnected the battery and started the car that first time, no ABS light. It was only after disconnecting the battery again, reassembling everything and reconnecting the battery that I got the light that is now chronic. I also tried disconnecting the battery again to no avail. I just replaced the ABS module a couple of weeks ago (car is new to me and I knew it needed to be done since both the ABS and TRACS lights would come on intermittently; the new module cleared that up and I confirmed ABS indeed worked), so I know that's OK. I have a feeling the light just needs resetting, but what a pain.

Any ideas?

Thanks,

Chris
1998 S70 Base, Silver, 103k miles
2001 C70-C LT, Silver, 134k miles
johnnchrisr
New Member
New Member
 
Posts: 22
Joined: 07 Dec 2010, 23:04
Location: Pittsburgh, PA
Model and Year: S70 T5M, 1999

Re: ABS light now on after battery disconnect

Postby Matty Moo » 10 Dec 2010, 14:11

Are you getting just the ABS light, or both ABS and TRACS?

Generally, the lights won't come on from disconnecting the battery, but stranger things have happened.

check your harnesses going to the module. Make sure the smaller one is completely bottomed out, and reseat the large multi-pin harness a few times.
Image
http://www.midwest-abs.com

1996 850 Platinum Wagon. ARD Green Tune, OBX.
1998 s70 ARD tune, EST exhaust, SE/R interior.
1999 s70 Plain Jane.
2007 Chrysler 300c
2012 Jeep Wrangler Unlimited
User avatar
Matty Moo
Senior Forum Member
Senior Forum Member
 
Posts: 1375
Joined: 13 Oct 2008, 03:38
Location: Ann Arbor, MI
Model and Year: 850, 1996

Re: ABS light now on after battery disconnect

Postby jblackburn » 10 Dec 2010, 14:40

Once you check the wiring, just take it for a drive if you haven't yet since resetting the computer. The ABS system will automatically reset itself once you go over 20 mph and it determines everything's ok.
'98 S70 T5 218K miles
2012 Chevy Cruze LT 6MT


A learning experience is one of those things that says, "You know that thing you just did? Don't do that."

mercuic: Long live the tractor motor!
User avatar
jblackburn
MVS Moderator
MVS Moderator
 
Posts: 13631
Joined: 08 Jun 2008, 21:54
Location: Alexandria, VA
Model and Year: 1998 S70 T5

Re: ABS light now on after battery disconnect

Postby thecheat » 10 Dec 2010, 17:09

Obvious question here but did you reconnect the passenger airbag?
User avatar
thecheat
Forum Member
Forum Member
 
Posts: 533
Joined: 10 Jul 2010, 01:20
Location: Sunrise, FL
Model and Year: 1996 850 Turbo Wagon

Re: ABS light now on after battery disconnect

Postby johnnchrisr » 10 Dec 2010, 20:15

Thanks for the replies. I checked the harnesses and have driven about 12 miles at speeds up to 50 mph, but the light remains. TRACS light is not on, and ABS stays on (does not go off/come on). Before replacing the module, the ABS and TRACS lights coming on/going off was a symptom. The question about the airbag is an interesting one - yes, I did reconnect, but the ABS light coming on might have coincided with a marginally-connected ground strap when I was testing the bulbs before dash reassembly. I did not think the two were at all related, but could they be?
1998 S70 Base, Silver, 103k miles
2001 C70-C LT, Silver, 134k miles
johnnchrisr
New Member
New Member
 
Posts: 22
Joined: 07 Dec 2010, 23:04
Location: Pittsburgh, PA
Model and Year: S70 T5M, 1999

Re: ABS light now on after battery disconnect

Postby johnnchrisr » 10 Dec 2010, 20:28

And by "ground strap", I mean the one for the passenger airbag.
1998 S70 Base, Silver, 103k miles
2001 C70-C LT, Silver, 134k miles
johnnchrisr
New Member
New Member
 
Posts: 22
Joined: 07 Dec 2010, 23:04
Location: Pittsburgh, PA
Model and Year: S70 T5M, 1999

Re: ABS light now on after battery disconnect

Postby johnnchrisr » 30 Dec 2010, 03:03

In the interest of closing the loop, I'll let you all know what I discovered. Besides the ABS light staying illuminated, the left turn signal indicator didn't work, and neither did the rear fog light indicator. Thinking this was strange, I removed the dash cover again and voila - there it was - one of the three harness to the cluster not even plugged in (oops!). After plugging it back in, all is well.

Chris
1998 S70 Base, Silver, 103k miles
2001 C70-C LT, Silver, 134k miles
johnnchrisr
New Member
New Member
 
Posts: 22
Joined: 07 Dec 2010, 23:04
Location: Pittsburgh, PA
Model and Year: S70 T5M, 1999


Return to Volvo 850, S70, V70, C70 & V70-XC Forum (1992-2000)

Who is online

Users browsing this forum: A-Mer, Baptiste1106, erikv11, gmh, Google [Bot], JimBee, John91420, KBlue_V70, koffinb, paredown, quietcoolone, RigsPGT, rspi, RussB, ssama, Syd_c70, wjhandy850, Yahoo [Bot] and 114 guests