Entire right side speaker system not working

Help, Advice and DIY Tutorials on Volvo's extremely popular car line -- Volvo's 1990s "bread and butter" cars -- powered by the ubiquitous and durable Volvo inline 5-cylinder engine.
1992 - 1997 850, 850 R, 850 T5-R, 850 T5, 850 GLT
1997 - 2000 S70, S70 AWD
1997 - 2000 V70, V70 AWD
1997 - 2000 V70-XC
1997 - 2004 C70
Dagmar
Posts: 3
Joined: Wed Jan 05, 2011 10:22 pm
Year and Model: V70, 1998
Location: Georgia

Entire right side speaker system not working

Postby Dagmar » Wed Jan 05, 2011 10:32 pm

So, I removed my SC-816 stereo from my 1998 Volvo V70 wagon in a futile attempt to replace the bulbs since I was getting tired of turning on the interior lights to push a button on the radio at night. Long story short, I was not able to replace the bulbs and instead just reinstalled the radio and called it a day, telling myself I'd install an aftermarket when I got the chance.

However, upon powering the radio back on and entering the programming code I noticed my entire right side speaker system no longer worked. My left side however, all the way back to that tinny little speaker on the rear pillar by the hatch, worked perfectly. I removed the radio again and then reattached all the plugs as snugly as I could and still no sound out of the right side.

I only noticed 4 plugs in total to the back of my stereo, 2 wide multi-pin plugs with many colored wires coming out and then two antenna plugs. Am I missing one?

Did I blow an amp of some sort? If so, where is the amp for the right side? Any help would be much appreciated as I'm not too incredibly knowledgeable with car audio. :(

billy
Posts: 83
Joined: Sat Nov 06, 2010 11:29 am
Year and Model: 95 850 turbo
Location: florida-disney area

Re: Entire right side speaker system not working

Postby billy » Wed Jan 05, 2011 11:06 pm

Did you check to insure the" balance" was not accidentally changed with all the in and out action? "Balance" usually controls left to right sound and "fade" controls front to back to back sound. The two wide multi-pin- plugs you mentioned supply all the action you are speaking of.

FCPGroton
Posts: 2558
Joined: Wed Jun 17, 2009 3:57 pm
Year and Model: 2009 S60 2.5T
Location: Old Saybrook, CT
Flag: United States of America

Re: Entire right side speaker system not working

Postby FCPGroton » Wed Jan 05, 2011 11:52 pm

If it is not the balance, it could be the amp. Had the same issue on my 940 back in the day. The left side of the amp burned up on me.
Jason VanGorden
Volvo Product Manager
JasonV@FCPEURO.COM

Image
FCP Euro - European Car Parts Specialists
Quality & Service, Guaranteed for Life
155 Hill Street, Milford, CT 06460

Dagmar
Posts: 3
Joined: Wed Jan 05, 2011 10:22 pm
Year and Model: V70, 1998
Location: Georgia

Re: Entire right side speaker system not working

Postby Dagmar » Thu Jan 06, 2011 8:09 pm

Hey guys, just here to close this topic and show how stupid I can be sometimes. It was in fact, as mentioned, the balance. I was not aware I could even control the balance through the volume knob, with this being a new car and having a LOT more buttons than my previous vehicle, a '98 Chevy S10. Thank you very much though.


Return to “Volvo 850, S70, V70, C70 & V70-XC Forum (1992-2000)”

Who is online

Users browsing this forum: Bing [Bot], cuhfs, dyn blin, Google Adsense [Bot], shertzog, torslanda, Yahoo [Bot] and 60 guests