IPD - Volvo Parts SpecialistsVolvo PartsVolvo Salvage: Used Volvo Parts and Over 50 Years ExperienceSouthern Vo Vo sells genuine used Volvo parts

Please use this Amazon link ... and help keep MVS on the Web. Thank you!Amazon.com

Advertise here via Google

Login

Not part of the forums? Register. It's free.

Need help? See our Help Page.

trouble codes 410,133,&140. (secondary air & o2 sensor)

Help, Advice and DIY Tutorials on Volvo's extremely popular car line -- Volvo's 1990s "bread and butter" cars -- powered by the ubiquitous and durable Volvo inline 5-cylinder engine.
1992 - 1997 850, 850 R, 850 T5-R, 850 T5, 850 GLT
1997 - 2000 S70, S70 AWD
1997 - 2000 V70, V70 AWD
1997 - 2000 V70-XC
1997 - 2004 C70

trouble codes 410,133,&140. (secondary air & o2 sensor)

Postby pburnhamb » 13 Sep 2011, 19:35

so i have a 1998 v70 that has been throwing the check engine light on. i pulled codes 410 (secondary air system malfunction), 133 (o2 sensor ckt slow response ...bank 1 sensor1), and 140 (o2 sensor ckt no activity....bank 1 sensor2). i replaced the o2 sensor on the down pipe. i also took the computer out and soldred a rect dio between the 2 correct wires as described on a couple posts. i am still getting codes 410,133 & 140.......gulp. if i clear the odbII codes with the reader they come back and at the same time the "abs" and "tracs off" lights light up on the dash. where do i go from here (not the dealer). thank you all.-patrick-
pburnhamb
New Member
New Member
 
Posts: 20
Joined: 13 Sep 2011, 19:18
Location: connecticut usa
Model and Year: 1998 v70

Re: trouble codes 410,133,&140. (secondary air & o2 sensor)

Postby vjaneczko » 13 Sep 2011, 20:02

The ABS & TRACS lights usually come on when the ABS module fails, but never at the same time as the CEL - but it does sounds like you have two seperate issues (actually three).

ABS Module: Check Matty Moo's profile, who repairs the modules for a decent price. Also check for Ozark Lee's write-up on repairing it yourself if you're handy with a soldering iron.

SAS Delete: double-check the wiring you did. I've not done it (yet) but I'd be nervous about touching the wrong wire in there. Did you remove the parts related to the SAS or did you leave them in place? I'd yank 'em if you didn't.

O2 sensors; I'd take a look at them to see if they're coated with soot. It might also be time to replace them, but I don't think I've seen anyone post that they both go out at the same time. Any black, blue or white clouds coming from the tailpipe?
"He attacked everything in life with a mix of extraordinary genius and naive incompetence, and it was often difficult to tell which was which." - Douglas Adams

1997 855 GLT - Now for my daughter
2006 S60R - For ME!
User avatar
vjaneczko
Senior Forum Member
Senior Forum Member
 
Posts: 1514
Joined: 27 Mar 2006, 13:26
Location: Glen Ellyn, IL
Model and Year: '97 855 GLT;'06 S60R

Re: trouble codes 410,133,&140. (secondary air & o2 sensor)

Postby pburnhamb » 13 Sep 2011, 20:09

i did replace the front o2 sensor with a bosch one (the correct one) i cant find the link i used to do the ecu soldering job ...anone have it?? . but read in another link that there was some discrepencies as to which two pins needed the rectifier diode between them........as for te ABS thank you for the lead. i hate emissios checks. no smoke at tailpipe and runs well...???
pburnhamb
New Member
New Member
 
Posts: 20
Joined: 13 Sep 2011, 19:18
Location: connecticut usa
Model and Year: 1998 v70

Re: trouble codes 410,133,&140. (secondary air & o2 sensor)

Postby vjaneczko » 13 Sep 2011, 20:18

"He attacked everything in life with a mix of extraordinary genius and naive incompetence, and it was often difficult to tell which was which." - Douglas Adams

1997 855 GLT - Now for my daughter
2006 S60R - For ME!
User avatar
vjaneczko
Senior Forum Member
Senior Forum Member
 
Posts: 1514
Joined: 27 Mar 2006, 13:26
Location: Glen Ellyn, IL
Model and Year: '97 855 GLT;'06 S60R

Re: trouble codes 410,133,&140. (secondary air & o2 sensor)

Postby pburnhamb » 13 Sep 2011, 21:01

ok.thanks for sending that link. i used some other one that reqired me to solder one on A side and ne deep down on Bside. didnt work and wasnt easyto get at. just did it the way thelink above sad to A side to Aside. we will see how it works in the coming days. i will check into the abs issue now, though im not as concerned with it as the o2 issue and emissions in general as i need to get this thing registered so i dont have to drive it another year illegally.any ideas onthe o2 issues??? will report back, thank you much for help.
pburnhamb
New Member
New Member
 
Posts: 20
Joined: 13 Sep 2011, 19:18
Location: connecticut usa
Model and Year: 1998 v70

Re: trouble codes 410,133,&140. (secondary air & o2 sensor)

Postby turbozutek » 14 Sep 2011, 11:16

When a few separate computer controlled systems start acting up at once for seemingly no reason, I'm always tempted to check the battery voltage and charging voltage.

Low voltage = all sorts of electrical oddities. It's a quick check and worth doing maybe?

Chris...
turbozutek
Forum Member
Forum Member
 
Posts: 156
Joined: 14 Apr 2011, 12:11
Location: Glasgow
Model and Year: 1995 850 GLE

Re: trouble codes 410,133,&140. (secondary air & o2 sensor)

Postby pburnhamb » 16 Sep 2011, 20:24

ok, so soldering the rect diode like the link shows worked great. the only code i have now is p0133. o2sensor ckt slow response....#1 bank 1.....what does this mean.???? im gonna do some research on this site from later posts to see if any thing turns up. maybe start a new post if i dont find anything..???any ideas. im getting close to having no check engine light on i can feel it!. THANKS -patrick-
pburnhamb
New Member
New Member
 
Posts: 20
Joined: 13 Sep 2011, 19:18
Location: connecticut usa
Model and Year: 1998 v70

Re: trouble codes 410,133,&140. (secondary air & o2 sensor)

Postby frisby » 14 Nov 2013, 15:50

I have a 1998 Volvo V70 and I have a check engine light on. I was told it might have to do with the waste gate and the calibration. I have black soot coming from the tailpipe and the exhaust smells something awful. Any ideas on what it is and how to correct the problems would be greatly appreciated.
frisby
 
Posts: 1
Joined: 14 Nov 2013, 15:20
Location: usa
Model and Year: v70 1998

Re: trouble codes 410,133,&140. (secondary air & o2 sensor)

Postby vjaneczko » 14 Nov 2013, 16:00

Frisby, welcome to the forum.

There's a ton of reasons why the light is on, so you'll have to determine what code has been set to cause the CEL to go on. If you don't have an ODBII scanner, head over to an AutoZone, NAPA, or any other parts store and they'll most likely scan it for you. Once you get those codes, Google them or start a new thread and post them so we can point you in the right direction.
"He attacked everything in life with a mix of extraordinary genius and naive incompetence, and it was often difficult to tell which was which." - Douglas Adams

1997 855 GLT - Now for my daughter
2006 S60R - For ME!
User avatar
vjaneczko
Senior Forum Member
Senior Forum Member
 
Posts: 1514
Joined: 27 Mar 2006, 13:26
Location: Glen Ellyn, IL
Model and Year: '97 855 GLT;'06 S60R


Return to Volvo 850, S70, V70, C70 & V70-XC Forum (1992-2000)

Who is online

Users browsing this forum: allanweagle, Atis, Bing [Bot], fbfmcote, kahl, matthew1, mecheng, robbcolecrabtree, RSM-GA, RussB, whoa and 97 guests