battery not charging

Help, Advice, Owners' Discussion and DIY Tutorials on all Volvo's "mid era" rear wheel drive Volvos.
1975 - 1993 240
1983 - 1992 740
1982 - 1991 760
1986 - 1991 780
1990 - 1998 940
1990 - 1998 960
1997 - 1998 V90/S90
edwardstearly
Posts: 13
Joined: Fri Feb 25, 2011 4:13 am
Year and Model: 1995 850 NA
Location: sarasota, fl

battery not charging

Postby edwardstearly » Fri Feb 25, 2011 4:50 am

hi all, were looking for some help here ( wifes car ) 1993 240 4 cyl auto. we went out to start the car one morning and none of the gauges were working but it did start. she made it to work and when she came out it would not start. we installed several alternators, tested the battery and found it no to be charging but it tested fine. we were told that a relay was probably bad. we took the dash apart, my question is what relay should we consider replacing. the
e gauges aren't working and the battery is not charging, i think a bad relay or something is not allowing the alternator to charge the battery, i appreciate any thoughts and will answer any questions anyone may have.
thanks
95 850 NA
Automatic
125000

User avatar
jimmy57
Posts: 5240
Joined: Fri Nov 12, 2010 4:25 pm
Year and Model: 2004 V70R GT, et al
Location: Ponder Texas

Re: battery not charging

Postby jimmy57 » Fri Feb 25, 2011 5:10 am

The alternator will not start charging unless it has the circuit intact to warning lamp in instrument cluster (or if you rev engine up to 3000 rpm or more). Charging problem is not a problem when instrument cluster is fixed.
There is no relay associated with the instrument cluster on that car.
The first thing that comes to mind is corroded/broken/ blown fuse.
240'S are notorious for the ceramic body exposed conductor fuses having issues.
I would think removing the cluster and re-installing it would have remedied any connection problems at least temporarily.

edwardstearly
Posts: 13
Joined: Fri Feb 25, 2011 4:13 am
Year and Model: 1995 850 NA
Location: sarasota, fl

Re: battery not charging

Postby edwardstearly » Fri Feb 25, 2011 2:59 pm

thanks so much jimmy57, what you said makes perfect sense. we'll check it out and post our findings. i have a 95 850 and began experiencing headlight issues, after a look all the wires were cracked and chiped and shorting the lights out.
95 850 NA
Automatic
125000

edwardstearly
Posts: 13
Joined: Fri Feb 25, 2011 4:13 am
Year and Model: 1995 850 NA
Location: sarasota, fl

Re: battery not charging

Postby edwardstearly » Fri Feb 25, 2011 3:49 pm

it's something inside the cluster itself, cleaned all connections, and the same issue persists. the easiest way out is to replace the cluster but cant find one anywhere, not even in any junk yards have any. do you know of where i may find a cluster? the part number on the cluster is k40168. thanks.
95 850 NA
Automatic
125000


Return to “Volvo 240, 740, 760, 780, Bertone, 940, 960, V90, S90 Forum”

Who is online

Users browsing this forum: No registered users and 13 guests