Alarm problems

Help, Advice, Owners' Discussion and DIY Tutorials on Volvo's stylish, distinctive "P2" cars.
2001 - 2007 V70
2004 - 2007 V70 R
2001 - 2007 XC-70
2001 - 2009 S60
2003 - 2007 S60 R
g4gvb
Posts: 21
Joined: Sun Feb 20, 2011 4:55 pm
Year and Model: V70 2001
Location: Bognor Regis

Alarm problems

Postby g4gvb » Mon Mar 21, 2011 5:19 pm

Hi
Can anyone help. I brought the 2001 V70 two months ago, checked out the alarm all was OK, siren worked and everything. This morning got in the car and the red LED on the dash was flashing quickly, when I put the key in and turned it I got a message "Alarm been activated, check car" There was no sign of a problem. The car ran fine, Later this morning I used the car again, this time got the message "Alarm system requires a service" I had this message every time I started the engine, it went out after a few seconds.

When I got home I checked the codes, there wasn't any showing. I tried to check the alarm system by activating it while inside, no siren, also opening the bonnet, again no siren.

My question is it the alarm battery or the siren at fault or could it be something else? I was quoted by the stealers £130 for the unit + £31.50 labour + VAT

jda2000
Posts: 584
Joined: Thu Apr 01, 2010 11:22 pm
Year and Model: 04 V70 2.5T 01 V70T5
Location: Sarasota, FL

Re: Alarm problems

Postby jda2000 » Mon Mar 21, 2011 8:46 pm

open the alarm module and check the battery and the circuit board.

usually, the problem is that the battery leaks and destroys the circuit board.


Marlin
Posts: 6
Joined: Sun Mar 27, 2011 8:35 pm
Year and Model: V70 T5 2002
Location: England

Re: Alarm problems

Postby Marlin » Wed Mar 30, 2011 6:44 pm

I had the same problem with my V70 T5 last month,I removed the siren unit and cut it open and the batteries had corroded the circuit board,I found the cheapest option was to buy a complete alarm kit instead of just the siren .The complete kit was £95 and included all the rivets and a new bonnet switch,I got mine from M R KING VOLVO which has a shop on ebay.
The new unit was fitted and no dealer programming was required and now the alarm works perfect and the alarm system service message has reset itself .

g4gvb
Posts: 21
Joined: Sun Feb 20, 2011 4:55 pm
Year and Model: V70 2001
Location: Bognor Regis

Re: Alarm problems

Postby g4gvb » Sat Apr 02, 2011 6:39 pm

I had the dealers in Portsmouth do the job as I wanted the DRL turned off as well (£21 to turn off) They wanted to charge £156 for the siren, but when I said I would supply the kit that I could get for £91 they offered to match that price. They also did the job while I waited took about and hour altogether.

User avatar
brandonbeach14
Posts: 86
Joined: Mon Apr 04, 2011 12:15 am
Year and Model: 2.4T V70, 2001
Location: Folly Beach, SC

Re: Alarm problems

Postby brandonbeach14 » Tue Apr 05, 2011 1:50 am

I just bought a 01 V70 2 days ago. It in great shape with no issues other than it didn't come with the remotes. Today, I am now getting a "Alarm system requires service" message with no codes showing on a reader either. Any ideas? I haven'e decided if I want to spend $300 for a remote and programming at a dealer. Thanks

g4gvb
Posts: 21
Joined: Sun Feb 20, 2011 4:55 pm
Year and Model: V70 2001
Location: Bognor Regis

Re: Alarm problems

Postby g4gvb » Tue Apr 05, 2011 4:45 am

Based on my experience (which is minimal) I would say your alarm battery has gone, they seem to last about 10 years. Does the alarm work at all? You can get the Siren kit over here for about £91 (145 dollars) it takes about an hour to fit. Theres a post on here that shows you what you need to do, or you could take it to the shop.

User avatar
brandonbeach14
Posts: 86
Joined: Mon Apr 04, 2011 12:15 am
Year and Model: 2.4T V70, 2001
Location: Folly Beach, SC

Re: Alarm problems

Postby brandonbeach14 » Tue Apr 05, 2011 11:57 pm

Thanks I'll check it out. The lights flash when I lock it, but no siren chirp.

g4gvb
Posts: 21
Joined: Sun Feb 20, 2011 4:55 pm
Year and Model: V70 2001
Location: Bognor Regis

Re: Alarm problems

Postby g4gvb » Wed Apr 06, 2011 5:33 am

The lights flashed on mine, but there was no chirp, I don't think it does chirp. Even with the new unit in it does not chirp. Try arming the alarm then open the drivers door with the key, or open the window, arm the alarm wait 30 seconds then lean into the car through the window. When I did these tests on mine I got lights flashing, but no siren at all.

User avatar
brandonbeach14
Posts: 86
Joined: Mon Apr 04, 2011 12:15 am
Year and Model: 2.4T V70, 2001
Location: Folly Beach, SC

Re: Alarm problems

Postby brandonbeach14 » Sat Apr 09, 2011 2:20 am

Will do. Have you ever had a CEL code #0442 come up? "Evaporative Emission System Leak Detected (Small Leak)". I saw from other posts that it may be the j hose, but it was already replaced by the dealer. I just replaced the gas cap and reset the code. I am looking for any suggestions at this point if you're aware of any. Thanks again.


Return to “Volvo V70 & XC-70 (2001-2007), S60 (2001-2009)”

Who is online

Users browsing this forum: Bing [Bot] and 11 guests