Search found 44 matches

by xyourobob
Mon Jan 11, 2021 9:05 am
Forum: S60 2011+ and V60 2015+ and XC60 2010-2018
Topic: 2011 XC60 P0420 Code
Replies: 2
Views: 437

Re: 2011 XC60 P0420 Code

I ordered a new sensor for less than $100. It was fun removing the old one, heating it up with a propane torch did the trick. After installing the new sensor I disconnected the battery for 10 minutes to clear the code and so far so the engine light has remained off.
by xyourobob
Mon Jan 04, 2021 1:39 pm
Forum: S60 2011+ and V60 2015+ and XC60 2010-2018
Topic: 2011 XC60 P0420 Code
Replies: 2
Views: 437

Re: 2011 XC60 P0420 Code

Buzz!!!!
by xyourobob
Sat Jan 02, 2021 11:39 am
Forum: S60 2011+ and V60 2015+ and XC60 2010-2018
Topic: 2011 XC60 P0420 Code
Replies: 2
Views: 437

2011 XC60 P0420 Code

Happy New year to everyone. My 2011 XC60 T6 with 150K miles threw a P0420 code, my hand OBII wouldn't clear the code so I hooked up VIDA and sure enough the ECM fault code "Catalyst System Efficiency Below threshold (bank 1)" was there. Funny enough I was not able to delete the code using VIDA, most...
by xyourobob
Wed May 22, 2019 5:22 am
Forum: XC90 First Generation
Topic: 2004 XC90 Turbocharger issue
Replies: 13
Views: 1063

Re: 2004 XC90 Turbocharger issue

My bad, I had the turbos replaced. You are absolutly correct, the wastegate has a spot weld where it attaches to the turbo. It's a labor intensive job and it mades sense to do them both at the same time. The job was about $3500
by xyourobob
Mon May 20, 2019 6:50 pm
Forum: XC90 First Generation
Topic: 2004 XC90 Turbocharger issue
Replies: 13
Views: 1063

Re: 2004 XC90 Turbocharger issue

Sorry for the delay in responding to the thread. I ultimately took the car to an Indy and one of the turbo wastegate diaphram was shot, I had both turbo wastegates replaced and she is back running like new. Thanks for everyones feedback.
by xyourobob
Fri Mar 29, 2019 1:11 pm
Forum: XC90 First Generation
Topic: 2004 XC90 2.9 Rear End Issue
Replies: 6
Views: 434

Re: 2004 XC90 2.9 Rear End Issue

I ended up getting out the broken bolt via easyout, thanks for the feedback
by xyourobob
Fri Mar 29, 2019 9:01 am
Forum: XC90 First Generation
Topic: 2004 XC90 2.9 Rear End Issue
Replies: 6
Views: 434

Re: 2004 XC90 2.9 Rear End Issue

My rear wheel hub was seized. I broke the center wheel hub off in the axle because I must have gotten wrong info on torque. In any event how does the rear axle come out of the rear differential? And what is the correct torque for the center hub bolt?
by xyourobob
Fri Mar 29, 2019 6:32 am
Forum: XC90 First Generation
Topic: 2004 XC90 2.9 Rear End Issue
Replies: 6
Views: 434

Re: 2004 XC90 2.9 Rear End Issue

I pulled the disc off and put the wheel back on and she is still binding, parking breaks look good. I guess I will have to pull the hub now...not happily though
by xyourobob
Thu Mar 28, 2019 8:17 pm
Forum: XC90 First Generation
Topic: 2004 XC90 2.9 Rear End Issue
Replies: 6
Views: 434

2004 XC90 2.9 Rear End Issue

My 2004 XC90 2.9 started making a weird screeching/grinding noise and it sounds like it is coming from the drivers side rear. I jacked up the rear of the car and the drivers side rear tire does not spin freely however the passenger side does spin freely and I'm wondering if this is normal? I took th...
by xyourobob
Wed Mar 20, 2019 7:41 pm
Forum: S60 2011+ and V60 2015+ and XC60 2010-2018
Topic: 2011 XC60 Stuck in Park
Replies: 3
Views: 752

Re: 2011 XC60 Stuck in Park

Thanks for your advice Rick, I got home today to continue searching for the problem with my gear shift, I was going to over ride the shift so I could pull her closer to the garage but did not have to because she shifted without any problem. I hooked her up to Vida and no faults shown. I sprayed the ...