Search found 4 matches

by Josh08
Sat Jan 21, 2017 10:53 am
Forum: XC90 First Generation
Topic: Turn signals don't work.. but hazards do?
Replies: 7
Views: 3158

Re: Turn signals don't work.. but hazards do?

Hey roger awesome tutorial everything you said was spot on.. the contacts looked a little grimes so I used an eraser to clean them up. Looked shiny once I put everything back together but unfortunately, this did not solve the problem /: I was so sure this would work to the way the contacts looked bu...
by Josh08
Sat Jan 21, 2017 12:59 am
Forum: XC90 First Generation
Topic: Turn signals don't work.. but hazards do?
Replies: 7
Views: 3158

Re: Turn signals don't work.. but hazards do?

Hey Roger , pretty sure your right it seems to be the input side .. how would I go about fixing the turn signal stalk by chance ? Thanks so much for the help I'm kinda lost and not so familiar with this /:
by Josh08
Sat Jan 07, 2017 8:38 pm
Forum: XC90 First Generation
Topic: Turn signals don't work.. but hazards do?
Replies: 7
Views: 3158

Re: Turn signals don't work.. but hazards do?

Haven't tried playing with the contacts .. going to give this a try, thank you !
by Josh08
Fri Jan 06, 2017 6:23 pm
Forum: XC90 First Generation
Topic: Turn signals don't work.. but hazards do?
Replies: 7
Views: 3158

Turn signals don't work.. but hazards do?

Hello recently purchased a 2004 XC90 t6 , replaced the head gasket and it's running great . Only problem is the turn signals aren't working. Checked the hazards and they work fine. Also if it helps the reverse lights work and the windshield wipers work.. not sure if it's a flashing relay or a cem?.....