IPD sale XeMODeX - Experts in Volvo Electronics

Search found 396 matches

by XC70Rider
Mon Jul 01, 2019 8:42 am
Forum: Volvo V70 & XC-70 2001-2007, S60 2001-2009
Topic: DEM-0001 AWD Not Working
Replies: 48
Views: 1415
United States of America

Re: DEM-0001 AWD Not Working

You may need to split the DEM and solder the socket - it is mechanically attached as of now, and is not very tight. I knew I could of damaged the sensor terminals on that socket when I broke the sensor. I cleaned both terminals with CRC Electronic Cleaner and added in a small tab of dielectric grea...
by XC70Rider
Mon Jul 01, 2019 8:27 am
Forum: Volvo V70 & XC-70 2001-2007, S60 2001-2009
Topic: DEM-0001 AWD Not Working
Replies: 48
Views: 1415
United States of America

Re: DEM-0001 AWD Not Working

When I hooked up VIDA yesterday I got the DEM-0007 code. I cleared the code then drove her for a mile. The AWD worked and the code never returned. Wouldn't this code clear itself after I fixed the issue when firmly inserting the pump harness into the DEM? It might. When the code becomes inactive, V...
by XC70Rider
Mon Jul 01, 2019 8:17 am
Forum: Volvo V70 & XC-70 2001-2007, S60 2001-2009
Topic: DEM-0001 AWD Not Working
Replies: 48
Views: 1415
United States of America

Re: DEM-0001 AWD Not Working

With "Oil ring" are you referring to the seal between the damper and Haldex? I replaced that seal when I threw on a new damper. I've read there is a weep hole on the bottom where the Haldex and Final drive gasket mate. No, I meant the oil will leak through the seal and will be thrown by the rotatin...
by XC70Rider
Mon Jul 01, 2019 7:24 am
Forum: Volvo V70 & XC-70 2001-2007, S60 2001-2009
Topic: DEM-0001 AWD Not Working
Replies: 48
Views: 1415
United States of America

Re: DEM-0001 AWD Not Working

When I hooked up VIDA yesterday I got the DEM-0007 code. I cleared the code then drove her for a mile. The AWD worked and the code never returned. Wouldn't this code clear itself after I fixed the issue when firmly inserting the pump harness into the DEM?
by XC70Rider
Mon Jul 01, 2019 7:23 am
Forum: Volvo V70 & XC-70 2001-2007, S60 2001-2009
Topic: DEM-0001 AWD Not Working
Replies: 48
Views: 1415
United States of America

Re: DEM-0001 AWD Not Working

After filling it to the dripping point you have to suck out 100 ml or so, otherwise it will leak through the seal. Do you have a typical "oil ring" on the chassis around the flange? This is the oil thrown up through the seal. With "Oil ring" are you referring to the seal between the damper and Hald...
by XC70Rider
Sun Jun 30, 2019 10:15 am
Forum: Volvo V70 & XC-70 2001-2007, S60 2001-2009
Topic: DEM-0001 AWD Not Working
Replies: 48
Views: 1415
United States of America

Re: DEM-0001 AWD Not Working

Not only had to mount the connector but I added 70ml of Hakdex fluid last week to get the pump working. I presumed it was low from not bleeding it. Well the DEM-007 code came back yesterday. Theres no external leaking and the pump is connected to the DEM. Didn't have time to check Haldex level befo...
by XC70Rider
Sat Jun 29, 2019 8:56 am
Forum: Volvo V70 & XC-70 2001-2007, S60 2001-2009
Topic: DEM-0001 AWD Not Working
Replies: 48
Views: 1415
United States of America

Re: DEM-0001 AWD Not Working

Haven't removed the pump since installing new oscillation damper last April. Pump and filter have new o-rings and a new seal for the damper.

If its low in fluid again then I'll fill it up and charge pump alone for several minutes. I'll peak at the DEM to see if the sensor or valve are leaking.
by XC70Rider
Sat Jun 29, 2019 7:52 am
Forum: Volvo V70 & XC-70 2001-2007, S60 2001-2009
Topic: DEM-0001 AWD Not Working
Replies: 48
Views: 1415
United States of America

DEM-0007

Not only had to mount the connector but I added 700ml of Hakdex fluid last week to get the pump working. I presumed it was low from not bleeding it. Well the DEM-007 code came back yesterday. Theres no external leaking and the pump is connected to the DEM. Didn't have time to check Haldex level befo...
by XC70Rider
Fri Jun 28, 2019 10:02 am
Forum: Volvo V70 & XC-70 2001-2007, S60 2001-2009
Topic: 2003 XC70 - Loss of rear wheel drive (FWD only, AWD not working)
Replies: 22
Views: 3578
United States of America

Re: 2003 XC70 - Loss of rear wheel drive (FWD only, AWD not working)

..... Not too cheap, but you can get one for VW for 1/2 of price. Also driveshaft is bad too because of age and mileage, it needs a new CV joints and at least a new rubber around center bearing. P3 is worse than P2 all around, honestly. What's the VW matching AOC oil pump for our P2s? The cheapest ...
by XC70Rider
Thu Jun 27, 2019 4:41 pm
Forum: Volvo V70 & XC-70 2001-2007, S60 2001-2009
Topic: Engine Temperature Increase after Water Pump, Thermostat and Coolant replacement
Replies: 21
Views: 791
United States of America

Re: Engine Temperature Increase after Water Pump, Thermostat and Coolant replacement

Driving with the OEM unit back on it opened at 192F on highway with A/C running. It then dropped to 188F and stayed there for the remaining 40min drive. The Beck Arnley valve would constantly open and close. The IAT also held more steady at 104f on highway. During city traffic it reached 138f max. I...