Welcome to the world's #1 Volvo forum!

Volvo Fixes & Advice since 2001.

Login Register

Search found 163 matches

by lcc014
Wed Feb 26, 2020 8:11 am
Forum: 850 and S70, V70, C70, V70-XC 1992-2000
Topic: Rattling/Metal Noise when stepping on gas pedal
Replies: 11
Views: 371

Re: Rattling/Metal Noise when stepping on gas pedal

I drove the car onto ramp and checked around under the front of the car. Nothing loose. The heat shield above converter was tight. Then I started the car while car was on ramp and heard the noise of exhaust was not quite "right/normal". Sound like a leak but not very loud. Then I drove the car last ...
by lcc014
Sun Feb 23, 2020 4:00 pm
Forum: 850 and S70, V70, C70, V70-XC 1992-2000
Topic: Rattling/Metal Noise when stepping on gas pedal
Replies: 11
Views: 371

Re: Rattling/Metal Noise when stepping on gas pedal

Thank you for the suggestion. Brake backing plates are all gone on both side of the front brake for a long while. So, I will put the car on ramp to check for any loose heat shield.

Ching-Ho Cheng
by lcc014
Sat Feb 22, 2020 8:16 pm
Forum: 850 and S70, V70, C70, V70-XC 1992-2000
Topic: Rattling/Metal Noise when stepping on gas pedal
Replies: 11
Views: 371

Rattling/Metal Noise when stepping on gas pedal

Starting from yesterday driving home from work, I heard a rattling/metal noise from the front. Whenever I accelerated the car, noise happened. When my foot off gas pedal, noise disappear immediately. It wasn't that loud yesterday afternoon. Today, it became more louder whenever I stepped on gas peda...
by lcc014
Sun Nov 03, 2019 6:16 am
Forum: 850 and S70, V70, C70, V70-XC 1992-2000
Topic: 1995 855 NA ntermittant Hard Start Issue, no crank
Replies: 12
Views: 281

Re: 1995 855 NA ntermittant Hard Start Issue, no crank

Replaced ignition switch yesterday morning, so far so good. Also, checked the starter cable, no problem too. I will keep an eye on this issue.

Thanks,

Ching-Ho Cheng
by lcc014
Wed Oct 30, 2019 1:15 pm
Forum: 850 and S70, V70, C70, V70-XC 1992-2000
Topic: 1995 855 NA ntermittant Hard Start Issue, no crank
Replies: 12
Views: 281

Re: 1995 855 NA ntermittant Hard Start Issue, no crank

Thank you for the information, I will check that cable too.

Thanks,

Ching-Ho Cheng
by lcc014
Wed Oct 30, 2019 6:38 am
Forum: 850 and S70, V70, C70, V70-XC 1992-2000
Topic: 1995 855 NA ntermittant Hard Start Issue, no crank
Replies: 12
Views: 281

Re: 1995 855 NA ntermittant Hard Start Issue, no crank

Park or Neutral with an Automatic, correct. I didn't know the bypass does NOT bypass the PNP switch, so I learned something here. It DOES bypass the clutch safety switch on Manual transmissions. I would put it in Park, handbrake on, chock wheels. Thank you for the confirmation. Ching-Ho Cheng
by lcc014
Wed Oct 30, 2019 6:36 am
Forum: 850 and S70, V70, C70, V70-XC 1992-2000
Topic: 1995 855 NA ntermittant Hard Start Issue, no crank
Replies: 12
Views: 281

Re: 1995 855 NA ntermittant Hard Start Issue, no crank

Possible sources: Alarm/Start inhibitor relay. Internal contacts worn. <--- not sure about this one, my car equips with Volvo 1st gen. alarm Range sensor on transmission (PnP switch) worn contacts. <--- PNP was installed along with tranny back in 2009 at 218xxx miles Starter solenoid sticking, poor...
by lcc014
Wed Oct 30, 2019 6:04 am
Forum: 850 and S70, V70, C70, V70-XC 1992-2000
Topic: 1995 855 NA ntermittant Hard Start Issue, no crank
Replies: 12
Views: 281

Re: 1995 855 NA ntermittant Hard Start Issue, no crank

Possible sources: Alarm/Start inhibitor relay. Internal contacts worn. Range sensor on transmission (PnP switch) worn contacts. Starter solenoid sticking, poor connection. Poor connection anywhere in the starting system. When was the last time you cleaned the battery terminals? Lower left hand corn...
by lcc014
Tue Oct 29, 2019 7:08 pm
Forum: 850 and S70, V70, C70, V70-XC 1992-2000
Topic: 1995 855 NA ntermittant Hard Start Issue, no crank
Replies: 12
Views: 281

Re: 1995 855 NA ntermittant Hard Start Issue, no crank

Thank you for the prompt response and suggestion. Ignition switch was replaced back in 2010 September (about 234xxx miles). The replacement of ignition switch was due to no headlight when my daughter turned on headlight at the evening in highway. Once I replaced the switch, no more headlight issue. ...