IPD sale Volvo Parts
XeMODeX - Experts in Volvo Electronics Volvo Wholesale Parts - genuine Volvo parts
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

Issue Resolved - Car won't stay running - VIDEO added

Help, Advice and DIY Tutorials on Volvo's extremely popular car line -- Volvo's 1990s "bread and butter" cars -- powered by the ubiquitous and durable Volvo inline 5-cylinder engine.

1992 - 1997 850, 850 R, 850 T5-R, 850 T5, 850 GLT
1997 - 2000 S70, S70 AWD
1997 - 2000 V70, V70 AWD
1997 - 2000 V70-XC
1997 - 2004 C70

mrreilly
Posts: 259
Joined: Thu Aug 03, 2006 8:53 pm
Year and Model: 1998 Volvo S70 GLT
Location: Notheast, Ohio
Has thanked: 0
Been thanked: 0
mrreilly

Re: Urgent! Car won't stay running

Post by mrreilly » Sun Dec 19, 2010 11:30 am

Ok, now that we have the whole alternator issue cleared up.. lol

What should I do about my car? I made the mistake in thinking it was the MAF sensor. That code came up because I had taken it off and tried running the car as suggested to me. So I'm going to clear that code and try again.
I still need help in figuring out what to do. Could the alternator still be the issue?

I have about three weeks to clear this issue up before I have to head back to school. :s


1998 Volvo S70 GLT Black/Tan
Approx. 173,000 3/27/2010
My major repairs:
Timing Belt, Left&Right Control Arms, Tie-rod ends, Lower Engine Mount, Engine Stabilizer Mount, IPD Sway Bar Links, Brakes , Head Gasket, PCV System, Turbo Rebuild, and more

mrreilly
Posts: 259
Joined: Thu Aug 03, 2006 8:53 pm
Year and Model: 1998 Volvo S70 GLT
Location: Notheast, Ohio
Has thanked: 0
Been thanked: 0
mrreilly

Re: Urgent! Car won't stay running

Post by mrreilly » Sun Dec 19, 2010 1:17 pm

Update:
Here's the most current situation:
1. I've checked to make sure the battery is properly connected and cleaned the terminals and wires.
2. I put the MAF back on and ran the car for a little bit.
3. Checked for codes - No Code came up
4. After sitting in the car with my foot on the gas, I let off the gas and the car stopped running as it has been doing. When it stopped running, the battery light, oil light, and check engine light were all lit up. Does that tell me anything? In addition to that the "Arrow" light came which I assume means something with the transmission.
5. I Just just checked the alternator and it's doing just what it should be.
Suggestions? Fuel pump not putting out right? Clogged up vacuum hose?


1998 Volvo S70 GLT Black/Tan
Approx. 173,000 3/27/2010
My major repairs:
Timing Belt, Left&Right Control Arms, Tie-rod ends, Lower Engine Mount, Engine Stabilizer Mount, IPD Sway Bar Links, Brakes , Head Gasket, PCV System, Turbo Rebuild, and more

mrreilly
Posts: 259
Joined: Thu Aug 03, 2006 8:53 pm
Year and Model: 1998 Volvo S70 GLT
Location: Notheast, Ohio
Has thanked: 0
Been thanked: 0
mrreilly

Re: Urgent! Car won't stay running - VIDEO added

Post by mrreilly » Mon Dec 20, 2010 9:45 pm



Just listen to how the engine tries to start up maybe it might help?


1998 Volvo S70 GLT Black/Tan
Approx. 173,000 3/27/2010
My major repairs:
Timing Belt, Left&Right Control Arms, Tie-rod ends, Lower Engine Mount, Engine Stabilizer Mount, IPD Sway Bar Links, Brakes , Head Gasket, PCV System, Turbo Rebuild, and more

mrreilly
Posts: 259
Joined: Thu Aug 03, 2006 8:53 pm
Year and Model: 1998 Volvo S70 GLT
Location: Notheast, Ohio
Has thanked: 0
Been thanked: 0
mrreilly

Re: Issue Resolved - Car won't stay running - VIDEO added

Post by mrreilly » Tue Dec 21, 2010 5:12 pm

Issue has been resolved.
Turns out the engine had to 'relearn' how to do what it's supposed to. It's idling normally now.
God figure it's something simple like that.
Thanks for everyone's help.


1998 Volvo S70 GLT Black/Tan
Approx. 173,000 3/27/2010
My major repairs:
Timing Belt, Left&Right Control Arms, Tie-rod ends, Lower Engine Mount, Engine Stabilizer Mount, IPD Sway Bar Links, Brakes , Head Gasket, PCV System, Turbo Rebuild, and more

park1013
Posts: 10
Joined: Mon Apr 30, 2012 2:52 pm
Year and Model: 1999 s70
Location: US
Has thanked: 0
Been thanked: 0
park1013

Re: Issue Resolved - Car won't stay running - VIDEO added

Post by park1013 » Mon Apr 30, 2012 6:00 pm

Can someone please help me with the solution to this? I have the same problem.... 1999 s70 160000 2.4L non turbo, will crank for about a min on first try then stall out and gets shorter each time tried soon after. Also, after stall the oil, battery and upward arrow dash lights come one. Please help, thanks in advance...



Post Reply