IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

Electrical issue...

Help, Advice and DIY Tutorials on Volvo's extremely popular car line -- Volvo's 1990s "bread and butter" cars -- powered by the ubiquitous and durable Volvo inline 5-cylinder engine.

1992 - 1997 850, 850 R, 850 T5-R, 850 T5, 850 GLT
1997 - 2000 S70, S70 AWD
1997 - 2000 V70, V70 AWD
1997 - 2000 V70-XC
1997 - 2004 C70

mrreilly
Posts: 259
Joined: Thu Aug 03, 2006 8:53 pm
Year and Model: 1998 Volvo S70 GLT
Location: Notheast, Ohio
Has thanked: 0
Been thanked: 0
mrreilly

Electrical issue...

Post by mrreilly » Thu Feb 10, 2011 7:39 pm

Hey all,
My car has been starting really hard lately with the below 10degree tepms we've been having which I've experience in years past. But then my battery had drained after sitting for about 7 or 8 hours while I was in classes. I jumped it and then drove it for a good 45 minutes on the highway and reg. roads. I figured it would be all well and good this morning but no such luck. It was dead again and I barely got a crank out of it. So this evening I gave it another jump and it started right up. I ran for about 5 minutes and as I was packing up the jumper cables I heard a click and the car died again. There is ZERO power to my car. No lights, locks, dash, nothing.
This is a New Battery. No more that 2 months old. I plan on taking it back to auto zone and having them test it.
But is the battery even the issue? Could this be an alternator? I'm sure the cold isn't helping at all..
What's going on here??

Thanks

Mike


1998 Volvo S70 GLT Black/Tan
Approx. 173,000 3/27/2010
My major repairs:
Timing Belt, Left&Right Control Arms, Tie-rod ends, Lower Engine Mount, Engine Stabilizer Mount, IPD Sway Bar Links, Brakes , Head Gasket, PCV System, Turbo Rebuild, and more

vjaneczko
Posts: 1544
Joined: Mon Mar 27, 2006 6:26 am
Year and Model: 2006 S60R
Location: Austin, TX
Has thanked: 0
Been thanked: 2 times
United States of America
vjaneczko

Re: Electrical issue...

Post by vjaneczko » Thu Feb 10, 2011 7:55 pm

Battery could be bad, so have AutoZone to a peek at it.

Other than that, are there any electrical devices that aren't working properly? There might be a short related to something...


"He attacked everything in life with a mix of extraordinary genius and naive incompetence, and it was often difficult to tell which was which." - Douglas Adams

1997 855 GLT - R.I.P.
2006 S60R - For ME!

mrreilly
Posts: 259
Joined: Thu Aug 03, 2006 8:53 pm
Year and Model: 1998 Volvo S70 GLT
Location: Notheast, Ohio
Has thanked: 0
Been thanked: 0
mrreilly

Re: Electrical issue...

Post by mrreilly » Thu Feb 10, 2011 8:46 pm

I'm going to take it in tomorrow. I hope it's just the battery..


1998 Volvo S70 GLT Black/Tan
Approx. 173,000 3/27/2010
My major repairs:
Timing Belt, Left&Right Control Arms, Tie-rod ends, Lower Engine Mount, Engine Stabilizer Mount, IPD Sway Bar Links, Brakes , Head Gasket, PCV System, Turbo Rebuild, and more

Post Reply