IPD sale XeMODeX - Experts in Volvo Electronics

Get email notification of topic replies. Log in or register (free). Amazon Link Buy anything with this and it helps MVS!

Cabin fan runs continuously but no heat or a/c?

Help, Advice and DIY Tutorials on Volvo's extremely popular car line -- Volvo's 1990s "bread and butter" cars -- powered by the ubiquitous and durable Volvo inline 5-cylinder engine.

1992 - 1997 850, 850 R, 850 T5-R, 850 T5, 850 GLT
1997 - 2000 S70, S70 AWD
1997 - 2000 V70, V70 AWD
1997 - 2000 V70-XC
1997 - 2004 C70

a73s
Posts: 29
Joined: Wed Feb 25, 2015 2:53 pm
Year and Model: 850T 1995
Location: illinois

Re: Cabin fan runs continuously but no heat or a/c?

Post by a73s »

Neil & Erik,
Thanks again for all the input!
Well, I pulled the glove box out and all the rest of the stuff (Scott, the cursing was the easiest part....!) and got in to the blower motor. I pulled it out, gave it a bit of a dusting, and wired it into the car battery..... and it works, spins nicely!
So, I then examined all the wiring and connectors and nothing seems frayed, or kinked / disconnected that I could see. I turned on the car and nothing...same as before, no fan, no flashing lights on the ECC, and I even tried to get the codes from the OBD in the engine, but the B1 just glows continuously red...all same as before.
I think I may try to get another ECC power stage, and see if that's the problem....? What do you think?
Thanks again,
Alan.
scot850
Posts: 6259
Joined: Mon Apr 05, 2010 2:46 pm
Year and Model: 2000 V70 R
Location: Calgary, Alberta, Canada
Has thanked: 21 times
Been thanked: 262 times

Re: Cabin fan runs continuously but no heat or a/c?

Post by scot850 »

The fan motor may turn easily when out of the car, but did you check the fan cage and if it can move up and down the motor shaft. Actually it is not going up and down the shaft, the shaft is moving in the bearings. If this is not tight then the motor may well be binding. If it is tight, then some light oil on the bearings and it should be good to go.

Does the fan motor work when you set the fan speed manually rather than in Auto?

If it is not working at all then it could be a fuse or the resistor pack as most call it.

You will then have eliminated the fan motor and ECC. Having said that, I was helping someone else recently and they replaced their ECC with at least one or 2 before they got a good one. If you still have the original ECC have you tried putting it back in to see if anything changes?

Did you clean the cabin temp sensors?

Neil.
2000 V70 R - still being an endless PITA
2006 XC70
2003 Toyota 4Runner V8 Limited
2015 Kia Sportage EX-L
1993 850 GLT -Sold
1998 V70 XC - Sold
1997 Volvo 850 SE NA - Went to niece in California - Sold
2000 V70 SE NA - New project and test bed - Sold
a73s
Posts: 29
Joined: Wed Feb 25, 2015 2:53 pm
Year and Model: 850T 1995
Location: illinois

Re: Cabin fan runs continuously but no heat or a/c?

Post by a73s »

scot850 wrote:The fan motor may turn easily when out of the car, but did you check the fan cage and if it can move up and down the motor shaft. Actually it is not going up and down the shaft, the shaft is moving in the bearings. If this is not tight then the motor may well be binding. If it is tight, then some light oil on the bearings and it should be good to go.

Does the fan motor work when you set the fan speed manually rather than in Auto?

If it is not working at all then it could be a fuse or the resistor pack as most call it.

You will then have eliminated the fan motor and ECC. Having said that, I was helping someone else recently and they replaced their ECC with at least one or 2 before they got a good one. If you still have the original ECC have you tried putting it back in to see if anything changes?

Did you clean the cabin temp sensors?

Neil.
Neil,
The cage (yellow plastic cage / blower?) is attached really solidy to the motor and was attached when I ran the current from the battery so I think that 's good.I did put some oil on it.
Fan doesn't work on AUT or manual. Fuse is good.
I think power stage (is that what you mean by "resistor pack") is the next possibility.....I will try to swap out the "new" ECC I got and put back in the old one....maybe the junkyard ECC is broken? Any other way to check the ECC......too bad my OBD I "B1" port seems to be broken too...

Thanks again,
Alan.
scot850
Posts: 6259
Joined: Mon Apr 05, 2010 2:46 pm
Year and Model: 2000 V70 R
Location: Calgary, Alberta, Canada
Has thanked: 21 times
Been thanked: 262 times

Re: Cabin fan runs continuously but no heat or a/c?

Post by scot850 »

Never seen a yellow blower cage, interesting. Strange about the port. Maybe there is a short in the system causing is to be reading a constant value?

power stage = resistor pack

Try the ECC swap back and see if status changes. Like I said, maybe junkyard ECC is also duff.

Neil
2000 V70 R - still being an endless PITA
2006 XC70
2003 Toyota 4Runner V8 Limited
2015 Kia Sportage EX-L
1993 850 GLT -Sold
1998 V70 XC - Sold
1997 Volvo 850 SE NA - Went to niece in California - Sold
2000 V70 SE NA - New project and test bed - Sold
a73s
Posts: 29
Joined: Wed Feb 25, 2015 2:53 pm
Year and Model: 850T 1995
Location: illinois

Re: Cabin fan runs continuously but no heat or a/c?

Post by a73s »

another....UPDATE!
Well, got a (used) power stage, installed that and same thing......no joy!
At this point I think maybe the (junk / replacement) ECC is no good. I'm trying to get another one...
So far my conclusions are....
ECC...could be the problem
Blower...seems to be good, I took it out lubed it etc AND it randomly comes on when I start the car and WON'T turn off until I turn off the car (unlike other posters here it never stays on after the engine is shut down.)
Power stage.....replaced this but didn't make any difference...could be a dud replacement but I feel like the ECC is most likely the issue
Codes.....can't get the codes because for some reason my OBD (box in engine compartment) doesn't light up at all for the B1 port

I'll let you know when I get a solution.

Alan
a73s
Posts: 29
Joined: Wed Feb 25, 2015 2:53 pm
Year and Model: 850T 1995
Location: illinois

Re: Cabin fan runs continuously but no heat or a/c?

Post by a73s »

OK finally...good news!
Turns out the problem was a bad ECC (the used one I bought); I got a second one and everything works fine now......and tearing up the glove box to get in to the blower and power stage, turns out I didn't need to do that at all.....but it's all character building!!

One curious thing is that I thought there were only two types of climate control units, ECC or manual (with 4 fan positions etc). The one for my 850 is the ECC, but I noticed on the replacement ECC that wouldn't work, it had a small button on the bottom that my original one didn't have and a strip of black plastic. The button is just a small plastic piece that could push in to the ECC base (see photos). The second replacement I got didn't have this either (and that one worked in the car.)
Does anyone know what the button is far? Is this unit not compatible with the 850 ('95) model?
Thanks,
Alan.
Attachments
20160602_ecc_005.jpg
20160602_ecc_005.jpg (89.13 KiB) Viewed 449 times
ECC that was originally in my 850
ECC that was originally in my 850
20160602_ecc_003.jpg (130.11 KiB) Viewed 449 times
close up of button on base of ECC
close up of button on base of ECC
20160602_ecc_002.jpg (129.26 KiB) Viewed 449 times
ECC on left has black button
ECC on left has black button
20160602_ecc_001.jpg (92.7 KiB) Viewed 449 times
User avatar
abscate
MVS Moderator
Posts: 22453
Joined: Sun Feb 17, 2013 5:54 pm
Year and Model: 99T5 ,99S70,2005V70
Location: NYC, ALBANY NY
Has thanked: 375 times
Been thanked: 1166 times

Re: Cabin fan runs continuously but no heat or a/c?

Post by abscate »

Probably a support to stop from touching the stereo head unit, perhaps ground loop prevention?

It doesn't look terribly important
Empty Nester
A Captain in a Sea of Estrogen
1999-V70-T5M56 2005-V70-M56 1999-S70 VW T4 BMW
Link to Maintenance record thread
Link To Volvo Glossary
Post Reply
  • Similar Topics
    Replies
    Views
    Last post