IPD sale XeMODeX - Experts in Volvo Electronics Free shipping all USA - Experts in Brakes
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

Rough Idle - Limp home mode

Help, Advice and DIY Tutorials on Volvo's extremely popular car line -- Volvo's 1990s "bread and butter" cars -- powered by the ubiquitous and durable Volvo inline 5-cylinder engine.

1992 - 1997 850, 850 R, 850 T5-R, 850 T5, 850 GLT
1997 - 2000 S70, S70 AWD
1997 - 2000 V70, V70 AWD
1997 - 2000 V70-XC
1997 - 2004 C70

spott
Posts: 7
Joined: Tue Apr 26, 2011 7:35 pm
Year and Model: 2000 S70
Location: Austin, Tx
Has thanked: 0
Been thanked: 0
spott

Rough Idle - Limp home mode

Post by spott » Sat Sep 17, 2016 7:59 pm

2000 S70 - Turbo

Past History:
Car drove fine. Had an intermittent ETS light & Check Engine Light (P0422- went away on its own, P1332- see below). No change in drivability or other symptoms. Ran this way flawlessly for quite a while, so I didn't worry about it.
Had a coolant leak, so I replaced the coolant reservoir tank. The coolant level sensor fell out during this process. This is probably irrelevant, but IDK.

Recent History:
Car drove 40 min trip home fine. Stopped for gas, and on startup it went into 'limp home mode'. It idled rough, RPMs were jumpy.
The only code, at that time, was P1332. So, had a mechanic friend replace the CVVT solenoid. The part was replaced, but battery was drained. Took the battery to a local parts shop, was told battery was fine & it was recharged. Drove it once for about 20 min. and it was fine. The next day, it was a little rough on startup. Drove it to a store about 5 miles away & was fine. On next startup, back to the rough idle and limp home mode.

No codes or check engine lights now. I've been suspicious of the ETS/ETM, so I replaced the Mass Airflow Sensor. Unfortunately, there was no change. It idles rough and I have to floor it to keep it from stalling out. The lights dim with RPM dips, and the swing in RPM seems greater.
I don't really want to replace the ETM without knowing for sure. It would be pricy gamble.

Any thoughts?
Last edited by spott on Mon Sep 19, 2016 8:42 pm, edited 2 times in total.

beigg
Posts: 691
Joined: Sun Sep 22, 2013 9:07 am
Year and Model: 850 97
Location: Est. Mi
Has thanked: 0
Been thanked: 0
Uruguay
beigg

Re: Rough Idle - Limp home mode

Post by beigg » Sat Sep 17, 2016 8:13 pm

Whats the alternator reading during idle?
ugh smh 850 Turbo fridge

spott
Posts: 7
Joined: Tue Apr 26, 2011 7:35 pm
Year and Model: 2000 S70
Location: Austin, Tx
Has thanked: 0
Been thanked: 0
spott

Re: Rough Idle - Limp home mode

Post by spott » Mon Sep 19, 2016 5:39 pm

So, I hooked up a voltmeter to the battery after the car had been off more than 24 hours. The readout was 12.55V.
Started it up and the ETS light was on, still no codes.
The readout of the battery fluctuated between 13.8-13.9V. Turned on the radio and cranked the heater, battery read 13.5-13.8V.
The drops in volts seem to correspond to the RPM fluctuations.
I didn't hook up the voltmeter to the alternator itself.

User avatar
misha
Posts: 4133
Joined: Sun Dec 07, 2008 4:09 pm
Year and Model: '97 850 2.5 20v
Location: Serbia
Has thanked: 46 times
Been thanked: 107 times
Serbia
misha

Re: Rough Idle - Limp home mode

Post by misha » Mon Sep 19, 2016 6:51 pm

spott wrote:...Started it up and the ETS light was on, still no codes.
You allready answered your question.
It seems that etm is on it's way out.

You posted on the wrong forum....administrators will transfer this topic to a proper one and you will get more accurate answers.
'97 850 2.5 20v / fully equipped / Motronic 4.4 from the factory / upgraded with S,V,C,XC70 instrument cluster / polar white wagon
'91 Citroen XM 2.0 SI /fully equipped/mandarine red metallic
History of Volvos in the family:
'71 144 S
'73 144 De Luxe
'78 244 DL
'78 244 DL
'79 244 GLE
'85 340 GLS

spott
Posts: 7
Joined: Tue Apr 26, 2011 7:35 pm
Year and Model: 2000 S70
Location: Austin, Tx
Has thanked: 0
Been thanked: 0
spott

Re: Rough Idle - Limp home mode

Post by spott » Mon Sep 19, 2016 8:41 pm

Thanks misha.
(Sorry, I originally typed V70, when I meant S70. I need more sleep. I edited my original post to reflect this.)

Post Reply
  • Similar Topics
    Replies
    Views
    Last post