IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy anything with this and it helps MVS!

2000 S70 2.4 Erratic Injector Pulse Topic is solved

Help, Advice and DIY Tutorials on Volvo's extremely popular car line -- Volvo's 1990s "bread and butter" cars -- powered by the ubiquitous and durable Volvo inline 5-cylinder engine.

1992 - 1997 850, 850 R, 850 T5-R, 850 T5, 850 GLT
1997 - 2000 S70, S70 AWD
1997 - 2000 V70, V70 AWD
1997 - 2000 V70-XC
1997 - 2004 C70

fastcars1173
Posts: 6
Joined: Wed Sep 28, 2016 12:29 pm
Year and Model: 2000 S70
Location: S. Florida
Has thanked: 0
Been thanked: 0
United States of America
fastcars1173

2000 S70 2.4 Erratic Injector Pulse

Post by fastcars1173 » Wed Sep 28, 2016 12:43 pm

Has anyone ever had an issue with erratic injector pulse? When I start the vehicle it runs smooth and within 5 seconds it starts running like it has a misfire. The MAF signal was only changing between 1.50 and 2.50 with engine revving and running rich fouling the plugs. I changed the MAF. Now the values correlate with RPM. It seems to run a little better but it still starts smooth then goes rough. It has new plugs and all 5 coil packs are firing (I checked the actual spark not just the signal). I checked the injector pulse with a noid light and am getting erratic pulses to the injectors. Also some were getting a weak erratic signal and some were not even getting a signal. Then after checking through again the same ones that were not getting a signal started to have a good signal and the others that were low and erratic stopped getting one. I have come to the conclusion it may be the computer. I am a seasoned tech but do not have much experience with volvos. Thanks for any input!

User avatar
kcodyjr
Posts: 1110
Joined: Sun Jan 31, 2010 11:48 pm
Year and Model: 1997 850 GLT
Location: Massachusetts, USA
Has thanked: 0
Been thanked: 1 time
United States of America
kcodyjr

Re: 2000 S70 2.4 Erratic Injector Pulse

Post by kcodyjr » Wed Sep 28, 2016 1:22 pm

Does the 2000 have the same gray master fuel injector relay up on the cooling fan shroud, whose connector gets all crappy?
1997 850 GLT sedan, 152K and WHOOHOO!
RIP 1996 850 wagon, 201K, hit by a runaway 4-wheeler
RIP 1996 850 GLT sedan 5spd, 260K, rearended someone
RIP 1986 245 boring, 200K, rusted beyond inspectability
RIP 1981 242 turbo 5spd, 300K, serious teenage crash

fastcars1173
Posts: 6
Joined: Wed Sep 28, 2016 12:29 pm
Year and Model: 2000 S70
Location: S. Florida
Has thanked: 0
Been thanked: 0
United States of America
fastcars1173

Re: 2000 S70 2.4 Erratic Injector Pulse

Post by fastcars1173 » Wed Sep 28, 2016 1:45 pm

I only see the MAP sensor and the fan relays there. There is a relay in the kidney shaped main fuse panel that has a relay for the injectors.

User avatar
kcodyjr
Posts: 1110
Joined: Sun Jan 31, 2010 11:48 pm
Year and Model: 1997 850 GLT
Location: Massachusetts, USA
Has thanked: 0
Been thanked: 1 time
United States of America
kcodyjr

Re: 2000 S70 2.4 Erratic Injector Pulse

Post by kcodyjr » Wed Sep 28, 2016 2:06 pm

Hm. They may have fixed that in the S70. (I have an 850). That relay, with its poor placement, is responsible for many a no-start.

Someone correct me if I'm wrong, but I believe the S70 injectors also get a constant 12V and then get grounded by the ECU to open them. Check how steady the 12V is (green wire?) - if it's rock solid, then the poor signal is the ECU isn't properly grounding the injector. If it's flaky, trace the wires looking for a bad connection, the ECU could be fine.

ECU failures in these cars are fairly rare, unless you do something stupid like cross wires and send 12V down the wrong path.
1997 850 GLT sedan, 152K and WHOOHOO!
RIP 1996 850 wagon, 201K, hit by a runaway 4-wheeler
RIP 1996 850 GLT sedan 5spd, 260K, rearended someone
RIP 1986 245 boring, 200K, rusted beyond inspectability
RIP 1981 242 turbo 5spd, 300K, serious teenage crash

fastcars1173
Posts: 6
Joined: Wed Sep 28, 2016 12:29 pm
Year and Model: 2000 S70
Location: S. Florida
Has thanked: 0
Been thanked: 0
United States of America
fastcars1173

Re: 2000 S70 2.4 Erratic Injector Pulse

Post by fastcars1173 » Wed Sep 28, 2016 2:54 pm

It has solid voltage to the injectors. All of the injectors ohm out perfect, 15.4-15.6. As I unplug the injectors it seems as though the signal jumps around. Number 1 seems to fire consistently but the others don't. For example, if I check number 4 it won't be firing, then if I unplug 5 and 3 then number 4 starts to. I'm leaning more and more towards a bad injector driver in the ECU. All grounds are good. I pulled the cover off of the ECU and nothing is visibly burnt inside and no traces of moisture.

shaker_chi
Posts: 400
Joined: Mon Jun 29, 2009 2:17 pm
Year and Model: 94 850, 98 S70T5 M
Location: Chicago
Has thanked: 3 times
Been thanked: 3 times
Spain
shaker_chi

Re: 2000 S70 2.4 Erratic Injector Pulse

Post by shaker_chi » Wed Sep 28, 2016 3:03 pm

Have you swapped injectors to see if the problem persists with the injector itself or with the electronics?

fastcars1173
Posts: 6
Joined: Wed Sep 28, 2016 12:29 pm
Year and Model: 2000 S70
Location: S. Florida
Has thanked: 0
Been thanked: 0
United States of America
fastcars1173

Re: 2000 S70 2.4 Erratic Injector Pulse

Post by fastcars1173 » Wed Sep 28, 2016 3:48 pm

I'm not thinking it's the injectors. They all ohm'd great. It seems to be the signal that's the issue. A high impedance injector usually ohm's out at 12 to 16 ohms. Pretty much all regular injectors are high impedance (Saturated). Low impedance injectors are usually used in racing apps with aftermarket ECU's(Peak and hold).

User avatar
kcodyjr
Posts: 1110
Joined: Sun Jan 31, 2010 11:48 pm
Year and Model: 1997 850 GLT
Location: Massachusetts, USA
Has thanked: 0
Been thanked: 1 time
United States of America
kcodyjr

Re: 2000 S70 2.4 Erratic Injector Pulse

Post by kcodyjr » Wed Sep 28, 2016 5:09 pm

OK, yeah, if you're sure there isn't a wiring fault that explains it, try swapping an ECU from the boneyard.

Someone chime in, did they start with the reprogramming to the car bullcrap in 2000? I think you can simply swap it.
1997 850 GLT sedan, 152K and WHOOHOO!
RIP 1996 850 wagon, 201K, hit by a runaway 4-wheeler
RIP 1996 850 GLT sedan 5spd, 260K, rearended someone
RIP 1986 245 boring, 200K, rusted beyond inspectability
RIP 1981 242 turbo 5spd, 300K, serious teenage crash

User avatar
abscate
MVS Moderator
Posts: 21105
Joined: Sun Feb 17, 2013 5:54 pm
Year and Model: 99T5 ,99S70,2005V70
Location: NYC, ALBANY NY
Has thanked: 318 times
Been thanked: 987 times
Trinidad & Tobago
abscate

Re: 2000 S70 2.4 Erratic Injector Pulse

Post by abscate » Wed Sep 28, 2016 6:27 pm

1999-on require ECU to be married to car in software.

It's not your ECU.
Empty Nester
A Captain in a Sea of Estrogen
1999-V70-T5M56 2005-V70-M56 1999-S70 VW T4 BMW
Link to Maintenance record thread
Link To Volvo Glossary

User avatar
kcodyjr
Posts: 1110
Joined: Sun Jan 31, 2010 11:48 pm
Year and Model: 1997 850 GLT
Location: Massachusetts, USA
Has thanked: 0
Been thanked: 1 time
United States of America
kcodyjr

Re: 2000 S70 2.4 Erratic Injector Pulse

Post by kcodyjr » Wed Sep 28, 2016 7:09 pm

Thanks, abscate, I wasn't sure how much of it started with the late P80's and how much started with the P2's.

Does it take a legit VIDA setup to do the remarriage or will one of the chinese hack jobs off eBay do it?

Anyway, I agree that an ECU failure is really unlikely. I've never heard of one just crapping out. With all that hassle, it isn't worth swapping one from a junkyard just to check and see.

How closely have you inspected the wiring? The way it comes and goes really sounds like something wiggling loose, or a wire cracked and rotted to the point it's a marginal conductor.
1997 850 GLT sedan, 152K and WHOOHOO!
RIP 1996 850 wagon, 201K, hit by a runaway 4-wheeler
RIP 1996 850 GLT sedan 5spd, 260K, rearended someone
RIP 1986 245 boring, 200K, rusted beyond inspectability
RIP 1981 242 turbo 5spd, 300K, serious teenage crash

Post Reply
  • Similar Topics
    Replies
    Views
    Last post