IPD sale XeMODeX - Experts in Volvo Electronics

Get email notification of topic replies. Log in or register (free). Amazon Link Buy anything with this and it helps MVS!

Just replaced ECT Sensor... Fan still runs after shutdown Topic is solved

Help, Advice and DIY Tutorials on Volvo's extremely popular car line -- Volvo's 1990s "bread and butter" cars -- powered by the ubiquitous and durable Volvo inline 5-cylinder engine.

1992 - 1997 850, 850 R, 850 T5-R, 850 T5, 850 GLT
1997 - 2000 S70, S70 AWD
1997 - 2000 V70, V70 AWD
1997 - 2000 V70-XC
1997 - 2004 C70

mbaskette
Posts: 19
Joined: Wed Aug 24, 2016 10:31 am
Year and Model: 2000 V70XC
Location: Kentucky

Just replaced ECT Sensor... Fan still runs after shutdown

Post by mbaskette »

Working on my 2000 Volvo V70 XC...

This morning I have replaced the ETC Sensor (and thermostat while in there) in an effort to fix the issue of my cooling fan running after shutting down the car. This sensor seemed to be the #1 item on the punch list for this issue. After getting everything back together and topping off the coolant again, I took her out for a good solid run to get everything heated up again. Rolled back into the driveway, parked it, switched it off and removed the key. Fan still running :( .

What is next on the punch list???? Fan relays???

Thanks
Mike
2000 V70XC (53.7k)
2013 XC60 T6 (33k)
User avatar
bmdubya1198
Posts: 4332
Joined: Tue Dec 30, 2014 10:45 am
Year and Model: 2K V70R M56
Location: Charlotte, NC
Has thanked: 45 times
Been thanked: 182 times

Re: Just replaced ECT Sensor... Fan still runs after shutdown

Post by bmdubya1198 »

You might want to look into the fan relay. From what I've experienced, if the car has been running a while, the fan will run for a few minutes after shutting off the engine. But that was on a hot summer day. I don't know that it should be running on after turning off the car, especially in cooler weather.
'00 V70R Venetian Red/Charcoal M56 Swapped 199k
'03 S60 2.4T Silver/Black 117k
'07 XC90 V8 AWD Sport Titanium Grey/Black 174k
'91 944 Turbo Dark Green/Beige 175k
'92 245 Base White/Beige 249k
'99 BMW 528i
'01 Mountaineer 5.0
Sold-
2000 S70 GLT Mystic Silver/Taupe 253k
1993 944 Base Beige/Beige 221k
1998 V70 GLT Black/Beige 199k
1998 S90- Silver/Gray 207k
1995 850 GLT Tropic Green... crushed
2001 S60 2.4T Black/Black 230k
1988 744 Turbo M46 Beige Metallic/Beige 188k
mbaskette
Posts: 19
Joined: Wed Aug 24, 2016 10:31 am
Year and Model: 2000 V70XC
Location: Kentucky

Re: Just replaced ECT Sensor... Fan still runs after shutdown

Post by mbaskette »

Thanks... about 54 this morning when I took it out to test the work. Certainly not hot day issue.
2000 V70XC (53.7k)
2013 XC60 T6 (33k)
User avatar
misha
Posts: 4506
Joined: Sun Dec 07, 2008 4:09 pm
Year and Model: '97 850 2.5 20v
Location: Serbia
Has thanked: 59 times
Been thanked: 163 times

Re: Just replaced ECT Sensor... Fan still runs after shutdown  Topic is solved

Post by misha »

It should do that on 2000 and later cars.Earlier models behave like that only when ect is bad.
2000 and later models owners says that it's normal.
'97 850 2.5 20v / fully equipped / Motronic 4.4 from the factory / upgraded with S,V,C,XC70 instrument cluster / polar white wagon
'91 Citroen XM 2.0 SI /fully equipped/mandarine red metallic
History of Volvos in the family:
'71 144 S
'73 144 De Luxe
'78 244 DL
'78 244 DL
'79 244 GLE
'85 340 GLS
scot850
Posts: 6281
Joined: Mon Apr 05, 2010 2:46 pm
Year and Model: 2000 V70 R
Location: Calgary, Alberta, Canada
Has thanked: 21 times
Been thanked: 266 times

Re: Just replaced ECT Sensor... Fan still runs after shutdown

Post by scot850 »

My 2000 fan does run after the car is switched off. But again only when I have been driving hard or outside temp is high.

Not sure how long the fan runs for, but maybe if you have a way of measuring the under hood temp, you could monitor the temp with the hood closed and see when the fan switches off and see if the temp is consistent in range when it does. If it is still running all the time, then I'd suspect there is a temp sensor gone rogue or the relay is stuck on.

Neil.
2000 V70 R - still being an endless PITA
2006 XC70
2003 Toyota 4Runner V8 Limited
2015 Kia Sportage EX-L
1993 850 GLT -Sold
1998 V70 XC - Sold
1997 Volvo 850 SE NA - Went to niece in California - Sold
2000 V70 SE NA - New project and test bed - Sold
mbaskette
Posts: 19
Joined: Wed Aug 24, 2016 10:31 am
Year and Model: 2000 V70XC
Location: Kentucky

Re: Just replaced ECT Sensor... Fan still runs after shutdown

Post by mbaskette »

Great... well the thermostat and ECT I removed were pretty grungy, so I guess I may have upgrade a functioning system.
2000 V70XC (53.7k)
2013 XC60 T6 (33k)
s10lowrider1994
Posts: 107
Joined: Mon Mar 09, 2015 7:04 pm
Year and Model: 2000 v70
Location: USA
Has thanked: 4 times
Been thanked: 3 times

Re: Just replaced ECT Sensor... Fan still runs after shutdown

Post by s10lowrider1994 »

MIne does that, totally normal.
User avatar
bmdubya1198
Posts: 4332
Joined: Tue Dec 30, 2014 10:45 am
Year and Model: 2K V70R M56
Location: Charlotte, NC
Has thanked: 45 times
Been thanked: 182 times

Re: Just replaced ECT Sensor... Fan still runs after shutdown

Post by bmdubya1198 »

Hmm... my cousin's '99 has done that once or twice, but mine has never done that. My dad's old E53 X5 used to run after turning the engine off.
'00 V70R Venetian Red/Charcoal M56 Swapped 199k
'03 S60 2.4T Silver/Black 117k
'07 XC90 V8 AWD Sport Titanium Grey/Black 174k
'91 944 Turbo Dark Green/Beige 175k
'92 245 Base White/Beige 249k
'99 BMW 528i
'01 Mountaineer 5.0
Sold-
2000 S70 GLT Mystic Silver/Taupe 253k
1993 944 Base Beige/Beige 221k
1998 V70 GLT Black/Beige 199k
1998 S90- Silver/Gray 207k
1995 850 GLT Tropic Green... crushed
2001 S60 2.4T Black/Black 230k
1988 744 Turbo M46 Beige Metallic/Beige 188k
User avatar
BEJinFbk
Posts: 3756
Joined: Sat Jan 05, 2008 10:32 pm
Year and Model: '98 V70 R
Location: Fairbanks, Alaska
Has thanked: 25 times
Been thanked: 56 times

Re: Just replaced ECT Sensor... Fan still runs after shutdown

Post by BEJinFbk »

mbaskette wrote:Working on my 2000 Volvo V70 XC...

This morning I have replaced the ETC Sensor (and thermostat while in there) in an effort to fix the issue of my cooling fan running after shutting down the car. This sensor seemed to be the #1 item on the punch list for this issue. After getting everything back together and topping off the coolant again, I took her out for a good solid run to get everything heated up again. Rolled back into the driveway, parked it, switched it off and removed the key. Fan still running :( .

What is next on the punch list???? Fan relays???

Thanks
Mike
It's supposed to keep running if the engine is still hot enough to need it.
Have you plugged in with anything to see realtime temp readings?
How long does it run?
If it's not more than a few minutes, it's probably just doing it's job.
'98 V70 R - Well Equipped for Life Up North... ;)
mbaskette
Posts: 19
Joined: Wed Aug 24, 2016 10:31 am
Year and Model: 2000 V70XC
Location: Kentucky

Re: Just replaced ECT Sensor... Fan still runs after shutdown

Post by mbaskette »

Great... well the thermostat and ECT I removed were pretty grungy, so I guess I may have upgrade a functioning system.
2000 V70XC (53.7k)
2013 XC60 T6 (33k)
Post Reply
  • Similar Topics
    Replies
    Views
    Last post