IPD sale XeMODeX - Experts in Volvo Electronics Free shipping all USA - Experts in Brakes
I'll be performing maintenance on the server March 31. I'll try my best to make interruptions as painless as possible. Thanks for your understanding.
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy anything with this and it helps MVS!

2000 S70 lit like a Christmas tree but no codes? Topic is solved

Help, Advice and DIY Tutorials on Volvo's extremely popular car line -- Volvo's 1990s "bread and butter" cars -- powered by the ubiquitous and durable Volvo inline 5-cylinder engine.

1992 - 1997 850, 850 R, 850 T5-R, 850 T5, 850 GLT
1997 - 2000 S70, S70 AWD
1997 - 2000 V70, V70 AWD
1997 - 2000 V70-XC
1997 - 2004 C70

aaron1611
Posts: 105
Joined: Sun Apr 02, 2017 4:48 pm
Year and Model: 2006 XC90 2.5
Location: Virginia
Has thanked: 0
Been thanked: 3 times
United States of America
aaron1611

Re: 2000 S70 lit like a Christmas tree but no codes?

Post by aaron1611 » Wed Apr 12, 2017 7:58 pm

I've been working double shifts and I've not had time to work on the car but it drove great today, great acceleration, cruises at 75 mph nicely and all 4 speakers working great and only the solid up arrow. Tomorrow it will be a different story I'm sure as it was yesterday.
06 XC90 175K current daily driver
02 V70 XC 135K sons daily driver
05 XC90 251K current daily driver
Volvo's that were driven and flipped:
92 240DL 215K
01 V70 TMU
00 S70 100K
99 V70 189K
94 940 136K
92 240 GL wagon TMU
85 240 DL 196K
90 240 DL 169K
95 850 wagon 250K
99 S70 135K

aaron1611
Posts: 105
Joined: Sun Apr 02, 2017 4:48 pm
Year and Model: 2006 XC90 2.5
Location: Virginia
Has thanked: 0
Been thanked: 3 times
United States of America
aaron1611

Re: 2000 S70 lit like a Christmas tree but no codes?

Post by aaron1611 » Fri Apr 14, 2017 1:59 pm

so, quick follow up to a "new" symptom. Started it up to leave work last night and it acted like I was pulling a large boat and up a hill. No matter how far I depressed the gas peddle, it would just slowly creep until I got to highway speed where it drove fine at that speed but once I slowed down it took forever to accelerate. No jerking or hesitation, just slow moving and no passing gear. Stopped at 7-11 and when I came back out and started it up all symptoms were gone. Once home, I sprayed carb cleaner all around all the throttle body areas and found no leaks, cleaned the MAF and no difference. Unplugged MAF while engine was on and it immediately died. Drove normally to work this morning with same lit dash and sporadic hesitations. I guess I'll pick up an ETM and just bite the bullet.
06 XC90 175K current daily driver
02 V70 XC 135K sons daily driver
05 XC90 251K current daily driver
Volvo's that were driven and flipped:
92 240DL 215K
01 V70 TMU
00 S70 100K
99 V70 189K
94 940 136K
92 240 GL wagon TMU
85 240 DL 196K
90 240 DL 169K
95 850 wagon 250K
99 S70 135K

scot850
Posts: 5762
Joined: Mon Apr 05, 2010 2:46 pm
Year and Model: 2000 V70 R
Location: Calgary, Alberta, Canada
Has thanked: 9 times
Been thanked: 187 times
Canada
scot850

Re: 2000 S70 lit like a Christmas tree but no codes?

Post by scot850 » Fri Apr 14, 2017 2:09 pm

The slow response to accelerating (assuming the orange arrow is on) is the car is in limp mode. Basically it goes to about 3rd gear, perhaps someone could chime in on that one.

ETM can also cause the issue if it is not getting a position signal so again will give the slow response to accelerating.

Neil.
2000 V70 R - still being an endless PITA
2006 XC70
2003 Toyota 4Runner V8 Limited
2015 Kia Sportage EX-L
1993 850 GLT -Sold
1998 V70 XC - Sold
1997 Volvo 850 SE NA - Went to niece in California - Sold
2000 V70 SE NA - New project and test bed - Sold

aaron1611
Posts: 105
Joined: Sun Apr 02, 2017 4:48 pm
Year and Model: 2006 XC90 2.5
Location: Virginia
Has thanked: 0
Been thanked: 3 times
United States of America
aaron1611

Re: 2000 S70 lit like a Christmas tree but no codes?

Post by aaron1611 » Sat Apr 15, 2017 8:59 am

yes, the up arrow was steady, not flashing. Still no ETM dash light and I'm still confused as to why it's not throwing any codes. Could my OBD11 port be non functioning? It reads my car etc, but just doesn't throw any codes. I'm going to try to work on it later today. Thanks again for all the input so far.
06 XC90 175K current daily driver
02 V70 XC 135K sons daily driver
05 XC90 251K current daily driver
Volvo's that were driven and flipped:
92 240DL 215K
01 V70 TMU
00 S70 100K
99 V70 189K
94 940 136K
92 240 GL wagon TMU
85 240 DL 196K
90 240 DL 169K
95 850 wagon 250K
99 S70 135K

User avatar
abscate
MVS Moderator
Posts: 20458
Joined: Sun Feb 17, 2013 5:54 pm
Year and Model: 99T5 ,99S70,2005V70
Location: NYC, ALBANY NY
Has thanked: 285 times
Been thanked: 898 times
Trinidad & Tobago
abscate

Re: 2000 S70 lit like a Christmas tree but no codes?

Post by abscate » Sat Apr 15, 2017 10:07 am

Try reading the monitor readiness, then reset by disconnecting the battery and seeing if the monitors go not ready to test OBD port
Empty Nester
A Captain in a Sea of Estrogen
1999-V70-T5M56 2005-V70-M56 1999-S70 VW T4 BMW
Link to Maintenance record thread
Link To Volvo Glossary

aaron1611
Posts: 105
Joined: Sun Apr 02, 2017 4:48 pm
Year and Model: 2006 XC90 2.5
Location: Virginia
Has thanked: 0
Been thanked: 3 times
United States of America
aaron1611

Re: 2000 S70 lit like a Christmas tree but no codes?

Post by aaron1611 » Wed Apr 26, 2017 4:15 pm

so, an update. I purchased a new MAF and installed it and as soon as I started the engine I immediately got the ETS light. While sitting in the driveway feeling frustrated, all the other CEL's were coming and going as they do and I figured that I would check my primary from battery to fuse box under the hood . Even though it looked fine I pulled it out and all 4 of them in the harness were shot, sheathing melted off, corroded and splintering. Could this be my problem the whole time? I replaced it and put it back together and stared up the engine and zero CEL's!! About 10 mins into my test drive with everything working great, everything returned as normal, all the same lights, no odom or speedo etc. but no ETS light since. I went back to check for codes and I finally got one!! P0600. Seems to be much said about this code but I'm not finding a "one" solution. I'm holding off on getting the new ETM but I guess I want to know what to do next. Thank you.
06 XC90 175K current daily driver
02 V70 XC 135K sons daily driver
05 XC90 251K current daily driver
Volvo's that were driven and flipped:
92 240DL 215K
01 V70 TMU
00 S70 100K
99 V70 189K
94 940 136K
92 240 GL wagon TMU
85 240 DL 196K
90 240 DL 169K
95 850 wagon 250K
99 S70 135K

aaron1611
Posts: 105
Joined: Sun Apr 02, 2017 4:48 pm
Year and Model: 2006 XC90 2.5
Location: Virginia
Has thanked: 0
Been thanked: 3 times
United States of America
aaron1611

Re: 2000 S70 lit like a Christmas tree but no codes?

Post by aaron1611 » Wed May 03, 2017 4:40 pm

so, an update. I purchased a new MAF and installed it and as soon as I started the engine I immediately got the ETS light. While sitting in the driveway feeling frustrated, all the other CEL's were coming and going as they do and I figured that I would check my primary from battery to fuse box under the hood . Even though it looked fine I pulled it out and all 4 of them in the harness were shot, sheathing melted off, corroded and splintering. Could this be my problem the whole time? I replaced it and put it back together and stared up the engine and zero CEL's!! About 10 mins into my test drive with everything working great, everything returned as normal, all the same lights, no odom or speedo etc. but no ETS light since. I went back to check for codes and I finally got one!! P0600. Seems to be much said about this code but I'm not finding a "one" solution. I'm holding off on getting the new ETM but I guess I want to know what to do next. Thank you.
06 XC90 175K current daily driver
02 V70 XC 135K sons daily driver
05 XC90 251K current daily driver
Volvo's that were driven and flipped:
92 240DL 215K
01 V70 TMU
00 S70 100K
99 V70 189K
94 940 136K
92 240 GL wagon TMU
85 240 DL 196K
90 240 DL 169K
95 850 wagon 250K
99 S70 135K

aaron1611
Posts: 105
Joined: Sun Apr 02, 2017 4:48 pm
Year and Model: 2006 XC90 2.5
Location: Virginia
Has thanked: 0
Been thanked: 3 times
United States of America
aaron1611

Re: 2000 S70 lit like a Christmas tree but no codes?

Post by aaron1611 » Wed May 03, 2017 4:40 pm

oops. ordering new ETM and will post back results.
06 XC90 175K current daily driver
02 V70 XC 135K sons daily driver
05 XC90 251K current daily driver
Volvo's that were driven and flipped:
92 240DL 215K
01 V70 TMU
00 S70 100K
99 V70 189K
94 940 136K
92 240 GL wagon TMU
85 240 DL 196K
90 240 DL 169K
95 850 wagon 250K
99 S70 135K

User avatar
abscate
MVS Moderator
Posts: 20458
Joined: Sun Feb 17, 2013 5:54 pm
Year and Model: 99T5 ,99S70,2005V70
Location: NYC, ALBANY NY
Has thanked: 285 times
Been thanked: 898 times
Trinidad & Tobago
abscate

Re: 2000 S70 lit like a Christmas tree but no codes?

Post by abscate » Thu May 04, 2017 5:24 am

Your P0600 is an ECU comm link code....but.......it's not your ECU. Root cause is probably bad 12V supply somewhere

Wiring on these cars is very robust. What caused the burned wires on the primary supply side?
Empty Nester
A Captain in a Sea of Estrogen
1999-V70-T5M56 2005-V70-M56 1999-S70 VW T4 BMW
Link to Maintenance record thread
Link To Volvo Glossary

aaron1611
Posts: 105
Joined: Sun Apr 02, 2017 4:48 pm
Year and Model: 2006 XC90 2.5
Location: Virginia
Has thanked: 0
Been thanked: 3 times
United States of America
aaron1611

Re: 2000 S70 lit like a Christmas tree but no codes?

Post by aaron1611 » Sun May 07, 2017 7:31 pm

I don't really know why the primary was shot up underneath the fuse box but it was the same way on my V70 too. Everywhere that I can check with my meter is 14+v, took the Napa battery up to be checked, had alt. checked and both are good. On a side note, I lived in NYC for about 10 yrs and loved it.
06 XC90 175K current daily driver
02 V70 XC 135K sons daily driver
05 XC90 251K current daily driver
Volvo's that were driven and flipped:
92 240DL 215K
01 V70 TMU
00 S70 100K
99 V70 189K
94 940 136K
92 240 GL wagon TMU
85 240 DL 196K
90 240 DL 169K
95 850 wagon 250K
99 S70 135K

Post Reply
  • Similar Topics
    Replies
    Views
    Last post