IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy anything with this and it helps MVS!

Stuttering, idle problem Topic is solved

Help, Advice and DIY Tutorials on Volvo's extremely popular car line -- Volvo's 1990s "bread and butter" cars -- powered by the ubiquitous and durable Volvo inline 5-cylinder engine.

1992 - 1997 850, 850 R, 850 T5-R, 850 T5, 850 GLT
1997 - 2000 S70, S70 AWD
1997 - 2000 V70, V70 AWD
1997 - 2000 V70-XC
1997 - 2004 C70

User avatar
hanzbe420
Posts: 528
Joined: Fri Dec 10, 2010 8:13 am
Year and Model: 2006 s60 2.5T
Location: CT,USA
Has thanked: 4 times
Been thanked: 0
United States of America
hanzbe420

Stuttering, idle problem

Post by hanzbe420 » Sun May 07, 2017 5:37 pm

Hi all 94 850 turbo here. It's driving me crazy. Its hard to start it cranks for a long time then finally catches after giving some gas. So far I changed iacv,coil,spark plugs, TPS sensor. Cleaned throttle body not to through but good enough. It's driving me crazy. No New codes. Just the same codes that been there rear o2 sensor, front knock sensor. But it is throwing misfire codes and has minor backfires sometimes in park after I hit the gas. I got a used o2 sensor at the junkyard​ and gonna throw it in there. O and there's allot of gas going into the throttle bottle and even leaking out the bottom of the air tree on throttle bottle like where it seats. Anyways what can it be? Temp sensor crank sensor.? The crank sensor wires got cut a long time ago but I redid them with black tape, and it has been fine ever since unless it's dead now. Or maybe fuel filter. Looks old and rusty I changed it a few years ago. Any help please.

User avatar
hanzbe420
Posts: 528
Joined: Fri Dec 10, 2010 8:13 am
Year and Model: 2006 s60 2.5T
Location: CT,USA
Has thanked: 4 times
Been thanked: 0
United States of America
hanzbe420

Re: Stuttering, idle problem

Post by hanzbe420 » Tue May 09, 2017 8:03 am

I checked the distributor cap and rotor and they look ok. So today I will take of the fuel filter and blow through it. Any suggestions? I also saw some smoke coming from what I think would be the rear main seal but that's a whole different story. Please help me out I would appreciate it.

User avatar
misha
Posts: 4396
Joined: Sun Dec 07, 2008 4:09 pm
Year and Model: '97 850 2.5 20v
Location: Serbia
Has thanked: 57 times
Been thanked: 144 times
Serbia
misha

Re: Stuttering, idle problem  Topic is solved

Post by misha » Tue May 09, 2017 8:32 am

hanzbe420 wrote:
Sun May 07, 2017 5:37 pm
...O and there's allot of gas going into the throttle bottle and even leaking out the bottom of the air tree on throttle bottle like where it seats....
Can you actually explain this?
Do you have a raw fuel into intake and vacuum tree?

If so,then you have a classic case of fuel pressure regulator failure.It's vacuum side leaks fuel into intake.
Remove vacuum line from fuel pressure regulator and check for fuel...(from fuel pressure regulator side)there should be a plenty of it in this case.You can create vacuum with your mouth,for testing.
Otherwise...when it's ok,there MUST NOT be a trace of fuel...not even bigger smell of it.

Confirm this allowing us to proceed further.
'97 850 2.5 20v / fully equipped / Motronic 4.4 from the factory / upgraded with S,V,C,XC70 instrument cluster / polar white wagon
'91 Citroen XM 2.0 SI /fully equipped/mandarine red metallic
History of Volvos in the family:
'71 144 S
'73 144 De Luxe
'78 244 DL
'78 244 DL
'79 244 GLE
'85 340 GLS

User avatar
hanzbe420
Posts: 528
Joined: Fri Dec 10, 2010 8:13 am
Year and Model: 2006 s60 2.5T
Location: CT,USA
Has thanked: 4 times
Been thanked: 0
United States of America
hanzbe420

Re: Stuttering, idle problem

Post by hanzbe420 » Tue May 09, 2017 7:14 pm

So basically if I pull the vacuum side from the fuel pressure regulator there should be gas if it failed? I also took the fuel filter off and it seamed pretty clogged and dirty with black crap.

User avatar
hanzbe420
Posts: 528
Joined: Fri Dec 10, 2010 8:13 am
Year and Model: 2006 s60 2.5T
Location: CT,USA
Has thanked: 4 times
Been thanked: 0
United States of America
hanzbe420

Re: Stuttering, idle problem

Post by hanzbe420 » Tue May 09, 2017 7:58 pm

Ok so I went out there and pulled the vacuum side of the fuel pressure regulator and it immediately started dripping gas. I'm so happy I finnaly figured it out. Thank you so much. O and one more thing I removed the fuel filter and it's so rusty I can't tell the correct flow direction will it matter if it's put on backwards?

j-dawg
Posts: 1096
Joined: Sat Apr 20, 2013 10:56 am
Year and Model: 1999 V70 T5
Location: Los Angeles, CA
Has thanked: 1 time
Been thanked: 21 times
United States of America
j-dawg

Re: Stuttering, idle problem

Post by j-dawg » Tue May 09, 2017 8:05 pm

do not put it on backwards. all the junk you've filtered out over the years will be pushed into the fuel system, as it'll now be on the wrong side of the filter element. go get a generic fuel filter or even a hose barb - basically nothing you could do would be worse than installing a used filter backwards.
1999 V70 T5 5-SPD | ~270k mi | burns more oil than gasoline

User avatar
erikv11
Posts: 9752
Joined: Sat Jul 25, 2009 2:03 pm
Year and Model: 850, S/V70, 06 S60R
Location: Iowa
Has thanked: 101 times
Been thanked: 293 times
United States of America
erikv11

Re: Stuttering, idle problem

Post by erikv11 » Tue May 09, 2017 10:05 pm

Courtesy of Eeuroparts:
lg_c45d8af9-eb78-4dcd-ba4a-c2a214995c35.jpg
The back end is curved, front end is seamed.
lg_c45d8af9-eb78-4dcd-ba4a-c2a214995c35.jpg (88.18 KiB) Viewed 1106 times
'95 854 T5-R, Motronic 4.4, 185k
'96 855 NA, 145k
'98 S70 NA, 220k (living out west)
'98 V70, T5 tune-injectors-turbo, LPT engine, 286k
'06 S60 R, 167k
'99 Camry V6 :shock: 125k
gone: '96 NA 850 210k, '98 NA V70 182k

User avatar
hanzbe420
Posts: 528
Joined: Fri Dec 10, 2010 8:13 am
Year and Model: 2006 s60 2.5T
Location: CT,USA
Has thanked: 4 times
Been thanked: 0
United States of America
hanzbe420

Re: Stuttering, idle problem

Post by hanzbe420 » Tue May 09, 2017 10:43 pm

Ok thank you so much. So basically the round end towards the rear of the car and the seamed end facing the engine. Yea that would suck if I installed it back words. I wouldn't even bother putting it back on buy need car to go get new one. I was trying to find some thing to ok just connect both hoses.well I have it the way I stated. I hope that's the waft ha ha

User avatar
misha
Posts: 4396
Joined: Sun Dec 07, 2008 4:09 pm
Year and Model: '97 850 2.5 20v
Location: Serbia
Has thanked: 57 times
Been thanked: 144 times
Serbia
misha

Re: Stuttering, idle problem

Post by misha » Wed May 10, 2017 5:27 am

Replace that fpr before damaging something else with all of that fuel..if not allready.
'97 850 2.5 20v / fully equipped / Motronic 4.4 from the factory / upgraded with S,V,C,XC70 instrument cluster / polar white wagon
'91 Citroen XM 2.0 SI /fully equipped/mandarine red metallic
History of Volvos in the family:
'71 144 S
'73 144 De Luxe
'78 244 DL
'78 244 DL
'79 244 GLE
'85 340 GLS

User avatar
rspi
Posts: 7278
Joined: Sat Nov 05, 2011 10:40 am
Year and Model: 850 T-5R Wagon
Location: Albuquerque, NM
Has thanked: 22 times
Been thanked: 49 times
United States of America
rspi

Re: Stuttering, idle problem

Post by rspi » Wed May 10, 2017 7:27 am

Why would you put an old rusty contaminated fuel filter back on the car?

How long has this car been in your possession?
'95 855 T-5R M, Panther - 22/28 mpg
'98 S70 GLT, Lil' Red 25/32 mpg
--------------------
Volvo's of past: '87 740 GLE, '79 262C Bertone, '78 264, 960's, '98 S70 GLT, '95 850 T-5R YellowVolvo Repair Videos

Post Reply
  • Similar Topics
    Replies
    Views
    Last post