IPD sale XeMODeX - Experts in Volvo Electronics Free shipping all USA - Experts in Brakes
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy anything with this and it helps MVS!

1996 850R transmission. Stall or winter mode no codes

Help, Advice and DIY Tutorials on Volvo's extremely popular car line -- Volvo's 1990s "bread and butter" cars -- powered by the ubiquitous and durable Volvo inline 5-cylinder engine.

1992 - 1997 850, 850 R, 850 T5-R, 850 T5, 850 GLT
1997 - 2000 S70, S70 AWD
1997 - 2000 V70, V70 AWD
1997 - 2000 V70-XC
1997 - 2004 C70

nickm
Posts: 15
Joined: Sat Mar 02, 2013 6:04 am
Year and Model: 1996 850R
Location: Sydney Australia
Has thanked: 0
Been thanked: 0
nickm

1996 850R transmission. Stall or winter mode no codes

Post by nickm » Mon Jul 31, 2017 12:33 am

Hi All
Wondering if anyone could suggest a way of diagnosing this issue.

I have an intermittent stall or stuck in winter mode on a 1996 850R auto.
The issue is not temperature related it can happen from a cold or warm start and generally occurs in less than a minute into moving. It does not occur at idle.
The orange arrow will flash with the engine check and the car will stall. It always starts straight back up.
Or the trans will shift into winter mode and then disengage.
No faults are recorded. The arrow does not flash. I'm checking errors through Volfcr.
Trans fluid is good the cars drives well. The trans shifts fine when this is not occurring.

So far I have checked and cleaned the PNP The mode selector switch.

So could this be an ECU issue or possibly a solenoid issue....

Thanks Nick

User avatar
Clemens
Posts: 1116
Joined: Thu Sep 03, 2015 12:34 pm
Year and Model: 96 855 R + 94 855 T5
Location: Austria
Has thanked: 81 times
Been thanked: 43 times
Austria
Clemens

Re: 1996 850R transmission. Stall or winter mode no codes

Post by Clemens » Mon Jul 31, 2017 12:59 am

i fortunately haven't had to deal with my trannies too much (*knockonwood*), but if the switches are okay it could likely be a solenoid.
I know there is a way to test their resistance and i think you can also try to move them by putting the right voltage on the connectors. I remember a gentleman from switzerland with a t5r had a similar problem, it was the S2 solenoid if i recall correctly.
I doubt it is the ecu or the tcm, they are known to be very sturdy.
I hope someone smarter than me chimes in.
Summer: 1996 855 R
Winter: 1994 855 T5M
Donor: 1995 854 10V

User avatar
bmdubya1198
Posts: 3634
Joined: Tue Dec 30, 2014 10:45 am
Year and Model: 2K V70R M56
Location: Charlotte, NC
Has thanked: 41 times
Been thanked: 131 times
United States of America
bmdubya1198

Re: 1996 850R transmission. Stall or winter mode no codes

Post by bmdubya1198 » Thu Aug 03, 2017 9:22 pm

That's strange. Does your car have the little diagnostic code box in front of the ECU? Have you checked for codes on that? I'm not 100% sure the 850 still had that in '96, but if you do I would use it. It seems odd to me that the up arrow would be flashing yet you wouldn't have any transmission codes. Have you checked OBD2 codes?
Also, how does the ATF look? Is it clean or does it look dark or dirty?
2000 V70R Venetian Red/Charcoal M56 Swapped 195k
2000 S70 GLT Mystic Silver/Taupe 253k
2003 S60 2.4T Silver/Black 109k
2007 XC90 V8 AWD Sport Titanium Grey/Black 165k
1993 944 Base Beige/Beige 221k
1991 944 Turbo Dark Green/Beige 172k
1992 245 Base White/Beige 249k
Sold-
1998 V70 GLT Black/Beige 199k
1998 S90- Silver/Gray 207k
1995 850 GLT Tropic Green... crushed
2001 S60 2.4T Black/Black 230k
1988 744 Turbo M46 Beige Metallic/Beige 188k

nickm
Posts: 15
Joined: Sat Mar 02, 2013 6:04 am
Year and Model: 1996 850R
Location: Sydney Australia
Has thanked: 0
Been thanked: 0
nickm

Re: 1996 850R transmission. Stall or winter mode no codes

Post by nickm » Thu Aug 03, 2017 9:43 pm

thanks...Yes it is an odd issue.
My fluid is good. I flushed it 12 months ago when I changed the rear main seal. Levels are spot on.

1996 Australian R's have an OBD2 port in the console. But It runs motronic 4.3. so it is not fully OBD2 compliant.
so no under hood/bonnet diagnostic port.

Engine ECU , EEC and Cruse control codes can be read with on LED and a switch. The others can be read with VOLFCR.

I have looked through the Volvo trouble shooting guides. I can force a code by removing the Mode switch.

It seems the car will drop into winter mode and sometimes stall (not always). When it stalls the engine check light will flash up once. No code is stored.
It will come out of winter mode on its own after about 30 seconds . Or If I shut the car down and start it back up.
So I am suspecting a transmission fault causing the problem. It is difficult to trace or test the solenoids as the fault is intermittent and by the time it has occurred. I shut the car down to test the fault has gone.
But surely if solenoid S1 or S2 are failing it would show a code?
Do you know if the solenoids could cause a stall?
I am leaning toward changing the solenoids. But Avoiding it as it is a more complex job and may not solve the issue.

User avatar
Clemens
Posts: 1116
Joined: Thu Sep 03, 2015 12:34 pm
Year and Model: 96 855 R + 94 855 T5
Location: Austria
Has thanked: 81 times
Been thanked: 43 times
Austria
Clemens

Re: 1996 850R transmission. Stall or winter mode no codes

Post by Clemens » Fri Aug 04, 2017 2:19 am

are the solenoids that tough of a job? I thought they are accessile under the airbox/battery.
if you get a chance to get used ones from a junk yard it might be worth a try.
Summer: 1996 855 R
Winter: 1994 855 T5M
Donor: 1995 854 10V

User avatar
bmdubya1198
Posts: 3634
Joined: Tue Dec 30, 2014 10:45 am
Year and Model: 2K V70R M56
Location: Charlotte, NC
Has thanked: 41 times
Been thanked: 131 times
United States of America
bmdubya1198

Re: 1996 850R transmission. Stall or winter mode no codes

Post by bmdubya1198 » Fri Aug 04, 2017 7:49 am

Usually if one of the solenoids fail, it will throw a code.
From what I've heard, I think one of them is easier and can be accessed through that panel on the front of the transmission under the battery tray, and the other is a bit more of a pain.
BUT, since you're not getting any codes and the car is stalling, I would check wiring. I had a huge thread and spent LOTS of time trying to figure out what was wrong with my car after I put it back together, and the transmission was in a failsafe mode, which felt like it was stuck in winter mode. However I didn't have the up arrow light at all, it just wouldn't work. After lots of dead ends, I eventually found that this gray square connector right near the purge valve under the air intake tube had been crushed. I put it back together and my transmission has worked perfectly ever since.
Check the wiring and connectors around the transmission, especially those connected to the PNP switch.
2000 V70R Venetian Red/Charcoal M56 Swapped 195k
2000 S70 GLT Mystic Silver/Taupe 253k
2003 S60 2.4T Silver/Black 109k
2007 XC90 V8 AWD Sport Titanium Grey/Black 165k
1993 944 Base Beige/Beige 221k
1991 944 Turbo Dark Green/Beige 172k
1992 245 Base White/Beige 249k
Sold-
1998 V70 GLT Black/Beige 199k
1998 S90- Silver/Gray 207k
1995 850 GLT Tropic Green... crushed
2001 S60 2.4T Black/Black 230k
1988 744 Turbo M46 Beige Metallic/Beige 188k

nickm
Posts: 15
Joined: Sat Mar 02, 2013 6:04 am
Year and Model: 1996 850R
Location: Sydney Australia
Has thanked: 0
Been thanked: 0
nickm

Re: 1996 850R transmission. Stall or winter mode no codes

Post by nickm » Fri Aug 04, 2017 10:13 am

Yes I think I'll bite the bullet and change them.
I been over wiring and rebuilt the PNP in the process.

You need to either jack the engine or drop the subframe to get the front cover off for access to the S1 S2 solenoids.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post