IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy anything with this and it helps MVS!

Tachometer stopped working and back to normal

Help, Advice and DIY Tutorials on Volvo's extremely popular car line -- Volvo's 1990s "bread and butter" cars -- powered by the ubiquitous and durable Volvo inline 5-cylinder engine.

1992 - 1997 850, 850 R, 850 T5-R, 850 T5, 850 GLT
1997 - 2000 S70, S70 AWD
1997 - 2000 V70, V70 AWD
1997 - 2000 V70-XC
1997 - 2004 C70

lcc014
Posts: 145
Joined: Mon Jul 05, 2010 5:41 pm
Year and Model: 855, 1995
Location: Boston
Has thanked: 0
Been thanked: 2 times
United States of America
lcc014

Tachometer stopped working and back to normal

Post by lcc014 » Thu Sep 21, 2017 6:02 am

This happened yesterday after work. I did not pay attention in parking lot and then found out that tachometer was at "zero" soon after getting on highway. Car was driving fine as usual. After about 5 or 6 minutes later, tachometer jumped back to normal rpm at 65 mph. Then it worked fine last night. This morning, when I started to car, tachometer was at "zero" again. I let car idle for a few minutes and tachometer worked again.

Any suggestion to troubleshoot this "no tach" issue ? How does tachometer get signal from to drive the needle ?

Thanks,

Ching-Ho Cheng

User avatar
rspi
Posts: 7278
Joined: Sat Nov 05, 2011 10:40 am
Year and Model: 850 T-5R Wagon
Location: Albuquerque, NM
Has thanked: 22 times
Been thanked: 49 times
United States of America
rspi

Re: Tachometer stopped working and back to normal

Post by rspi » Thu Sep 21, 2017 6:03 am

What kind of car do you have?
'95 855 T-5R M, Panther - 22/28 mpg
'98 S70 GLT, Lil' Red 25/32 mpg
--------------------
Volvo's of past: '87 740 GLE, '79 262C Bertone, '78 264, 960's, '98 S70 GLT, '95 850 T-5R YellowVolvo Repair Videos

lcc014
Posts: 145
Joined: Mon Jul 05, 2010 5:41 pm
Year and Model: 855, 1995
Location: Boston
Has thanked: 0
Been thanked: 2 times
United States of America
lcc014

Re: Tachometer stopped working and back to normal

Post by lcc014 » Thu Sep 21, 2017 8:39 am

Sorry, I forgot to stated that in original post. It is 1995 855 NA with basic instrument cluster.

Thanks,

Ching-Ho Cheng

Post Reply
  • Similar Topics
    Replies
    Views
    Last post