IPD sale XeMODeX - Experts in Volvo Electronics Free shipping all USA - Experts in Brakes
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

98 s70 t5 stalls as soon as it warms up so 10 min or so

Help, Advice and DIY Tutorials on Volvo's extremely popular car line -- Volvo's 1990s "bread and butter" cars -- powered by the ubiquitous and durable Volvo inline 5-cylinder engine.

1992 - 1997 850, 850 R, 850 T5-R, 850 T5, 850 GLT
1997 - 2000 S70, S70 AWD
1997 - 2000 V70, V70 AWD
1997 - 2000 V70-XC
1997 - 2004 C70

Steve99s70t5manual
Posts: 12
Joined: Fri Dec 01, 2017 4:20 pm
Year and Model: 99s70 t5
Location: BC
Has thanked: 0
Been thanked: 0
Canada
Steve99s70t5manual

98 s70 t5 stalls as soon as it warms up so 10 min or so

Post by Steve99s70t5manual » Fri Jan 12, 2018 11:54 pm

Ok I just bought a 98 s70 and the Ce light is on and the codes that come up are p0300,01 02,03,05 and the p0442 p0455 p0116. The coolant sensor was my first suspect but I changed it and it still stalls when it warms up. Now it runs beautiful from cold, like smooth idle and revs nice but I notice that the revs don't come down easy. Also once it has been running for 3min it starts to get the odd sputter and only gets worse until it totally stalls out. The guy I got the car from said a few times all the lights on the dash would flash and then the car stalls so if that helps please let me know. I also check the fuel pressure relay and it was ok. Any help at all would be great as I only have a 2day permit on the insurance and it is 40miles away from home at a gas station.

User avatar
wizechatmgr
Posts: 1300
Joined: Thu Jan 12, 2017 1:07 pm
Year and Model: 1999 V70 XC AWD 2.4T
Location: Albany, NY area
Has thanked: 22 times
Been thanked: 53 times
Contact:
United States of America
wizechatmgr

Re: 98 S70 t5 stalls as soon as it warms up so 10 min or so

Post by wizechatmgr » Sat Jan 13, 2018 12:31 am

The P030x are multiple cylinder misfires - I'd ignore them at this point in time. P0442 & P0455 is EVAP/EMISSIONS - Large vac. leak I believe...

P0116 indicates you may have a faulty Engine Coolant Temp sensor or the circuit it is in. That would explain weirdness after hot though usually those have problems when the engine is cold... That's a cheap and relatively easy part to replace. I'd replace it first.

Link to troubleshooting values of one... viewtopic.php?t=52203
Wisdom requires knowledge as a prerequisite, but knowledge can be developed due to a lack of wisdom.
In order to learn how to fix something, you must first learn how to break it.
1999 V70 XC AWD - ~183k miles

Steve99s70t5manual
Posts: 12
Joined: Fri Dec 01, 2017 4:20 pm
Year and Model: 99s70 t5
Location: BC
Has thanked: 0
Been thanked: 0
Canada
Steve99s70t5manual

Re: 98 S70 t5 stalls as soon as it warms up so 10 min or so

Post by Steve99s70t5manual » Sat Jan 13, 2018 1:09 am

I already changed the coolant sensor and no change in problem. Could it possibly be the coil since it is just single coil rather than indv coil packs? Because the dash lights flash when it stalls on occasion

Steve99s70t5manual
Posts: 12
Joined: Fri Dec 01, 2017 4:20 pm
Year and Model: 99s70 t5
Location: BC
Has thanked: 0
Been thanked: 0
Canada
Steve99s70t5manual

Re: 98 S70 t5 stalls as soon as it warms up so 10 min or so

Post by Steve99s70t5manual » Sat Jan 13, 2018 1:15 am

It kind of seems like it's starved for fuel when I'm trying to start it after it's stalled out. And I wonder if it might have to do with the evaporative codes because if there was no vent in the gas tank it would eventually have have a pressure release that might be the reason it has to wait so long before it starts again

User avatar
RickHaleParker
Posts: 3551
Joined: Mon May 25, 2015 2:30 pm
Year and Model: See Signature below.
Location: Kansas
Has thanked: 3 times
Been thanked: 433 times
United States of America
RickHaleParker

Re: 98 S70 t5 stalls as soon as it warms up so 10 min or so

Post by RickHaleParker » Sat Jan 13, 2018 1:23 am

Did you clear the codes? If so what came back?
Platform: P80 1998 C70, B5234T3, 16T, AW50-42, Bosch Motronic 4.4, Special Edition package, Plant: Uddevalla Sweden.

Platform: X40 (Nedcar) 2003 S40, B4204T3, 14T twin scroll AW55-50/51SN, Siemens EMS 2000. Plant: Born Netherlands.

Platform P2 2005 XC90 T6 Executive, B6294T, 4T65 AWD, Bosch Motronic 7.0,
Plant Torslanda Sweden.
----------------------------------------------------------------
1997 S90, B6304S, AW30-42, Bosch Motronic 4.4 - Sold

User avatar
wizechatmgr
Posts: 1300
Joined: Thu Jan 12, 2017 1:07 pm
Year and Model: 1999 V70 XC AWD 2.4T
Location: Albany, NY area
Has thanked: 22 times
Been thanked: 53 times
Contact:
United States of America
wizechatmgr

Re: 98 S70 t5 stalls as soon as it warms up so 10 min or so

Post by wizechatmgr » Sat Jan 13, 2018 1:24 am

Leave the gas cap loose to test that theory.

Did you check the resistance of the sensor before/after installation? Occasionally bad parts make it into customer hands. I'd say the odds are less than 1 in 100, but it still can happen.

When was the fuel filter last replaced? It may be original and full of crud.

I'd suggest bypassing the fuel pump relay with some 12 gauge copper wire hammered flat on the ends. RSPI has a video on how to do this at https://www.youtube.com/watch?v=gLoO-D4yOcU

When it does this, it sounds like you can't restart it. Are you able to hear the fuel pump start at all? If not, fuel pump or fuel pump relay.
Wisdom requires knowledge as a prerequisite, but knowledge can be developed due to a lack of wisdom.
In order to learn how to fix something, you must first learn how to break it.
1999 V70 XC AWD - ~183k miles

User avatar
abscate
MVS Moderator
Posts: 19963
Joined: Sun Feb 17, 2013 5:54 pm
Year and Model: 99T5 ,99S70,2005V70
Location: NYC, ALBANY NY
Has thanked: 267 times
Been thanked: 846 times
Trinidad & Tobago
abscate

Re: 98 S70 t5 stalls as soon as it warms up so 10 min or so

Post by abscate » Sat Jan 13, 2018 5:49 am

If you didn't use a Volvo part for that coolant sensor return it and get the right one.

The time to diagnose it is when you can't restart, check for spark, check fuel pressure at rail.

Then follow the tracing on the no start thread on the appropriate fork.

On a -1998, check the fuel pressure regulator for gas in the diaphragm, too.

Vacuum leaks could also cause this running, check the elbow under the intake manifold and all those hoses for split

Finally check all the induction fat Air hoses by removing them , inspecting with flashlight, and replacing carefully with new clamps as needed.

A new to you car will likely have trouble in at least 2 of these areas.
Empty Nester
A Captain in a Sea of Estrogen
1999-V70-T5M56 2005-V70-M56 1999-S70 VW T4 BMW
Link to Maintenance record thread
Link To Volvo Glossary

User avatar
FLXC90
Posts: 925
Joined: Mon Aug 18, 2014 4:31 pm
Year and Model: 98 V70 T5
Location: Florida Panhandle
Has thanked: 2 times
Been thanked: 12 times
United States of America
FLXC90

Re: 98 S70 t5 stalls as soon as it warms up so 10 min or so

Post by FLXC90 » Sat Jan 13, 2018 8:14 am

Steve99s70t5manual wrote:
Sat Jan 13, 2018 1:09 am
I already changed the coolant sensor and no change in problem. Could it possibly be the coil since it is just single coil rather than indv coil packs? Because the dash lights flash when it stalls on occasion
Look at the threads for ignition switch failure as well.
Current Volvos:
1998 V70 T5, 112k sat 5 years, still in mechanical coma (finally at the top of the pile )
2004 XC90 T6 AWD: 186k, 60 on transaxle ( traded in )
1998 POS70 N/A: DD/training aid, 236k but really about 240k, I think...ABS module( passed on to son who sold it)

Caroline02
Posts: 1
Joined: Sat Jan 13, 2018 9:40 am
Year and Model: 2002 S60
Location: Marseille
Has thanked: 0
Been thanked: 0
France
Caroline02

Re: 98 S70 t5 stalls as soon as it warms up so 10 min or so

Post by Caroline02 » Sat Jan 13, 2018 9:41 am

Steve99s70t5manual wrote:
Fri Jan 12, 2018 11:54 pm
Ok I just bought a 98 S70 and the Ce light is on and the codes that come up are p0300,01 02,03,05 and the p0442 p0455 p0116. The coolant sensor was my first suspect but I changed it and it still stalls when it warms up. Now it runs beautiful from cold, like smooth idle and revs nice but I notice that the revs don't come down easy. Also once it has been running for 3min it starts to get the odd sputter and only gets worse until it totally stalls out. The guy I got the car from said a few times all the lights on the dash would flash and then the car stalls so if that helps please let me know. I also check the fuel pressure relay and it was ok. Any help at all would be great as I only have a 2day permit on the insurance and it is 40miles away from home at a gas station.
Where is the picture of this?

scot850
Posts: 5662
Joined: Mon Apr 05, 2010 2:46 pm
Year and Model: 2000 V70 R
Location: Calgary, Alberta, Canada
Has thanked: 9 times
Been thanked: 168 times
Canada
scot850

Re: 98 S70 t5 stalls as soon as it warms up so 10 min or so

Post by scot850 » Sat Jan 13, 2018 1:08 pm

Can you clarify the year? In your details you say 99 S70 T5 and in the header for the thread you say 98 T5. These use different systems so just want to make sure we are helping you with the non-common parts of these systems. Only use OE coolant temp sensor as previously mentioned.

Neil.
2000 V70 R - still being an endless PITA
2006 XC70
2003 Toyota 4Runner V8 Limited
2015 Kia Sportage EX-L
1993 850 GLT -Sold
1998 V70 XC - Sold
1997 Volvo 850 SE NA - Went to niece in California - Sold
2000 V70 SE NA - New project and test bed - Sold

Post Reply
  • Similar Topics
    Replies
    Views
    Last post