IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy anything with this and it helps MVS!

1998 S70 PnP switch 9466012, bad aftermarket new part Topic is solved

Help, Advice and DIY Tutorials on Volvo's extremely popular car line -- Volvo's 1990s "bread and butter" cars -- powered by the ubiquitous and durable Volvo inline 5-cylinder engine.

1992 - 1997 850, 850 R, 850 T5-R, 850 T5, 850 GLT
1997 - 2000 S70, S70 AWD
1997 - 2000 V70, V70 AWD
1997 - 2000 V70-XC
1997 - 2004 C70

ferocity02
Posts: 161
Joined: Sat Oct 25, 2014 1:56 pm
Year and Model: 1998 S70 GLT
Location: Califfornia
Has thanked: 0
Been thanked: 10 times
United States of America
ferocity02

Re: Ongoing issue with Transmission Range Switch

Post by ferocity02 » Mon Feb 12, 2018 9:04 pm

RickHaleParker wrote: ↑
Mon Feb 12, 2018 1:35 pm
Probe for shorts in the cable to the mode selector.
Just did, no dead shorts.

User avatar
RickHaleParker
Posts: 4396
Joined: Mon May 25, 2015 2:30 pm
Year and Model: See Signature below.
Location: Kansas
Has thanked: 3 times
Been thanked: 560 times
United States of America
RickHaleParker

Re: Ongoing issue with Transmission Range Switch

Post by RickHaleParker » Mon Feb 12, 2018 10:17 pm

Just did, no dead shorts.

It comes and goes, did you move the cable around and stress it, in attempt to recreate the conditions?
--------
Platform: P80 1998 C70, B5234T3, 16T, AW50-42, Bosch Motronic 4.4, Special Edition package.
Platform: X40 (Nedcar) 2003 S40, B4204T3, 14T twin scroll AW55-50/51SN, Siemens EMS 2000.
Platform P2 2005 XC90 T6 Executive, B6294T, 4T65 AWD, Bosch Motronic 7.0.
Platform P2 2004 S60R, B2524T4, AW50/51 AWD, B8444S TF80 AWD, Bosch Motronic 7.0, BorgWarner K24 turbocharger. V8 conversion in progress.

ferocity02
Posts: 161
Joined: Sat Oct 25, 2014 1:56 pm
Year and Model: 1998 S70 GLT
Location: Califfornia
Has thanked: 0
Been thanked: 10 times
United States of America
ferocity02

Re: Ongoing issue with Transmission Range Switch

Post by ferocity02 » Tue Feb 13, 2018 2:02 pm

RickHaleParker wrote: ↑
Mon Feb 12, 2018 10:17 pm
Just did, no dead shorts.

It comes and goes, did you move the cable around and stress it, in attempt to recreate the conditions?
I have wiggled the cable around as much as possible and no dice. I'm going to try shaking the TCM and it's connections. I did unplug the mode switch completely and it gave me a signal high code, AT-125 I think.

I'm contemplating swapping the TCM, they are pretty cheap used.

User avatar
RickHaleParker
Posts: 4396
Joined: Mon May 25, 2015 2:30 pm
Year and Model: See Signature below.
Location: Kansas
Has thanked: 3 times
Been thanked: 560 times
United States of America
RickHaleParker

Re: Ongoing issue with Transmission Range Switch

Post by RickHaleParker » Tue Feb 13, 2018 2:39 pm

I did unplug the mode switch completely and it gave me a signal high code, AT-125 I think.

Try that again but this time manually hardware a mode.

Economy mode = Green-Orange grounded + Brown-Green open.
Sports mode = Green-Orange Open + Brown-Green grounded.
Weather mode = Green-Orange grounded + Brown-Green grounded.

Use a known good ground point. Don't use the ground to the mode switch.
--------
Platform: P80 1998 C70, B5234T3, 16T, AW50-42, Bosch Motronic 4.4, Special Edition package.
Platform: X40 (Nedcar) 2003 S40, B4204T3, 14T twin scroll AW55-50/51SN, Siemens EMS 2000.
Platform P2 2005 XC90 T6 Executive, B6294T, 4T65 AWD, Bosch Motronic 7.0.
Platform P2 2004 S60R, B2524T4, AW50/51 AWD, B8444S TF80 AWD, Bosch Motronic 7.0, BorgWarner K24 turbocharger. V8 conversion in progress.

ferocity02
Posts: 161
Joined: Sat Oct 25, 2014 1:56 pm
Year and Model: 1998 S70 GLT
Location: Califfornia
Has thanked: 0
Been thanked: 10 times
United States of America
ferocity02

Re: Ongoing issue with Transmission Range Switch

Post by ferocity02 » Wed Feb 14, 2018 10:04 am

RickHaleParker wrote: ↑
Tue Feb 13, 2018 2:39 pm

Economy mode = Green-Orange grounded + Brown-Green open.
Sports mode = Green-Orange Open + Brown-Green grounded.
Weather mode = Green-Orange grounded + Brown-Green grounded.
Yep. I did this too and it checked out.

I'm curious if there is an issue with the wiring, because if I hold down the "W" for 25+ seconds, it does not throw a fault. This would indicate that the TCM is not receiving the signal from either wires.

I appreciate your help with this!

ferocity02
Posts: 161
Joined: Sat Oct 25, 2014 1:56 pm
Year and Model: 1998 S70 GLT
Location: Califfornia
Has thanked: 0
Been thanked: 10 times
United States of America
ferocity02

Re: Ongoing issue with Transmission Range Switch

Post by ferocity02 » Sat Feb 17, 2018 1:54 pm

I pulled apart the green connector at the drive mode switch and cleaned and tightened up the contacts. Then I ran another ground for this switch to the same ground point as the parking brake switch. Not sure if this will help at all.

Regarding the holding "W" down for 25 seconds causing a DTC. I found out that holding it down will rather throw code AT-121 Shift solenoid S1, short-circuit to ground. This does not cause the transmission up arrow to flash or the check engine light to appear.

Not sure what to make of this code?

ferocity02
Posts: 161
Joined: Sat Oct 25, 2014 1:56 pm
Year and Model: 1998 S70 GLT
Location: Califfornia
Has thanked: 0
Been thanked: 10 times
United States of America
ferocity02

Re: Ongoing issue with Transmission Range Switch

Post by ferocity02 » Tue Feb 27, 2018 9:09 pm

I replaced the TCM and no dice...

Any other suggestions?

User avatar
wizechatmgr
Posts: 1360
Joined: Thu Jan 12, 2017 1:07 pm
Year and Model: 1999 V70 XC AWD 2.4T
Location: Albany, NY area
Has thanked: 24 times
Been thanked: 61 times
Contact:
United States of America
wizechatmgr

Re: Ongoing issue with Transmission Range Switch

Post by wizechatmgr » Wed Feb 28, 2018 5:57 am

Know anyone in a neighboring state that doesn't follow CARB? Get it registered there.

How intermittent is the issue? Intermittent enough to get it to pass every x attempts?
Wisdom requires knowledge as a prerequisite, but knowledge can be developed due to a lack of wisdom.
In order to learn how to fix something, you must first learn how to break it.
1999 V70 XC AWD - ~190k miles

ferocity02
Posts: 161
Joined: Sat Oct 25, 2014 1:56 pm
Year and Model: 1998 S70 GLT
Location: Califfornia
Has thanked: 0
Been thanked: 10 times
United States of America
ferocity02

Re: Ongoing issue with Transmission Range Switch

Post by ferocity02 » Wed Feb 28, 2018 12:08 pm

wizechatmgr wrote: ↑
Wed Feb 28, 2018 5:57 am
Know anyone in a neighboring state that doesn't follow CARB? Get it registered there.

How intermittent is the issue? Intermittent enough to get it to pass every x attempts?
It's become more consistent now... The transmission will fault (flashing up arrow, stuck in 3rd) every third or fourth drive. This is not long enough to get the car's self-checks to pass. And the smog tech generally has to start/stop the engine several times during the test.

User avatar
RickHaleParker
Posts: 4396
Joined: Mon May 25, 2015 2:30 pm
Year and Model: See Signature below.
Location: Kansas
Has thanked: 3 times
Been thanked: 560 times
United States of America
RickHaleParker

Re: Ongoing issue with Transmission Range Switch

Post by RickHaleParker » Wed Feb 28, 2018 3:18 pm

The only thing you have not replaced is the wiring .....
--------
Platform: P80 1998 C70, B5234T3, 16T, AW50-42, Bosch Motronic 4.4, Special Edition package.
Platform: X40 (Nedcar) 2003 S40, B4204T3, 14T twin scroll AW55-50/51SN, Siemens EMS 2000.
Platform P2 2005 XC90 T6 Executive, B6294T, 4T65 AWD, Bosch Motronic 7.0.
Platform P2 2004 S60R, B2524T4, AW50/51 AWD, B8444S TF80 AWD, Bosch Motronic 7.0, BorgWarner K24 turbocharger. V8 conversion in progress.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post