IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy anything with this and it helps MVS!

1998 S70 2.5T Car stopped and does not start bad coil tel:1275174 Topic is solved

Help, Advice and DIY Tutorials on Volvo's extremely popular car line -- Volvo's 1990s "bread and butter" cars -- powered by the ubiquitous and durable Volvo inline 5-cylinder engine.

1992 - 1997 850, 850 R, 850 T5-R, 850 T5, 850 GLT
1997 - 2000 S70, S70 AWD
1997 - 2000 V70, V70 AWD
1997 - 2000 V70-XC
1997 - 2004 C70

Mupphack
Posts: 2
Joined: Fri Mar 30, 2018 12:47 pm
Year and Model: 1998 S70 2.5T
Location: Sweden
Has thanked: 1 time
Been thanked: 0
Sweden
Mupphack

1998 S70 2.5T Car stopped and does not start bad coil tel:1275174  Topic is solved

Post by Mupphack » Fri Mar 30, 2018 2:35 pm

Hello,

First of all, I am Swedish so some of my terms used might be considered weird, sorry for that. Anyway, my 1998 Volvo S70 2.5T (Turbo) has been "out of traffic" since last summer since I am currently studying so I only use the car during the summer when I work. Today, I decided to start and run the car a while since I am going to use it in 2 months. It started really easy but when I was about to drive away, it stopped. Seems like I did not have any gasoline in it so I just filled it up and it started again after maybe 15 seconds. I drove away and the car went really good. I drove for about 2 kilometers (1.2 miles?) before I decided that I wanted to test my old brakes so I applied the clutch and pressed the brake, then the car just stopped. The starter is fine but it is like no fuel is getting ignited. I received help from some random people to push the car down a road but zero happened when to run-start it or whatever you call it.

Later my dad came and we towed it to my parents house. The things I have tried and measured are:
  • Measured the cable to the fuel pump and it was good.
  • The fuel pump is giving a sound, though it is kinda low but I guess that it is normal?
  • Measured the fuel pressure on the fuel rail and it was around 2.6-2.7 bar (39 PSI) when the ignition was on and around 2.7-3.0 bar (39-44 PSI) when I tried starting the car.
  • Checked the OBD-2 diagnostics and the only thing there was something about the throttle position sensor which I erased. I think that this is a random code that just appears sometimes. I was also able to read the voltage to the same unit and it had 0.5 V originally and about 2-3 V something when I pressed the gas pedal. A weird thing though was that I was able to read the degrees of how much the throttle is open and it was 0 even if I pressed the gas pedal. I guess that this only gets registered when the car actually is running?
  • By a coincidence, my brother had a one year old camshaft sensor which I tried, but it still did not start.
  • Removed a spark plug and measured the compression for that cylinder which was about 10.5 bar (152 PSI). It is possible that it could have gotten higher if we tried starting it for some more seconds. We kinda had to "build up" the pressure with some turns on the starter, though the pressure stayed the same when we stopped.
  • Checked the spark on one of the spark plugs. It was not that clear and I do not know how well you are supposed to see the spark on a car? At least the spark was strong enough to ignite some gasoline which we forgot to dry/clean.
  • Measured the voltage to the ignition coil which was good.
  • By another coincidence (I accidentally dropped a tool and had to look down passed the cooler), I found out that the big earth cable to the engine block was loose (the one in the front of the engine, near the bottom of the cooler). I though that this was the obvious reason that the car did not start but it made no difference.
  • Spark plugs, distributor cap and rotor arm were replaced like 2 years ago and have gone maybe 5000 kilometers (3100 miles).

Here is some of my own guesses:
  • Bad crankshaft sensor? Though I read that it will only affect the starting of the car and that it should not stop a running car.
  • Ignition coil is broken, hence the not that bright spark from the plugs? Can this just suddenly break? Could be noted that the ignition coil was was lukewarm even 20 minutes after that the car stopped. I heard that it is impossible to know if these are broken without having an oscilloscope, is this true?
  • Bad fuel pump? But then I should had gotten bad fuel pressure, which I did not.
  • Bad throttle position sensor? But even if that were true, the car should still start with the help of the "idling engine"?
  • Maybe the loose earth cable were the problem and maybe I have flooded the engine with fuel, the "lawnmower Syndrome"? Though I should have gotten bad compression, which I did not.

Sorry for the wall of text. Anyone that have any suggestions/hints? Thanks!
Last edited by Mupphack on Sat Mar 31, 2018 5:08 am, edited 1 time in total.

User avatar
wizechatmgr
Posts: 1364
Joined: Thu Jan 12, 2017 1:07 pm
Year and Model: 1999 V70 XC AWD 2.4T
Location: Albany, NY area
Has thanked: 24 times
Been thanked: 62 times
Contact:
United States of America
wizechatmgr

Re: 1998 S70 2.5T Car stopped and does not start

Post by wizechatmgr » Fri Mar 30, 2018 5:18 pm

Do you smell petrol at the exhaust pipe when attempting to start it? If so, fuel injection is working. If not, then you have pressure to the rail but are likely lacking a signal from the ECU.
These users thanked the author wizechatmgr for the post:
Mupphack
Wisdom requires knowledge as a prerequisite, but knowledge can be developed due to a lack of wisdom.
In order to learn how to fix something, you must first learn how to break it.
1999 V70 XC AWD - ~190k miles

Mupphack
Posts: 2
Joined: Fri Mar 30, 2018 12:47 pm
Year and Model: 1998 S70 2.5T
Location: Sweden
Has thanked: 1 time
Been thanked: 0
Sweden
Mupphack

Re: 1998 S70 2.5T Car stopped and does not start

Post by Mupphack » Sat Mar 31, 2018 3:35 am

Hi! Thank you for your answer. It smelled a lot of gasoline so I guess that they works.

But I think I found the problem. We tried towing the car and nothing happened, but afterwards I saw that the ignition coil had cracked by the towing so I guess this probably must have been the problem all this time.

Sorry but I did not know how to resize the image:
Image

Post Reply
  • Similar Topics
    Replies
    Views
    Last post