IPD sale XeMODeX - Experts in Volvo Electronics

Get email notification of topic replies. Log in or register (free). Amazon Link Buy anything with this and it helps MVS!

No power after braking Topic is solved

Help, Advice and DIY Tutorials on Volvo's extremely popular car line -- Volvo's 1990s "bread and butter" cars -- powered by the ubiquitous and durable Volvo inline 5-cylinder engine.

1992 - 1997 850, 850 R, 850 T5-R, 850 T5, 850 GLT
1997 - 2000 S70, S70 AWD
1997 - 2000 V70, V70 AWD
1997 - 2000 V70-XC
1997 - 2004 C70

User avatar
erikv11
Posts: 10052
Joined: Sat Jul 25, 2009 2:03 pm
Year and Model: 850, S/V70, 06 S60R
Location: Iowa
Has thanked: 124 times
Been thanked: 351 times

Re: No power after braking  Topic is solved

Post by erikv11 »

Semi truck trailer? Forklift? :D
'95 854 T5-R, Motronic 4.4, 185k
'96 855 NA, 145k
'98 S70 NA, 220k (living out west)
'98 V70, T5 tune-injectors-turbo, LPT engine, 293k
'06 S60 R, 167k
'99 Camry V6 :shock: 130k
gone: '96 NA 850 210k, '98 NA V70 182k
Sommerfeldt
Posts: 1141
Joined: Tue Jul 29, 2008 1:25 pm
Year and Model: 1996 850 T5
Location: Oslo Area, Norway
Has thanked: 55 times
Been thanked: 37 times

Re: No power after braking

Post by Sommerfeldt »

:D :D :D
No matter what, cleaning stuff is always a good idea. :)

- S
'96 855 T5, R bumper and spoiler, Koni Yellows & blue H&R springs all 'round.
Cammer
Posts: 9
Joined: Fri Oct 05, 2018 2:27 pm
Year and Model: 1996 Volvo 850
Location: Vancouver
Has thanked: 4 times

Re: No power after braking

Post by Cammer »

Problem solved! I replaced all the vacuum hoses and fittings (some quite brittle). Problem persisted. I vacuum tested the MAP sensor -ok. Heat tested the Intake Air Temperature sensor - ok. I went back to the fuel system again (had already replaced the filter and checked pressure at the rail. Began with the pump - couldn’t hear it. I jumpered and bypassed the pump relay. Could hear the pump functioning! Replaced the old intermittent relay with one from inventory - the car is running like a champ. Thank you all for sharing your experience and expertise in helping me get back on the road!
User avatar
WhatAmIDoing
Posts: 761
Joined: Sat Jul 30, 2016 1:13 pm
Year and Model: 1998 S70 T5M
Location: North America
Has thanked: 66 times
Been thanked: 57 times

Re: No power after braking

Post by WhatAmIDoing »

Cammer wrote: Fri Nov 02, 2018 2:32 pm Problem solved! I replaced all the vacuum hoses and fittings (some quite brittle). Problem persisted. I vacuum tested the MAP sensor -ok. Heat tested the Intake Air Temperature sensor - ok. I went back to the fuel system again (had already replaced the filter and checked pressure at the rail. Began with the pump - couldn’t hear it. I jumpered and bypassed the pump relay. Could hear the pump functioning! Replaced the old intermittent relay with one from inventory - the car is running like a champ. Thank you all for sharing your experience and expertise in helping me get back on the road!
Those pesky fuel pump relays will get you. Always test the relay before you start tearing things apart and replacing things. I learned that the hard way.
'98 S70 T5M - 282,000+mi - forever a project
'99 S70 "AWD" - 220,000+mi - part out :cry:
Knows enough to be dangerous :wink:
User avatar
erikv11
Posts: 10052
Joined: Sat Jul 25, 2009 2:03 pm
Year and Model: 850, S/V70, 06 S60R
Location: Iowa
Has thanked: 124 times
Been thanked: 351 times

Re: No power after braking

Post by erikv11 »

Eh, totally worth it to replace all of the brittle vacuum lines, no harm done there. Otherwise he just tested things, smart moves all.

Cammer, glad you solved it! I had a fuel pump relay die on me this morning, too ...
'95 854 T5-R, Motronic 4.4, 185k
'96 855 NA, 145k
'98 S70 NA, 220k (living out west)
'98 V70, T5 tune-injectors-turbo, LPT engine, 293k
'06 S60 R, 167k
'99 Camry V6 :shock: 130k
gone: '96 NA 850 210k, '98 NA V70 182k
Post Reply
  • Similar Topics
    Replies
    Views
    Last post