IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

ECM-6300 and ECM-6B00 2000 V70R [BAD Battery to fusebox supply cable!] EPIC Troubleshooting Topic is solved

Help, Advice and DIY Tutorials on Volvo's extremely popular car line -- Volvo's 1990s "bread and butter" cars -- powered by the ubiquitous and durable Volvo inline 5-cylinder engine.

1992 - 1997 850, 850 R, 850 T5-R, 850 T5, 850 GLT
1997 - 2000 S70, S70 AWD
1997 - 2000 V70, V70 AWD
1997 - 2000 V70-XC
1997 - 2004 C70

Post Reply
User avatar
bmdubya1198
Posts: 3392
Joined: Tue Dec 30, 2014 10:45 am
Year and Model: '98 V70 GLT
Location: Charlotte, NC
Has thanked: 32 times
Been thanked: 108 times
United States of America
bmdubya1198

Re: ECM-6300 and ECM-6B00 2000 V70R

Post by bmdubya1198 » Thu Apr 18, 2019 7:15 pm

New O2 sensor didn't fix anything. After checking VIDA, I'm getting the same reading from the old and new sensors when revving in neutral (see log below).

Now I'm having a strange issue where when I let off the gas and press the clutch to shift, the engine continues to rev, and with the engine spinning free of the transmission, it came close to over revving multiple times while driving it earlier. I disconnected the battery and let it sit for a while then test drove again... same issue. No new codes.

I ran the ETM test earlier on VIDA and the differential between the potentiometers was something like 2.7 degrees, and VIDA says the maximum allowable difference is 13, so my ETM appears good. However I think the humming noise I've been hearing may be the ETM. I noticed that as soon as I rev the car over idle, the noise goes away.
You do not have the required permissions to view the files attached to this post.


2000 V70R Venetian Red/Charcoal M56 Swapped 191k
2000 S70 GLT Mystic Silver/Taupe 2??k
2003 S60 2.4T Silver/Black 108k
2007 XC90 V8 AWD Sport Titanium Grey/Black 160k
1993 944 Base Beige/Beige 221k
1992 Miata Mariner Blue/Black 146k
Sold-
1998 V70 GLT Black/Beige 193k
1998 S90- Silver/Gray 207k
1995 850 GLT Tropic Green... crushed
2001 S60 2.4T Black/Black 230k
1988 744 Turbo M46 Beige Metallic/Beige 188k- Never should have sold it


Need used parts? PM me!

User avatar
bmdubya1198
Posts: 3392
Joined: Tue Dec 30, 2014 10:45 am
Year and Model: '98 V70 GLT
Location: Charlotte, NC
Has thanked: 32 times
Been thanked: 108 times
United States of America
bmdubya1198

Re: ECM-6300 and ECM-6B00 2000 V70R

Post by bmdubya1198 » Sun Apr 28, 2019 9:36 pm

I guess I should probably update this thread now that I swapped ETMs, being that I mentioned it in my last post. I swapped back the original ETM after rebuilding it with the Sacer contactless throttle position sensor. The difference between the sensors is now about 1.7 degrees, even better than before. I don't think there's any problem at all with the ETM.

I am also pretty positive that the noise I mentioned (separate thread on that issue, but it could be related) is not the ETM. I took another video today, I'll post it in the appropriate thread in the interest of separating these problems.

I also took a video of the CEL doing its weird "pulsing". I am pretty certain that this issue is related to the codes. The ETS light does the same thing. The only time this happens is if the light is on due to a fault. If I manually activate the lights in VIDA, they glow solid as they should. Same thing when I first turn the key on, no pulsing/flashing.

So... through logging and basic troubleshooting, I can't find any issues at all that could cause these codes. How likely is it that my ECU is the problem? And how easy is it to get another one and program it to my VIN? Or the cluster, for that matter. Maybe that's the problem?


2000 V70R Venetian Red/Charcoal M56 Swapped 191k
2000 S70 GLT Mystic Silver/Taupe 2??k
2003 S60 2.4T Silver/Black 108k
2007 XC90 V8 AWD Sport Titanium Grey/Black 160k
1993 944 Base Beige/Beige 221k
1992 Miata Mariner Blue/Black 146k
Sold-
1998 V70 GLT Black/Beige 193k
1998 S90- Silver/Gray 207k
1995 850 GLT Tropic Green... crushed
2001 S60 2.4T Black/Black 230k
1988 744 Turbo M46 Beige Metallic/Beige 188k- Never should have sold it


Need used parts? PM me!

Sommerfeldt
Posts: 1113
Joined: Tue Jul 29, 2008 1:25 pm
Year and Model: 1996 850 T5
Location: Oslo Area, Norway
Has thanked: 50 times
Been thanked: 30 times
Norway
Sommerfeldt

Re: ECM-6300 and ECM-6B00 2000 V70R

Post by Sommerfeldt » Tue Apr 30, 2019 2:28 am

I've been looking through some Swedish and Norwegian forums, and it seems that the 6B00 is pretty closely associated with an ECU failure when there's no actual malfunction to be found. :( The ECU itself isn't hard to find, as far as I can tell, but getting it programmed to immo and VIN is the hurdle. Rumor has it that ARD can do that for you, but it seems like it's going to cost you a few hundred bucks, whichever way you turn. :(

- S


'96 855 T5, R bumper and spoiler, Koni Yellows & blue H&R springs all 'round.

User avatar
abscate
MVS Moderator
Posts: 19247
Joined: Sun Feb 17, 2013 5:54 pm
Year and Model: 99T5 ,99S70,2005V70
Location: NYC, ALBANY NY
Has thanked: 232 times
Been thanked: 767 times
Trinidad & Tobago
abscate

Re: ECM-6300 and ECM-6B00 2000 V70R

Post by abscate » Tue Apr 30, 2019 5:39 am

Bmdub....

I think you are running ME7 on that car

The CEL gets a 12V feed from the CDM and is lit by grounding through the ECM pin B46

There isn’t anyth8ng else between the light and a ECM so I think you’ve got it narrowed down

Yagger can clone your ECM for you,


Empty Nester
A Captain in a Sea of Estrogen
1999-V70-T5M56 2005-V70-M56 1999-S70 VW T4 BMW
Link to Maintenance record thread
Link To Volvo Glossary

User avatar
bmdubya1198
Posts: 3392
Joined: Tue Dec 30, 2014 10:45 am
Year and Model: '98 V70 GLT
Location: Charlotte, NC
Has thanked: 32 times
Been thanked: 108 times
United States of America
bmdubya1198

Re: ECM-6300 and ECM-6B00 2000 V70R

Post by bmdubya1198 » Tue Apr 30, 2019 8:21 am

I'll have to message someone who can clone the ECU and see how I go about taking care of that. If I can't find any other issues, that may be what I need to do.
The short to ground detail of that code makes me think that it's somehow an internal fault on the ECU if the ECU is what grounds that signal.

I also noticed the ECU failure an 6B00 on those forums, interestingly none of them were in English. It seems this is very uncommon, but with my luck, that's exactly what's wrong.


2000 V70R Venetian Red/Charcoal M56 Swapped 191k
2000 S70 GLT Mystic Silver/Taupe 2??k
2003 S60 2.4T Silver/Black 108k
2007 XC90 V8 AWD Sport Titanium Grey/Black 160k
1993 944 Base Beige/Beige 221k
1992 Miata Mariner Blue/Black 146k
Sold-
1998 V70 GLT Black/Beige 193k
1998 S90- Silver/Gray 207k
1995 850 GLT Tropic Green... crushed
2001 S60 2.4T Black/Black 230k
1988 744 Turbo M46 Beige Metallic/Beige 188k- Never should have sold it


Need used parts? PM me!

User avatar
RickHaleParker
Posts: 3250
Joined: Mon May 25, 2015 2:30 pm
Year and Model: See Signature below.
Location: Kansas
Has thanked: 3 times
Been thanked: 382 times
United States of America
RickHaleParker

Re: ECM-6300 and ECM-6B00 2000 V70R

Post by RickHaleParker » Tue Apr 30, 2019 1:49 pm

bmdubya1198 wrote:
Tue Apr 16, 2019 6:04 pm
ECM-6300 ETS warning lamp. Signal too low. Intermittent fault.
ECM-6B00 Malfunction Indicator Lamp (MIL). Signal too low. Intermittent fault.
Did you replace the bulbs with LEDs or something other the the original bulb sizes?


Platform: P80 1998 C70, B5234T3, 16T, AW50-42, Bosch Motronic 4.4, Special Edition package, Plant: Uddevalla Sweden.

Platform: X40 (Nedcar) 2003 S40, B4204T3, 14T twin scroll AW55-50/51SN, Siemens EMS 2000. Plant: Born Netherlands.

Platform P2 2005 XC90 T6 Executive, B6294T, 4T65 AWD, Bosch Motronic 7.0,
Plant Torslanda Sweden.
----------------------------------------------------------------
1997 S90, B6304S, AW30-42, Bosch Motronic 4.4 - Sold

User avatar
bmdubya1198
Posts: 3392
Joined: Tue Dec 30, 2014 10:45 am
Year and Model: '98 V70 GLT
Location: Charlotte, NC
Has thanked: 32 times
Been thanked: 108 times
United States of America
bmdubya1198

Re: ECM-6300 and ECM-6B00 2000 V70R

Post by bmdubya1198 » Tue Apr 30, 2019 6:51 pm

RickHaleParker wrote:
Tue Apr 30, 2019 1:49 pm
bmdubya1198 wrote:
Tue Apr 16, 2019 6:04 pm
ECM-6300 ETS warning lamp. Signal too low. Intermittent fault.
ECM-6B00 Malfunction Indicator Lamp (MIL). Signal too low. Intermittent fault.
Did you replace the bulbs with LEDs or something other the the original bulb sizes?
I have not, but it's probably not a bad idea to check the bulbs themselves.


2000 V70R Venetian Red/Charcoal M56 Swapped 191k
2000 S70 GLT Mystic Silver/Taupe 2??k
2003 S60 2.4T Silver/Black 108k
2007 XC90 V8 AWD Sport Titanium Grey/Black 160k
1993 944 Base Beige/Beige 221k
1992 Miata Mariner Blue/Black 146k
Sold-
1998 V70 GLT Black/Beige 193k
1998 S90- Silver/Gray 207k
1995 850 GLT Tropic Green... crushed
2001 S60 2.4T Black/Black 230k
1988 744 Turbo M46 Beige Metallic/Beige 188k- Never should have sold it


Need used parts? PM me!

User avatar
RickHaleParker
Posts: 3250
Joined: Mon May 25, 2015 2:30 pm
Year and Model: See Signature below.
Location: Kansas
Has thanked: 3 times
Been thanked: 382 times
United States of America
RickHaleParker

Re: ECM-6300 and ECM-6B00 2000 V70R

Post by RickHaleParker » Tue Apr 30, 2019 7:02 pm

bmdubya1198 wrote:
Tue Apr 30, 2019 6:51 pm
I have not, but it's probably not a bad idea to check the bulbs themselves.
Turn on the key. They should light up during the lamp check. Tap on them, see if you can get them to intermittent.


Platform: P80 1998 C70, B5234T3, 16T, AW50-42, Bosch Motronic 4.4, Special Edition package, Plant: Uddevalla Sweden.

Platform: X40 (Nedcar) 2003 S40, B4204T3, 14T twin scroll AW55-50/51SN, Siemens EMS 2000. Plant: Born Netherlands.

Platform P2 2005 XC90 T6 Executive, B6294T, 4T65 AWD, Bosch Motronic 7.0,
Plant Torslanda Sweden.
----------------------------------------------------------------
1997 S90, B6304S, AW30-42, Bosch Motronic 4.4 - Sold

User avatar
bmdubya1198
Posts: 3392
Joined: Tue Dec 30, 2014 10:45 am
Year and Model: '98 V70 GLT
Location: Charlotte, NC
Has thanked: 32 times
Been thanked: 108 times
United States of America
bmdubya1198

Re: ECM-6300 and ECM-6B00 2000 V70R

Post by bmdubya1198 » Tue Apr 30, 2019 7:23 pm

I know they both come on when I first turn the key on. I’ll try tapping on them tomorrow just to make sure that’s not the issue.


2000 V70R Venetian Red/Charcoal M56 Swapped 191k
2000 S70 GLT Mystic Silver/Taupe 2??k
2003 S60 2.4T Silver/Black 108k
2007 XC90 V8 AWD Sport Titanium Grey/Black 160k
1993 944 Base Beige/Beige 221k
1992 Miata Mariner Blue/Black 146k
Sold-
1998 V70 GLT Black/Beige 193k
1998 S90- Silver/Gray 207k
1995 850 GLT Tropic Green... crushed
2001 S60 2.4T Black/Black 230k
1988 744 Turbo M46 Beige Metallic/Beige 188k- Never should have sold it


Need used parts? PM me!

User avatar
RickHaleParker
Posts: 3250
Joined: Mon May 25, 2015 2:30 pm
Year and Model: See Signature below.
Location: Kansas
Has thanked: 3 times
Been thanked: 382 times
United States of America
RickHaleParker

Re: ECM-6300 and ECM-6B00 2000 V70R

Post by RickHaleParker » Tue Apr 30, 2019 10:56 pm

bmdubya1198 wrote:
Tue Apr 30, 2019 7:23 pm
I’ll try tapping on them tomorrow just to make sure that’s not the issue.
If they intermittent you can be sure the bulbs are an issue.
If they don't intermittent, you may not be physically shocking them enough.


Platform: P80 1998 C70, B5234T3, 16T, AW50-42, Bosch Motronic 4.4, Special Edition package, Plant: Uddevalla Sweden.

Platform: X40 (Nedcar) 2003 S40, B4204T3, 14T twin scroll AW55-50/51SN, Siemens EMS 2000. Plant: Born Netherlands.

Platform P2 2005 XC90 T6 Executive, B6294T, 4T65 AWD, Bosch Motronic 7.0,
Plant Torslanda Sweden.
----------------------------------------------------------------
1997 S90, B6304S, AW30-42, Bosch Motronic 4.4 - Sold

Post Reply
  • Similar Topics
    Replies
    Views
    Last post