IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

ECM-6300 and ECM-6B00 2000 V70R [BAD Battery to fusebox supply cable!] EPIC Troubleshooting Topic is solved

Help, Advice and DIY Tutorials on Volvo's extremely popular car line -- Volvo's 1990s "bread and butter" cars -- powered by the ubiquitous and durable Volvo inline 5-cylinder engine.

1992 - 1997 850, 850 R, 850 T5-R, 850 T5, 850 GLT
1997 - 2000 S70, S70 AWD
1997 - 2000 V70, V70 AWD
1997 - 2000 V70-XC
1997 - 2004 C70

Post Reply
User avatar
bmdubya1198
Posts: 3390
Joined: Tue Dec 30, 2014 10:45 am
Year and Model: '98 V70 GLT
Location: Charlotte, NC
Has thanked: 31 times
Been thanked: 108 times
United States of America
bmdubya1198

Re: ECM-6300 and ECM-6B00 2000 V70R

Post by bmdubya1198 » Wed May 01, 2019 7:36 am

Alright let's clarify... the codes are both showing INTERMITTENT. Neither are permanent. I have cleared codes several times, and these two keep returning.
The lights flicker only if they're on due to a code. If I command them on via VIDA, they glow solid. Same goes for when they key is in the ON position and they self-test.


2000 V70R Venetian Red/Charcoal M56 Swapped 191k
2000 S70 GLT Mystic Silver/Taupe 2??k
2003 S60 2.4T Silver/Black 108k
2007 XC90 V8 AWD Sport Titanium Grey/Black 160k
1993 944 Base Beige/Beige 221k
1992 Miata Mariner Blue/Black 146k
Sold-
1998 V70 GLT Black/Beige 193k
1998 S90- Silver/Gray 207k
1995 850 GLT Tropic Green... crushed
2001 S60 2.4T Black/Black 230k
1988 744 Turbo M46 Beige Metallic/Beige 188k- Never should have sold it


Need used parts? PM me!

User avatar
bmdubya1198
Posts: 3390
Joined: Tue Dec 30, 2014 10:45 am
Year and Model: '98 V70 GLT
Location: Charlotte, NC
Has thanked: 31 times
Been thanked: 108 times
United States of America
bmdubya1198

Re: ECM-6300 and ECM-6B00 2000 V70R

Post by bmdubya1198 » Sat Jul 20, 2019 2:14 pm

Lemme revive this thread and see if anyone will find it and offer some input... I've been working on this car since April with no changes. All other little issues seem to have been resolved, but these codes won't go away.

To reiterate... the only thing I notice is that sometimes, after starting the car when the warning lights are in their test phase just before turning off, I'll notice the CEL flicker while it's illuminated, and turn off as it's supposed to. Other times, it doesn't do that. When it flickers, I hear the ETM whining. I've done every bit of diagnostics I know of, plus what anyone and everyone has suggested, and I cannot find ANYTHING wrong.

The problem, I think, is that I keep getting redirected to other possible issues, but let's remember... these are the only two codes I have (aside from a random pair of ABS codes that appeared today, and the clutch sensor which is not plugged in), and the only symptoms I have are directly related to the ETM, ECM, and CDM. Nothing else.

I've checked the signal wires (pink for ETS light, brown/white for CEL) for a short to ground. When I disconnect the 24/13D connector (under dash, the only connector between the ECM and CDM) I get an open circuit to ground in all key positions. Therefore, I do not believe the wires are a problem.
Both wires will show continuity to ground when everything is connected, but that's due to the way the circuit is designed in the CDM. So from what I understand, they are supposed to be grounded (albeit at 30ish ohms).

Everything else in the car is fine (except for the low boost and lack of AC, both of those I know the where the problem is), so as much as I'd like to ignore the ECM as a suspect, I really believe it's a possibility. Although I appreciate everybody who has helped me on here and other forums and Facebook, I have yet to receive any advice that's gotten me any closer to the problem. VIDA has been useless, and unfortunately so has Swedespeed (which is odd, those guys tend to be better with electrical stuff). I've contact Hilton about this, and he doesn't seem to have any idea either.

I am NOT bringing this or any of my cars to the dealer, I refuse to give them my business at their outrageous prices... plus I can't allow myself to pawn work off onto someone else, it goes against my "do everything myself" mentality!


2000 V70R Venetian Red/Charcoal M56 Swapped 191k
2000 S70 GLT Mystic Silver/Taupe 2??k
2003 S60 2.4T Silver/Black 108k
2007 XC90 V8 AWD Sport Titanium Grey/Black 160k
1993 944 Base Beige/Beige 221k
1992 Miata Mariner Blue/Black 146k
Sold-
1998 V70 GLT Black/Beige 193k
1998 S90- Silver/Gray 207k
1995 850 GLT Tropic Green... crushed
2001 S60 2.4T Black/Black 230k
1988 744 Turbo M46 Beige Metallic/Beige 188k- Never should have sold it


Need used parts? PM me!

jimmy57
Posts: 6445
Joined: Fri Nov 12, 2010 9:25 am
Year and Model: 2004 V70R GT, et al
Location: Ponder Texas
Has thanked: 2 times
Been thanked: 198 times
jimmy57

Re: ECM-6300 and ECM-6B00 2000 V70R

Post by jimmy57 » Sat Jul 20, 2019 4:11 pm

Those light circuits would be feeding battery voltage to the pins on the ECM when the lamps are not lit. With age the pins on modules can get corrosion and the female terminals in ECM base could have corrosion as that area is able to get wet with engine washing and puddle splashing. Remove ECM and inspect closely. If there is an issue with those terminals then there can be issues with others not yet causing DTCs because they are wrong signals but not out of plausible range for those signals.



User avatar
abscate
MVS Moderator
Posts: 19223
Joined: Sun Feb 17, 2013 5:54 pm
Year and Model: 99T5 ,99S70,2005V70
Location: NYC, ALBANY NY
Has thanked: 230 times
Been thanked: 764 times
Trinidad & Tobago
abscate

Re: ECM-6300 and ECM-6B00 2000 V70R

Post by abscate » Sat Jul 20, 2019 6:47 pm

Yeah you are pretty much down to cloning a new ECM and putting a new connector here.


Empty Nester
A Captain in a Sea of Estrogen
1999-V70-T5M56 2005-V70-M56 1999-S70 VW T4 BMW
Link to Maintenance record thread
Link To Volvo Glossary

User avatar
bmdubya1198
Posts: 3390
Joined: Tue Dec 30, 2014 10:45 am
Year and Model: '98 V70 GLT
Location: Charlotte, NC
Has thanked: 31 times
Been thanked: 108 times
United States of America
bmdubya1198

Re: ECM-6300 and ECM-6B00 2000 V70R

Post by bmdubya1198 » Sat Jul 20, 2019 7:30 pm

I've noticed that the terminals don't quite align with the connector due to it being two separate connectors within the A- and B-connectors, but I'm usually able to slide them to the right position to align it with the ECU. I'll pull it again tomorrow just to be sure.

It's also worth mentioning that IMM-321 appeared today, and I know for sure that it's associated with starting issues after clearing codes in VIDA. It's not every time, but several times when I've read/cleared codes, when I go to start the car it'll run for a couple seconds, then stall. After that, no matter how many times I turn it off and on, it'll crank and crank but won't start. Then I'll pull DICE off the OBD port and it'll crank right up. I find that really odd, and it has to be linked somehow.

There is a wire running between the OBD2 port and the immobilizer, which has an additional junction point on automatic models sending that into the TCM connector. When I removed automatic wiring during the swap, I left that wire alone so I wouldn't hurt the immobilizer function. Otherwise, there are no other differences between auto and manual wiring for this.

Also, when reading codes, my interior lighting (dome lights) will turn off and back on several times. Never noticed this in a P80 before.


2000 V70R Venetian Red/Charcoal M56 Swapped 191k
2000 S70 GLT Mystic Silver/Taupe 2??k
2003 S60 2.4T Silver/Black 108k
2007 XC90 V8 AWD Sport Titanium Grey/Black 160k
1993 944 Base Beige/Beige 221k
1992 Miata Mariner Blue/Black 146k
Sold-
1998 V70 GLT Black/Beige 193k
1998 S90- Silver/Gray 207k
1995 850 GLT Tropic Green... crushed
2001 S60 2.4T Black/Black 230k
1988 744 Turbo M46 Beige Metallic/Beige 188k- Never should have sold it


Need used parts? PM me!

User avatar
abscate
MVS Moderator
Posts: 19223
Joined: Sun Feb 17, 2013 5:54 pm
Year and Model: 99T5 ,99S70,2005V70
Location: NYC, ALBANY NY
Has thanked: 230 times
Been thanked: 764 times
Trinidad & Tobago
abscate

Re: ECM-6300 and ECM-6B00 2000 V70R

Post by abscate » Sun Jul 21, 2019 3:47 am

More weirdness. I’m in dome light Hades on my S70, it is quite a complicated function on that system, involving at least three modules I can see.


Empty Nester
A Captain in a Sea of Estrogen
1999-V70-T5M56 2005-V70-M56 1999-S70 VW T4 BMW
Link to Maintenance record thread
Link To Volvo Glossary

User avatar
bmdubya1198
Posts: 3390
Joined: Tue Dec 30, 2014 10:45 am
Year and Model: '98 V70 GLT
Location: Charlotte, NC
Has thanked: 31 times
Been thanked: 108 times
United States of America
bmdubya1198

Re: ECM-6300 and ECM-6B00 2000 V70R

Post by bmdubya1198 » Sun Jul 21, 2019 7:57 am

Yup... it's a pain.


2000 V70R Venetian Red/Charcoal M56 Swapped 191k
2000 S70 GLT Mystic Silver/Taupe 2??k
2003 S60 2.4T Silver/Black 108k
2007 XC90 V8 AWD Sport Titanium Grey/Black 160k
1993 944 Base Beige/Beige 221k
1992 Miata Mariner Blue/Black 146k
Sold-
1998 V70 GLT Black/Beige 193k
1998 S90- Silver/Gray 207k
1995 850 GLT Tropic Green... crushed
2001 S60 2.4T Black/Black 230k
1988 744 Turbo M46 Beige Metallic/Beige 188k- Never should have sold it


Need used parts? PM me!

scot850
Posts: 5591
Joined: Mon Apr 05, 2010 2:46 pm
Year and Model: 2000 V70 R
Location: Calgary, Alberta, Canada
Has thanked: 9 times
Been thanked: 149 times
Canada
scot850

Re: ECM-6300 and ECM-6B00 2000 V70R  Topic is solved

Post by scot850 » Mon Jul 22, 2019 7:44 am

I'm sure you have already checked or swapped the B+ cable in the main fusebox and the electrical portion of the ignition switch?

The B+ cable can look ok, but undo the nut in the fusebox and look at the cable under it. Mine looked ok, but found it had almost totally melted and had bare areas that could potentially short out.

Not sure if it would help, but I have a spare ECU from a 2000 V70R, and also a ETM from a 2000 V70XC that I had connected to my 2000 V70R as suggested by precopster to see if it worked. It whined like a good un so should be good. Also think I may have a good electrical portion of an ignition switch. If you fail to get any further I can send the parts for you to swap out on a trial basis. I would like them back as they are my back up stash.

Neil.


2000 V70 R - still being an endless PITA
2006 XC70
2003 Toyota 4Runner V8 Limited
2015 Kia Sportage EX-L
1993 850 GLT -Sold
1998 V70 XC - Sold
1997 Volvo 850 SE NA - Went to niece in California - Sold
2000 V70 SE NA - New project and test bed - Sold

User avatar
bmdubya1198
Posts: 3390
Joined: Tue Dec 30, 2014 10:45 am
Year and Model: '98 V70 GLT
Location: Charlotte, NC
Has thanked: 31 times
Been thanked: 108 times
United States of America
bmdubya1198

Re: ECM-6300 and ECM-6B00 2000 V70R

Post by bmdubya1198 » Mon Jul 22, 2019 8:21 am

scot850 wrote:
Mon Jul 22, 2019 7:44 am
I'm sure you have already checked or swapped the B+ cable in the main fusebox and the electrical portion of the ignition switch?

The B+ cable can look ok, but undo the nut in the fusebox and look at the cable under it. Mine looked ok, but found it had almost totally melted and had bare areas that could potentially short out.

Not sure if it would help, but I have a spare ECU from a 2000 V70R, and also a ETM from a 2000 V70XC that I had connected to my 2000 V70R as suggested by precopster to see if it worked. It whined like a good un so should be good. Also think I may have a good electrical portion of an ignition switch. If you fail to get any further I can send the parts for you to swap out on a trial basis. I would like them back as they are my back up stash.

Neil.
Thanks, I'll definitely let you know if I need to borrow any of that to check!

I checked the voltage drop on that B+ cable, IIRC there was not a significant enough drop to replace. It looks to be in pretty good shape, so I'm not too concerned about it yet. I may check that again just to be sure.
Fortunately I was able to borrow the ignition switch electrical portion from my S60 and I had a spare from an '04 C70, but I haven't noticed any changes after replacing it.


2000 V70R Venetian Red/Charcoal M56 Swapped 191k
2000 S70 GLT Mystic Silver/Taupe 2??k
2003 S60 2.4T Silver/Black 108k
2007 XC90 V8 AWD Sport Titanium Grey/Black 160k
1993 944 Base Beige/Beige 221k
1992 Miata Mariner Blue/Black 146k
Sold-
1998 V70 GLT Black/Beige 193k
1998 S90- Silver/Gray 207k
1995 850 GLT Tropic Green... crushed
2001 S60 2.4T Black/Black 230k
1988 744 Turbo M46 Beige Metallic/Beige 188k- Never should have sold it


Need used parts? PM me!

User avatar
abscate
MVS Moderator
Posts: 19223
Joined: Sun Feb 17, 2013 5:54 pm
Year and Model: 99T5 ,99S70,2005V70
Location: NYC, ALBANY NY
Has thanked: 230 times
Been thanked: 764 times
Trinidad & Tobago
abscate

Re: ECM-6300 and ECM-6B00 2000 V70R

Post by abscate » Mon Jul 22, 2019 11:45 am

I’m still not happy about the MT s2ap and getting that ECM to play there.

I’m guessing this did not code pre swap?


Empty Nester
A Captain in a Sea of Estrogen
1999-V70-T5M56 2005-V70-M56 1999-S70 VW T4 BMW
Link to Maintenance record thread
Link To Volvo Glossary

Post Reply
  • Similar Topics
    Replies
    Views
    Last post