blower motor auto postion not working Topic is solved

Help, Advice and DIY Tutorials on Volvo's extremely popular car line -- Volvo's 1990s "bread and butter" cars -- powered by the ubiquitous and durable Volvo inline 5-cylinder engine.

1992 - 1997 850, 850 R, 850 T5-R, 850 T5, 850 GLT
1997 - 2000 S70, S70 AWD
1997 - 2000 V70, V70 AWD
1997 - 2000 V70-XC
1997 - 2004 C70

Post Reply
Jaumme
Posts: 37
Joined: Sat Jan 19, 2019 2:50 am
Year and Model: Volvo 850 T5 1993
Location: Valencia
Been thanked: 2 times

blower motor auto postion not working

Post by Jaumme »

when i place the blower motor in auto mode the blower motor and the entire climate control components stop working, i have 3 ecc one is dead because the damper motors wont work with this one but the auto in blower motor is working. the other 2 are working perfect but the auto blower is not working i didnt find any information about that, anyone knows something?

User avatar
jreed
Posts: 1229
Joined: Sun Mar 08, 2009 5:43 am
Year and Model: '97 Volvo 855 GLT
Location: RTP, North Carolina
Has thanked: 117 times
Been thanked: 61 times

Post by jreed »

You could open up the ECC unit and inspect the components inside for damage. Some people have reported damage to the circuit board, capacitors, diodes and other components on the board. While you have it open, you could also test the sliding switch to see if the switch is working correctly when you slide it all the way over to "AUTO" mode.
Have you tried to connect a code reader to the ECC unit to check for error codes? That may provide clues about what is not working correctly. See for example: viewtopic.php?f=1&t=64888
1997 855 GLT (Light Pressure Turbo) still going strong. Previous: 1986 240 GL rusted out in '06, 1985 Saab 900T rusted out in '95, 1975 Saab 99 rusted out in '95, 1973 Saab 99 rusted out in '94

User avatar
RickHaleParker
Posts: 5204
Joined: Mon May 25, 2015 2:30 pm
Year and Model: See Signature below.
Location: Kansas
Has thanked: 3 times
Been thanked: 661 times

Post by RickHaleParker »

Unit #1: Auto works Dampers do not.
Unit #2 & #3: Dampers works but Auto does not.

Clearly the external circuits are all working. That leaves only two possibilities, you have three defective ECC units or some of them are defective and the others are the incapable reversions of the ECC. There are 10 revisions of the 850 ECC.
The '93 850s used ECC revisions 2 - 5.

Read this thread.
Last edited by RickHaleParker on Tue Jun 18, 2019 12:21 pm, edited 1 time in total.
1998 C70, B5234T3, 16T, AW50-42, Bosch Motronic 4.4, Special Edition package.
2003 S40, B4204T3, 14T twin scroll AW55-50/51SN, Siemens EMS 2000.
2004 S60R, B8444S TF80 AWD. Yamaha V8 conversion
2005 XC90 T6 Executive, B6294T, 4T65 AWD, Bosch Motronic 7.0.

jimmy57
Posts: 6674
Joined: Fri Nov 12, 2010 9:25 am
Year and Model: 2004 V70R GT, et al
Location: Ponder Texas
Has thanked: 4 times
Been thanked: 276 times

Post by jimmy57 »

The early versions require a ground signal on one of the pins supplied by ignition module or the Motronic ECM if 94 turbo (I don't remember the numbers but I have answered this several times and listed the pins.) and the later are designed to get engine running info from alternator charge light circuit as an engine run signal. The simple fix for the early ones is to cut the wire behind the ECC module and ground it. If you search you should find the earlier replies with pin and wire color info.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post