IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

Temp gauge fluctuating even after replacing thermostat and CTS

Help, Advice and DIY Tutorials on Volvo's extremely popular car line -- Volvo's 1990s "bread and butter" cars -- powered by the ubiquitous and durable Volvo inline 5-cylinder engine.

1992 - 1997 850, 850 R, 850 T5-R, 850 T5, 850 GLT
1997 - 2000 S70, S70 AWD
1997 - 2000 V70, V70 AWD
1997 - 2000 V70-XC
1997 - 2004 C70

User avatar
wizechatmgr
Posts: 1241
Joined: Thu Jan 12, 2017 1:07 pm
Year and Model: 1999 V70 XC AWD 2.4T
Location: Albany, NY area
Has thanked: 20 times
Been thanked: 51 times
Contact:
United States of America
wizechatmgr

Re: Temp gauge fluctuating even after replacing thermostat and CTS

Post by wizechatmgr » Thu Oct 03, 2019 8:38 am

RB3 wrote:
Mon Sep 30, 2019 11:03 am
Gonna try this today. Stat and sensor replaced last fall. Not sure if OEM. Also had water pump and timing belt replaced 2 mos. ago so naturally coolant was involved. I haven't noticed any fluctuations since and only topped it once. But after you mentioned the air, I did just run the heat the past couple mornings/evenings.

Been having random electrical issues as well. Replaced battery 2 days ago.

Thanks for tip on Stat.
I'd suggest having that alternator checked as well as the hot wire going to the fuse block. Alternator could have toasted battery from letting AC through the system - would cause all kinds of weird stuff to happen.


Wisdom requires knowledge as a prerequisite, but knowledge can be developed due to a lack of wisdom.
In order to learn how to fix something, you must first learn how to break it.
1999 V70 XC AWD - ~183k miles

RB3
Posts: 8
Joined: Sun Sep 29, 2019 4:47 am
Year and Model: 99 V70
Location: California
Has thanked: 0
Been thanked: 0
United States of America
RB3

Re: Temp gauge fluctuating even after replacing thermostat and CTS

Post by RB3 » Tue Oct 15, 2019 4:55 pm

Still no luck with the guage.
Gonna get the codes read I guess. Should I replace stat or sensor just to rule out? Maybe after codes?

Could the temp and possible fuel thing be related? Hesitation on acceleration and bogs if I coast. Almost like I'm braking. Thanks in advance



RB3
Posts: 8
Joined: Sun Sep 29, 2019 4:47 am
Year and Model: 99 V70
Location: California
Has thanked: 0
Been thanked: 0
United States of America
RB3

Re: Temp gauge fluctuating even after replacing thermostat and CTS

Post by RB3 » Sun Oct 27, 2019 1:14 pm

Original issues: Lacking power. Hesitation. Idle surges.
Then Temp gauge fluctuating below normal. Fan running after turning it off.
Hard Starts.
Started by replacing battery. Helped with starts.
Removed thermostat and drove it. Gauge still fluctuated.
Cleaned throttle body. Didnt notice much difference. Note ETS warning light never came on during several weeks of the original hesitation.
24 hours after cleaning ETS appeared. Ugh.
but needed to replace the CTS. Did that 4 days ago.
Temp gauge has been normal. Great!. It even seems to run better. No hesitations for few days. Seems like idle not hunting.
Then shortly after ETS warning lamp disappears. Coincidence? for 2 days.
But now reappeared again. 160,000

Mechanic was busy so didnt get in to have codes read and cleared. Can take to Auto store but they dont clear em.

lf Im not mistaken I believe this TB was replaced. But I dont see any labels white or yellow. might it be underneath. havent gotten a mirror out.

Still having electrical issue with license plate light. its on when hatch is open but goes out halfway down when closing. Any good electrical folks/shops in SF Bay Area? Don't think I'm up for that challenge.

Have a good Sunday all!



User avatar
erikv11
Posts: 9282
Joined: Sat Jul 25, 2009 2:03 pm
Year and Model: 850, S/V70, 06 S60R
Location: Iowa
Has thanked: 64 times
Been thanked: 216 times
United States of America
erikv11

Re: Temp gauge fluctuating even after replacing thermostat and CTS

Post by erikv11 » Sun Oct 27, 2019 4:08 pm

This doesn't address everything but two comments:

(1) you can reset codes by disconnecting the battery
(2) the wiring bundle as it goes into the tailgate is almost certainly the problem for the rear light. The wires get frayed after so many open-close cycles. You can often see the problem wire(s) if you look at the wiring where it runs through the hong on the eft (driver's) side.


'95 854 T5-R, Motronic 4.4, 185k
'96 855 NA, 140k
'98 S70 NA, 210k (living out west)
'98 V70, T5 tune-injectors-turbo, LPT engine, 280k
'06 S60 R, 160k
gone: '96 NA 850 210k, '98 NA V70 182k

RB3
Posts: 8
Joined: Sun Sep 29, 2019 4:47 am
Year and Model: 99 V70
Location: California
Has thanked: 0
Been thanked: 0
United States of America
RB3

Re: Temp gauge fluctuating even after replacing thermostat and CTS

Post by RB3 » Thu Oct 31, 2019 7:00 am

Thanks Eric. Forgot about disconnecting battery. Will do.

And alternator is on the list wizechat.

Its been driving ok for the most part. Couple hesitations. ETS went on and off and then came back on. Of course when I went to have codes read ALL lights cleared! Literally on the 5 mile drive. Got a good laugh anyway.

Now ETS popped back on but check engine off. Temp still in normal range after a week of driving.

First and second glance revealed nothing obvious on wires for rear lights. Gooey insulation.

I don't know much about cars. But I like learning. And don't mind trying the easier stuff.

Thanks for the help and Happy Halloween :twisted:



Post Reply