IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy anything with this and it helps MVS!

Engine died while driving and won't start. Topic is solved

Help, Advice and DIY Tutorials on Volvo's extremely popular car line -- Volvo's 1990s "bread and butter" cars -- powered by the ubiquitous and durable Volvo inline 5-cylinder engine.

1992 - 1997 850, 850 R, 850 T5-R, 850 T5, 850 GLT
1997 - 2000 S70, S70 AWD
1997 - 2000 V70, V70 AWD
1997 - 2000 V70-XC
1997 - 2004 C70

User avatar
bmdubya1198
Posts: 4050
Joined: Tue Dec 30, 2014 10:45 am
Year and Model: 2K V70R M56
Location: Charlotte, NC
Has thanked: 44 times
Been thanked: 158 times
United States of America
bmdubya1198

Re: Engine died while driving and won't start.

Post by bmdubya1198 » Wed May 06, 2020 2:57 pm

It sounds like it's grinding a bit in addition to the rough idle, is your timing belt tensioner set right? Or do you have an exhaust leak or aftermarket exhaust?
2000 V70R Venetian Red/Charcoal M56 Swapped 197k
2003 S60 2.4T Silver/Black 113k
2007 XC90 V8 AWD Sport Titanium Grey/Black 171k
1991 944 Turbo Dark Green/Beige 174k
1992 245 Base White/Beige 249k
2006 BMW 330i
1999 BMW 528i
Sold-
2000 S70 GLT Mystic Silver/Taupe 253k
1993 944 Base Beige/Beige 221k
1998 V70 GLT Black/Beige 199k
1998 S90- Silver/Gray 207k
1995 850 GLT Tropic Green... crushed
2001 S60 2.4T Black/Black 230k
1988 744 Turbo M46 Beige Metallic/Beige 188k

User avatar
valvolvo70
Posts: 56
Joined: Sat Oct 13, 2018 8:39 am
Year and Model: 1998 V70 T5 236K
Location: Michigan
Has thanked: 9 times
Been thanked: 2 times
United States of America
valvolvo70

Re: Engine died while driving and won't start.

Post by valvolvo70 » Wed May 06, 2020 3:24 pm

misha wrote:
Wed May 06, 2020 1:37 pm
erikv11 wrote:
Wed May 06, 2020 12:53 pm
...This is unusual. The car should run just fine with no MAF.
Yes....if the Maf is bad.
This shows that the problem is not the MAF.

I suspect that it is the oil in cap & rotor like allready suggested...but could be something else which makes problem when it's heat soaked.
Something like relay,probably ground or b+ cable.
I would suggest a voltage drop test across cables or simple charging voltage test across battery terminals with a multimeter when problem occurs.
Let somebody to keep the gas pedal,not allowing the engine to die while you check charging voltage across battery terminals.
My rented fuel pressure test kit came with a multi meter...
engine off- 12.76 volts (just purchased a new battery Monday)
engine idle (steady)- 14.08 (stumbling dropped/fluctuating to 12-13 volts)
engine @ 3K rpm (steady) 14.08-.09

User avatar
valvolvo70
Posts: 56
Joined: Sat Oct 13, 2018 8:39 am
Year and Model: 1998 V70 T5 236K
Location: Michigan
Has thanked: 9 times
Been thanked: 2 times
United States of America
valvolvo70

Re: Engine died while driving and won't start.

Post by valvolvo70 » Wed May 06, 2020 3:27 pm

bmdubya1198 wrote:
Wed May 06, 2020 2:57 pm
It sounds like it's grinding a bit in addition to the rough idle, is your timing belt tensioner set right? Or do you have an exhaust leak or aftermarket exhaust?
Definitely an rusted and welded 2X exhaust leak, cheapo performance sound!

User avatar
misha
Posts: 4396
Joined: Sun Dec 07, 2008 4:09 pm
Year and Model: '97 850 2.5 20v
Location: Serbia
Has thanked: 57 times
Been thanked: 144 times
Serbia
misha

Re: Engine died while driving and won't start.

Post by misha » Wed May 06, 2020 3:37 pm

Voltage is good.
The part when you get 12-13v is probably when rpm is fluctuating between 500-900...when engine is struggling to stay running.

Time to sort out the cap and rotor...to keep it clean and dry...before we proceed further.

Did you ever checked main fuel injection relay in the fusebox?

Also....i can't remember.....when stalling occurs...did you tried to jump fuel pump relay with circlip in proper terminals?
'97 850 2.5 20v / fully equipped / Motronic 4.4 from the factory / upgraded with S,V,C,XC70 instrument cluster / polar white wagon
'91 Citroen XM 2.0 SI /fully equipped/mandarine red metallic
History of Volvos in the family:
'71 144 S
'73 144 De Luxe
'78 244 DL
'78 244 DL
'79 244 GLE
'85 340 GLS

User avatar
valvolvo70
Posts: 56
Joined: Sat Oct 13, 2018 8:39 am
Year and Model: 1998 V70 T5 236K
Location: Michigan
Has thanked: 9 times
Been thanked: 2 times
United States of America
valvolvo70

Re: Engine died while driving and won't start.

Post by valvolvo70 » Wed May 06, 2020 4:45 pm

misha wrote:
Wed May 06, 2020 3:37 pm
Voltage is good.
The part when you get 12-13v is probably when rpm is fluctuating between 500-900...when engine is struggling to stay running. Right

Time to sort out the cap and rotor...to keep it clean and dry...before we proceed further. I cleaned it yesterday but I'll check again in the event oil is blowing back in. I'm going to replace both rear cam seals too.

Did you ever checked main fuel injection relay in the fusebox? Yes, I have a spare and swapped.

Also....i can't remember.....when stalling occurs...did you tried to jump fuel pump relay with circlip in proper terminals? I have a jumper but didn't think to jump when stumbling. I used it to verify the pump was running/fuel in rail.

User avatar
misha
Posts: 4396
Joined: Sun Dec 07, 2008 4:09 pm
Year and Model: '97 850 2.5 20v
Location: Serbia
Has thanked: 57 times
Been thanked: 144 times
Serbia
misha

Re: Engine died while driving and won't start.

Post by misha » Wed May 06, 2020 4:49 pm

Before you attack the cam seals....try with jumping the fuel pump relay when stumbling occurs again.
'97 850 2.5 20v / fully equipped / Motronic 4.4 from the factory / upgraded with S,V,C,XC70 instrument cluster / polar white wagon
'91 Citroen XM 2.0 SI /fully equipped/mandarine red metallic
History of Volvos in the family:
'71 144 S
'73 144 De Luxe
'78 244 DL
'78 244 DL
'79 244 GLE
'85 340 GLS

User avatar
valvolvo70
Posts: 56
Joined: Sat Oct 13, 2018 8:39 am
Year and Model: 1998 V70 T5 236K
Location: Michigan
Has thanked: 9 times
Been thanked: 2 times
United States of America
valvolvo70

Re: Engine died while driving and won't start.

Post by valvolvo70 » Thu May 07, 2020 2:01 pm

misha wrote:
Wed May 06, 2020 4:49 pm
Before you attack the cam seals....try with jumping the fuel pump relay when stumbling occurs again.
Jumped relay and didn't make a difference. Don't know if it was exhaust but it smelled like gas in the vehicle while jumped. Plugged the relay back in and stumbled, but not at higher rpms 2K-2500K.

User avatar
misha
Posts: 4396
Joined: Sun Dec 07, 2008 4:09 pm
Year and Model: '97 850 2.5 20v
Location: Serbia
Has thanked: 57 times
Been thanked: 144 times
Serbia
misha

Re: Engine died while driving and won't start.

Post by misha » Thu May 07, 2020 3:28 pm

Do you have a fuel leak somewhere?
Since we covered fuel...then it must be ignition/spark issue.
You will need to fix oil leak in the cap and rotor.
'97 850 2.5 20v / fully equipped / Motronic 4.4 from the factory / upgraded with S,V,C,XC70 instrument cluster / polar white wagon
'91 Citroen XM 2.0 SI /fully equipped/mandarine red metallic
History of Volvos in the family:
'71 144 S
'73 144 De Luxe
'78 244 DL
'78 244 DL
'79 244 GLE
'85 340 GLS

User avatar
valvolvo70
Posts: 56
Joined: Sat Oct 13, 2018 8:39 am
Year and Model: 1998 V70 T5 236K
Location: Michigan
Has thanked: 9 times
Been thanked: 2 times
United States of America
valvolvo70

Re: Engine died while driving and won't start.

Post by valvolvo70 » Fri May 08, 2020 4:00 pm

misha wrote:
Thu May 07, 2020 3:28 pm
Do you have a fuel leak somewhere? No, I was sitting in the drivers seat with the door open and my exhaust leak is right under the center console.
Since we covered fuel...then it must be ignition/spark issue. Makes sense...It just died, shut off, which is weird.
You will need to fix oil leak in the cap and rotor. yup.

User avatar
erikv11
Posts: 9752
Joined: Sat Jul 25, 2009 2:03 pm
Year and Model: 850, S/V70, 06 S60R
Location: Iowa
Has thanked: 101 times
Been thanked: 293 times
United States of America
erikv11

Re: Engine died while driving and won't start.

Post by erikv11 » Sat May 09, 2020 12:49 am

It's not weird at all if the cam seal is blown. Which it is.
'95 854 T5-R, Motronic 4.4, 185k
'96 855 NA, 145k
'98 S70 NA, 220k (living out west)
'98 V70, T5 tune-injectors-turbo, LPT engine, 286k
'06 S60 R, 167k
'99 Camry V6 :shock: 125k
gone: '96 NA 850 210k, '98 NA V70 182k

Post Reply
  • Similar Topics
    Replies
    Views
    Last post