IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

2004 XC90 AW55-50SN P0740 question about symptoms

Help, Advice, Owners' Discussion and DIY Tutorials on Volvo XC90s. The XC90 proved to be very popular, and very good for Volvo's sales numbers, since its introduction in model year 2003 (North America).
dadyer
Posts: 5
Joined: Wed Dec 31, 2014 9:13 am
Year and Model: 2004 Volvo xc90
Location: Missouri
Has thanked: 0
Been thanked: 0
United States of America
dadyer

2004 XC90 AW55-50SN P0740 question about symptoms

Post by dadyer » Mon Jan 25, 2016 9:00 am

Transmission Service Required message came on with CEL. Code read was P0740.
The car accelerates fine at start up when engine is cold. After 3 or 4 miles, goes into limp mode (D changes to dash), cruise control stops working, and starting from a dead stop feels like it is trying to take off from 2nd or 3rd gear instead of 1st. Otherwise, transmission seems to be working fine.
I'm thinking replacing the three linear solenoids with new ones from Rostra might fix this? Can these be replaced without pulling the transmission or removing the valve body?
Any suggestions and comments appreciated!

User avatar
oragex
Posts: 4546
Joined: Fri May 24, 2013 6:20 am
Year and Model: S60 2003
Location: Canada
Has thanked: 92 times
Been thanked: 227 times
Contact:
Canada
oragex

Re: 2004 XC90 AW55-50SN P0740 question about symptoms

Post by oragex » Tue Jan 26, 2016 1:58 pm

Given the cruise control stops working at same moment, I would try to figure out if there's some other main computer anomaly that can cause all the issues. When the solenoids work less well, the transmission will still be shifting through the gears, just a little more harsh.

Is the Winter mode on (button near the shifter)? It will appear as W on the display in place of a D. Maybe liquid causes the W button to stick/short

The 2004 models had an issue with corrosion at the main Eco unit under the hood - there are two modules inside a black box near the power steering reservoir, worth a look

dadyer
Posts: 5
Joined: Wed Dec 31, 2014 9:13 am
Year and Model: 2004 Volvo xc90
Location: Missouri
Has thanked: 0
Been thanked: 0
United States of America
dadyer

Re: 2004 XC90 AW55-50SN P0740 question about symptoms

Post by dadyer » Thu Jan 28, 2016 1:54 pm

Thanks, I'll check those out.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post