IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy anything with this and it helps MVS!

2007XC90 Battery is draining 3amp (Bad ALT Diode) Topic is solved

Help, Advice, Owners' Discussion and DIY Tutorials on Volvo XC90s. The XC90 proved to be very popular, and very good for Volvo's sales numbers, since its introduction in model year 2003 (North America).
ilkerk
Posts: 7
Joined: Thu Dec 28, 2017 2:49 pm
Year and Model: 2007 xc90
Location: us
Has thanked: 0
Been thanked: 0
United States of America
ilkerk

2007XC90 Battery is draining 3amp (Bad ALT Diode)  Topic is solved

Post by ilkerk » Thu Dec 28, 2017 3:07 pm

Hello all,
I have a 2007 XC90, which is draining about 3amp when car is turned off. After few hours, car doesn't start without a jump start. I tested the current draw before and after removing each fuse (and the relays in the engine fuse-box). Still draining the same amount regardless.

I want to check whether alternator causes draining before taking to a mechanic. Is there an easy way to check this? I couldn't locate the wiring from/to the alternator.

Also, I saw in an online manual that other than the 4 main fuse compartment there is a 5th one referred as "fuses by the battery".
Below is a picture of it:
These fuses supply DC to each of the fuse boxes. Anyone know if is it safe the remove each one of these and check for the current drain? Since these are not removable like the regular ones I have to remove the bolt of each one.

thanks.
Image

precopster
Posts: 7482
Joined: Sat Aug 21, 2010 12:20 am
Year and Model: Lots
Location: Melbourne Australia
Has thanked: 4 times
Been thanked: 109 times
Australia
precopster

Re: Battery is draining 3amp

Post by precopster » Thu Dec 28, 2017 5:05 pm

Which engine series is fitted? Is this 3.2L 6 cylinder or V8?

Best to disconnect battery then fit ammeter in series then connect battery so you can measure the current draw. If you don't do this you risk getting unclear-able SRS messages.

3 amps is a lot of drain. I once had a 4A drain from a faulty alternator regulator. You can remove large red lead from alternator and see if current draw is still there.
Current cars:2002 XC70, 2006 Ssangyong Rodius (Stavic), 2006 XC90 2.5T, VW Transporter 2.5TDI

www.precisioncarmodules.com.

ilkerk
Posts: 7
Joined: Thu Dec 28, 2017 2:49 pm
Year and Model: 2007 xc90
Location: us
Has thanked: 0
Been thanked: 0
United States of America
ilkerk

Re: Battery is draining 3amp

Post by ilkerk » Thu Dec 28, 2017 5:19 pm

It is 3.2L 6 cylinder model.
Yes, it is a lot of current which drains battery in a few hours.
I already got an SRS Airbag error message. I was thinking this is because I forgot to put back one of the fuses...
(I havent played with the "fuses by the battery"). Is that a bad news?

I will try to find the large red lead and test after removing it as you suggested.

Thanks for the info.

precopster
Posts: 7482
Joined: Sat Aug 21, 2010 12:20 am
Year and Model: Lots
Location: Melbourne Australia
Has thanked: 4 times
Been thanked: 109 times
Australia
precopster

Re: Battery is draining 3amp

Post by precopster » Thu Dec 28, 2017 9:13 pm

If you have SRS messages you'll need to clear it with a Volvo compatible scanner or dealer. Let us know if disconnection of the large red lead stops the current draw.
Current cars:2002 XC70, 2006 Ssangyong Rodius (Stavic), 2006 XC90 2.5T, VW Transporter 2.5TDI

www.precisioncarmodules.com.

ilkerk
Posts: 7
Joined: Thu Dec 28, 2017 2:49 pm
Year and Model: 2007 xc90
Location: us
Has thanked: 0
Been thanked: 0
United States of America
ilkerk

Re: Battery is draining 3amp

Post by ilkerk » Fri Dec 29, 2017 4:25 pm

I think I will deal with SRS message later since now I even can't start the car. But I got my lesson about procrastinating the issue.

I couldn't locate the red cable to the alternator. Alternator is difficult to reach in XC90. However, there are two red cables connected in the engine fuse compartment. May be one of those is going to the alternator?

Today I couldn't jump start the car so took the battery to a nearby mechanic. He said the battery was damaged from the cold ( it is -20C here) and he said the current drain was probably due to the damaged battery. I was happy for an hour with that possibility. But when I placed the new battery, the current draw was even more, it was changing between 5amp-6amp. I believe that is a shortcut.

I disconnected the battery. Tomorrow I will remove all the fuses and relays and the red alternator cable if I can find it.

best,

precopster
Posts: 7482
Joined: Sat Aug 21, 2010 12:20 am
Year and Model: Lots
Location: Melbourne Australia
Has thanked: 4 times
Been thanked: 109 times
Australia
precopster

Re: Battery is draining 3amp

Post by precopster » Sat Dec 30, 2017 12:01 am

Just had a look at Vida and it explains the procedure of removing the regulator from the B6324S engine in the following steps:

Remove the following items:
battery negative lead.
Refer to: Battery, disconnecting
the intake manifold.
Refer to: Induction pipe

Then there are 4 X M4 screws to remove the regulator

The attached document explains manifold removal
Attachments
Remove manifold B6324S.pdf
(209.51 KiB) Downloaded 464 times
Current cars:2002 XC70, 2006 Ssangyong Rodius (Stavic), 2006 XC90 2.5T, VW Transporter 2.5TDI

www.precisioncarmodules.com.

ilkerk
Posts: 7
Joined: Thu Dec 28, 2017 2:49 pm
Year and Model: 2007 xc90
Location: us
Has thanked: 0
Been thanked: 0
United States of America
ilkerk

Re: Battery is draining 3amp

Post by ilkerk » Sat Dec 30, 2017 2:44 pm

precopster thank you so much for the information. I couldn't try as now seems even bigger problems with the car.

Today when I removed all fuses and relays at the same time, the current drain dropped to 0.2amp. I had to remove the fuses together (not one at a time) to detect the ones that are causing current drain:
- ceiling lighting and upper electronic control module
- moonroof
- Rear AC
- Rear electronic module

I remove those 4 and turn the key. Nothing happened, just a sound from engine (like a pumping sound). Engine light is ON and I have a new error message Anti-skid service required.

Can these be because I removed the fuses of electronic control module?

The car getting worse everyday, nearby mechanic will be open on Tuesday. Sighh...

User avatar
abscate
MVS Moderator
Posts: 21814
Joined: Sun Feb 17, 2013 5:54 pm
Year and Model: 99T5 ,99S70,2005V70
Location: NYC, ALBANY NY
Has thanked: 355 times
Been thanked: 1087 times
Trinidad & Tobago
abscate

Re: Battery is draining 3amp

Post by abscate » Sun Dec 31, 2017 6:28 am

Where are you measuring the 3A drain?

I would check the drain at the left most red wire, the feed wire to the fuse box breakout , to isolate the drain. Ypu Can then check each feeder for drain.

Remember, remove neg cable. Wait 15 minutes

Then loosen each nut, Polish clean, and hand tighten for testing. Take each one-off, then use the ammeter to check in series. Don’t forget to connect negative before testing!

Once you disable a module on a can Bus Car, all bets are off on function...everything talks to everything else, mostly.
Empty Nester
A Captain in a Sea of Estrogen
1999-V70-T5M56 2005-V70-M56 1999-S70 VW T4 BMW
Link to Maintenance record thread
Link To Volvo Glossary

ilkerk
Posts: 7
Joined: Thu Dec 28, 2017 2:49 pm
Year and Model: 2007 xc90
Location: us
Has thanked: 0
Been thanked: 0
United States of America
ilkerk

Re: Battery is draining 3amp

Post by ilkerk » Mon Jan 01, 2018 12:34 pm

abscate thanks for the message.

3amp reading was when I disconnect the negative wire to the battery and place the ammeter in between.

Today when I put double checked the fuses. I tested each cable connection above. Total drain was 5.60amp. Below are each readings. Looks like the last one draining a lot. But all are much higher than the desired 0.02amp.

1st 5.60amp main connection to battery
2nd 0.73amp Rear Electronic Module (REM)
3rd 0.83amp Fuse in cargo compartment auxiliary fuse box
4th 0.45amp Central Electronic Module (CEM)
5th 0.00amp Fuses (1,3-6) in the passenger compartment
6th 3.63amp Fuses (2,9-14) in the passenger compartment

precopster
Posts: 7482
Joined: Sat Aug 21, 2010 12:20 am
Year and Model: Lots
Location: Melbourne Australia
Has thanked: 4 times
Been thanked: 109 times
Australia
precopster

Re: Battery is draining 3amp

Post by precopster » Tue Jan 02, 2018 2:23 pm

Follow the red cables to where you will find 2 connector blocks close to the REM under the removable foam corner pad. Check the connector blocks on the red cables for corrosion.

I'm assuming that ignition is turned OFF with the current draw readings you're getting?

Also on the CEM you can pull the green cable hold and remove the main power feed going into the CEM. After doing this you can retest the current draw.
Current cars:2002 XC70, 2006 Ssangyong Rodius (Stavic), 2006 XC90 2.5T, VW Transporter 2.5TDI

www.precisioncarmodules.com.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post