IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy anything with this and it helps MVS!

D5 Diesel Random Misfire, Random Cat Temp Implausible SOLVED

Help, Advice, Owners' Discussion and DIY Tutorials on Volvo XC90s. The XC90 proved to be very popular, and very good for Volvo's sales numbers, since its introduction in model year 2003 (North America).
SwissXC90
Posts: 1
Joined: Sat Mar 17, 2018 5:42 am
Year and Model: MY2009 XC90 D5
Location: ZH
Has thanked: 0
Been thanked: 0
Switzerland
SwissXC90

D5 Diesel Random Misfire, Random Cat Temp Implausible SOLVED

Post by SwissXC90 » Sat Mar 17, 2018 6:22 am

I'm posting this here to help others, as the findings and the solution, whilst present on a Volvo D5 engine, apply universally to all engines, all models, all makes.

I have owned a MY2009 Volvo XC90 with the 2.4L D5 Diesel engine for the past 2 years.
The vehicle is generally in excellent condition and has been regularly service on schedule at the same dealer all it's life.
I have VIDA and DICE and would often monitor the vehicle state and see what it was logging, as I am a curious person, and an engineer myself.

Symptoms
Over time, and with experience with the vehicle, it became clear that the vehicle logs a random misfire on cylinder 5, and also a random pre-cat temperature sensor signal implausible message.
No noticeable issues were ever noted when driving the vehicle.
The frequency of the problems were around one error every 2 or 3 months of driving.

Throughout the last 2 years and 2 services at the dealer, the dealer ignored / never mentioned these errors, and the frequency of occurrence was so low that it never triggered any permanent faults. Which is why it was ignored. That's fine, that fits the service methodology of the dealer.
But the errors were logged, and I wanted to know why. Where they a pre-cursor to a pending problem?

Theoretical Potential Causes
So one weekend after chatting to a fellow forum member who had a lot of experience with the D5 we ascertained that:
1. The misfire was highly unlikely to be an injector problem, as it would occur much more often
2. A fuel trim reading in VIDA will determine if any compression problems exist, but this was regarded as being unlikely, as the engine runs normally
3. This left the likely misfire cause to be an electrical issue - maybe chaffing of injector wires on the engine loom
4. And likely a similar electrical issue with the cat temp sensors

Diagnostic Steps
Armed with this knowledge and my decades of electrical experience (I am an electronics engineer) I did the following:
1. Ran the fuel trim measurements in VIDA - all were well within there normal tolerances, no discrepancies noted, as expected.
2. Took the engine cover off, took of the injector cover, and had a close visual inspection at the injector connections, and also at the cat temp sensor connections (in the same area of the engine as the injectors)

Findings
Here's what I found:
  • Connectors to injectors 1,2 and 3 were clean and dry
  • Connector on injector 4 shows signs of corrosion - white oxidation was appearing
  • Connector on injector 5 also was showing white oxidation
  • The wiring loom for the injectors was pressed hard up against injector 4 metal body, so much that the wiring loom was molding itself around the injector, however no signs of chaffing were evident.
  • The connectors for pre- and post-cat temp sensor are readily accessible behind the engine but showed no obvious signs of damage or corrosion. The high-temperature capable silicon wiring to the temp sensors was intact and shows no sign of damage.
I decided that I needed to clean and re-seat all connectors, and move the wiring loom away from the injector body.
If the wiring loom touching the injector body was not causing a problem now, it likely would in the future.

Remedial actions:
1. I cleaned all connector housings with a damp cloth to remove dust and dirt to ensure the rubber weatherproofing would seat properly to keep moisture and dirt out of the connector
2. I cleaned all connector pins, and the injectors, with contact cleaner spray, and connected and disconnected the connectors a few times whilst still wet with contact cleaner to ensure the cleaner was wiped over all mating surfaces
3. I moved the loom back away from the injector body, and tied it back with cable ties to ensure it would not rub or chaff

Consequent Monitoring and Long-Term Results
I connect VIDA and monitor the vehicle regularly, at least once a month.
I can currently report that 3 months after the work I have had ZERO misfire errors logged and ZERO cat temp sensor implausible readings logged.
I will continue to monitor the errors but I do believe I found the root cause and fixed it.

Summary
The engine bay is a hostile environment.
The components run at temperatures from 90°C (my Diesel D5) to 110°C (a typical petrol engine) and are often subject to road grime and rain water spray from the road, resulting in hot, wet, dirty conditions.
Any electrical connection must be kept clean and dry to be reliable.
Any wiring loom must be laid so that it can not rub and chaff on any surfaces.

Inspecting the vehicle and re-positioning wring looms to prevent rubbing and chaffing, and cleaning electrical connectors properly, is a worth while preventative maintenance action to ensure long term reliability of the vehicle.

The above methodology can be used on any modern engine.

  • Similar Topics
    Replies
    Views
    Last post