IPD sale XeMODeX - Experts in Volvo Electronics
MVS-Amazon link helps MVS!

Get email notification of topic replies. Log in or register (free). Amazon Link Buy anything with this and it helps MVS!

XC 90 Rear Diff Not Working. Anti skid Service Required.

Help, Advice, Owners' Discussion and DIY Tutorials on Volvo XC90s. The XC90 proved to be very popular, and very good for Volvo's sales numbers, since its introduction in model year 2003 (North America).
Post Reply
Gazi
Posts: 4
Joined: Sat Jun 30, 2018 10:43 pm
Year and Model: 2005 2.5 T
Location: Tirane
Has thanked: 1 time

XC 90 Rear Diff Not Working. Anti skid Service Required.

Post by Gazi »

I have XC90 2.5T 2005.My rear diff not working .
ANTI Skid SERVICE Required on dash.

I have check at a service who works with Volvo.
He said to me that he cannot connect with DEM.

I have read something from XeMOdex.

I have measure by my self pins that connect with DEM,11.8 volt.

Check the resistance of pump,it was 5.6 ohm.
Is that the right value ?

I have tested the pump with 12 v and it works.


Oslo I have open the module DEM.
No sings of burns inside or humidity.

I have seen the oil and the colour looks fine.

One day after I have try with it,clean the pins,suddenly it starts to work.

I have done more that 3 km it was ok.

Turn off the car and switch on,again ANTI Skid System Requried come on.

Somebody can help me ?
Last edited by matthew1 on Wed Jul 04, 2018 3:24 pm, edited 1 time in total.
Reason: No ALL CAPS in titles please.
User avatar
SuperHerman
Posts: 1625
Joined: Mon Dec 01, 2014 1:28 pm
Year and Model: 2004 & 2016 XC90
Location: Minnesota
Been thanked: 176 times

Re: XC 90 REAR DIFF NOT WORKING.Anti skid SERVICE Required.

Post by SuperHerman »

Sounds like you have a connection problem. I believe the unit also has a temp sensor that goes bad.

Other possible issues are the yaw sensor, clock spring, steering angle sensor module, and steering wheel module.

On my 2004 I had a similar problem and found out in the end it was the steering wheel module female connector that goes to the clock spring. My niece spilled a smoothie which caused all sorts of issues - mainly corrosion of the connector. Fortunately I visually saw the damage when I changed out the clock spring otherwise I would have never figured it out as the steering wheel module and clock spring both were fine, but the connection was the failed point. Diagnostics would say the clock spring as its data could not be seen by the steering wheel module. My point is check your connection points.
Gazi
Posts: 4
Joined: Sat Jun 30, 2018 10:43 pm
Year and Model: 2005 2.5 T
Location: Tirane
Has thanked: 1 time

Re: XC 90 REAR DIFF NOT WORKING.Anti skid SERVICE Required.

Post by Gazi »

Thanks Superherman,I will follow your advice.
Almost yesterday I check the Volvo with Delfi program.
SAS OK.
I have two isue.
1.Right door passenger module
2.BCM 0094 communication module fault.

The last things from the activation of rear DIFF that I touch it was YAW sensor and DEM connectors.

I have not reset code by Vida or anything else.

Is possible that the presure sensor of haldex can cause this fault and give this code error ?

If I change the pump,filter and oil maybe I will have AWD again ?

Can somebody tell me how much must be the resistance for pump and sensor?

I will appreciate all opinions for this kind of problems.
User avatar
SuperHerman
Posts: 1625
Joined: Mon Dec 01, 2014 1:28 pm
Year and Model: 2004 & 2016 XC90
Location: Minnesota
Been thanked: 176 times

Re: XC 90 REAR DIFF NOT WORKING.Anti skid SERVICE Required.

Post by SuperHerman »

The Haldex unit has a combined pressure/temperature sensor and a solenoid (I think that is their function). The pressure/temperature sensor is the smaller of the two with four pins and the solenoid the larger with two pins (at least for the purpose of helping you out).

Either or both of these can cause the code from what I have read.

You can do some research looking at Audi as the system is similar and for some years parts have been interchanged. I don't recall if when I researched mine I found my information on the Audi or Volvo write ups, but it is out there.

For resistance I measured a spare set that was working that I have. For the pump I got 4.9 ohms. On the Solenoid I get 3.2 ohms. The pressure/temperature has four pins.

I suppose you can measure your pressure/temperature sensor and post the results, but you will have to specify the direction you are taking your readings so I can measure in a similar manner. There is a tab in the middle which you can use as a reference point then go left to right or right to left.

BCM 0094 is a general communication error code between modules. As you potentially have an intermittent problem - check your wiring harnesses.
Gazi
Posts: 4
Joined: Sat Jun 30, 2018 10:43 pm
Year and Model: 2005 2.5 T
Location: Tirane
Has thanked: 1 time

Re: XC 90 REAR DIFF NOT WORKING.Anti skid SERVICE Required.

Post by Gazi »

Hi SuperHerman

I have measure the sensor,really it was impossible to get something.
I have try with all pins with digital meter and no value.
Maybe this means that sensor it's not working ?
The resistance of solenoid it was 1.9 ohm.

I have measure seven the pins at connector of DEM.

Two lines,white 2.7 volts and green 1.9 volts.
I put 12 volts to motor and it works,but I am not sure if to the presure that give.

Some body told me that some times those problem came from steering module.

I have told this problem to technician of XeMOdex and he told me that the problem is the DEM.

I don't know if he is right.

It's really a problem.

Thanks.
User avatar
SuperHerman
Posts: 1625
Joined: Mon Dec 01, 2014 1:28 pm
Year and Model: 2004 & 2016 XC90
Location: Minnesota
Been thanked: 176 times

Re: XC 90 REAR DIFF NOT WORKING.Anti skid SERVICE Required.

Post by SuperHerman »

Gazi: On the temp/pressure sensor - with the black tab in the middle facing up I get the following readings:

Pins 1 and 4: 5.32 K ohms;
Pins 2 and 4: 20.34 M ohms;
Pins 3 and 4: 21.85 K ohms; and
Pins 2 and 3: 20.35 M ohms.

I saw one poster supply only 5 volts to the pump - not sure what is required. Your 2.7 readings may be fine. The voltage value may go up once signal is given for more. The poster said that testing needs to be done with the system all together and one watches voltage and amp draw. (I know nothing about any of this other than what I have read).

Try again on your temp/pressure sensor - this may be the issue.
Gazi
Posts: 4
Joined: Sat Jun 30, 2018 10:43 pm
Year and Model: 2005 2.5 T
Location: Tirane
Has thanked: 1 time

Re: XC 90 Rear Diff Not Working. Anti skid Service Required.

Post by Gazi »

Thanks SuperHerman.
I will check again.

Aprisciate your help.
Post Reply
  • Similar Topics
    Replies
    Views
    Last post