IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy anything with this and it helps MVS!

P0108 - MAP reading HIGH after reinstalling 3.2 intake Topic is solved

Help, Advice, Owners' Discussion and DIY Tutorials on Volvo XC90s. The XC90 proved to be very popular, and very good for Volvo's sales numbers, since its introduction in model year 2003 (North America).
xHeart
Posts: 2735
Joined: Sat Dec 03, 2011 8:05 am
Year and Model: 13XC90/01V70X/97N854
Location: Great Lakes - USA
Has thanked: 22 times
Been thanked: 44 times
United States of America
xHeart

P0108 - MAP reading HIGH after reinstalling 3.2 intake

Post by xHeart » Thu Nov 15, 2018 12:33 pm

CEL P0108 after the recent 2013A XC90 Cooling System Service which required removing intake manifold.
Image
I'm guessing MAP is reading too much fresh air entering the throttle then optimal ratio at idle.

There is no MAF in 3.2, right?
--
Golden Retriever | 2014D VIDA DiCE | 2013A XC90 +144mi/231km | 2001 V70XC 1st Owner +200mi/ +322km | 1997 Volvo 850 NA 1st Owner +180mi/ +289km
Past: German Shepherd | 1989 Volvo 740 GL | 1979 Volvo 240

jimmy57
Posts: 6601
Joined: Fri Nov 12, 2010 9:25 am
Year and Model: 2004 V70R GT, et al
Location: Ponder Texas
Has thanked: 4 times
Been thanked: 249 times
jimmy57

Re: P0108 - MAP reading HIGH after reinstalling 3.2 intake

Post by jimmy57 » Thu Nov 15, 2018 2:46 pm

Denso uses MAF and MAP. Make sure the seal didn't get out of position on the MAP down low on intake, 15 in illustration.

MAF is not as accurate at low air mass at idle so MAP is used since it is accurate at low throttle and goes to max signal long before wide open throttle.

xHeart
Posts: 2735
Joined: Sat Dec 03, 2011 8:05 am
Year and Model: 13XC90/01V70X/97N854
Location: Great Lakes - USA
Has thanked: 22 times
Been thanked: 44 times
United States of America
xHeart

Re: P0108 - MAP reading HIGH after reinstalling 3.2 intake

Post by xHeart » Fri Nov 16, 2018 8:51 am

jimmy57 wrote:
Thu Nov 15, 2018 2:46 pm
Denso uses MAF and MAP. Make sure the seal didn't get out of position on the MAP down low on intake, 15 in illustration.
Is the SEAL on the MAP same as item 16 in illustration?

Pulled the harness connector away and off the sensor last night. The sensor appears to be seating firmly and attached to manifold. I wish there was a zoom-in function to examine it closely. A gentle wiggle did not change or displace it from its location.

But when I went to plug the harness connector back on the sensor, the connector slides over fine but did not click -- tried it few times. Did the connector snap tab malfunction or break?
--
Golden Retriever | 2014D VIDA DiCE | 2013A XC90 +144mi/231km | 2001 V70XC 1st Owner +200mi/ +322km | 1997 Volvo 850 NA 1st Owner +180mi/ +289km
Past: German Shepherd | 1989 Volvo 740 GL | 1979 Volvo 240

xHeart
Posts: 2735
Joined: Sat Dec 03, 2011 8:05 am
Year and Model: 13XC90/01V70X/97N854
Location: Great Lakes - USA
Has thanked: 22 times
Been thanked: 44 times
United States of America
xHeart

Re: P0108 - MAP reading HIGH after reinstalling 3.2 intake  Topic is solved

Post by xHeart » Fri Nov 16, 2018 7:55 pm

Multimeter shows 4.78v at green wire, but I'm not able to get continuity beep for ground.
--
Golden Retriever | 2014D VIDA DiCE | 2013A XC90 +144mi/231km | 2001 V70XC 1st Owner +200mi/ +322km | 1997 Volvo 850 NA 1st Owner +180mi/ +289km
Past: German Shepherd | 1989 Volvo 740 GL | 1979 Volvo 240

xHeart
Posts: 2735
Joined: Sat Dec 03, 2011 8:05 am
Year and Model: 13XC90/01V70X/97N854
Location: Great Lakes - USA
Has thanked: 22 times
Been thanked: 44 times
United States of America
xHeart

Re: P0108 - MAP reading HIGH after reinstalling 3.2 intake

Post by xHeart » Tue Nov 20, 2018 12:36 pm

Both connector and sensor are doing fine. A goodbye to P0108!
Thank you Jimmy57!
--
Golden Retriever | 2014D VIDA DiCE | 2013A XC90 +144mi/231km | 2001 V70XC 1st Owner +200mi/ +322km | 1997 Volvo 850 NA 1st Owner +180mi/ +289km
Past: German Shepherd | 1989 Volvo 740 GL | 1979 Volvo 240

jimmy57
Posts: 6601
Joined: Fri Nov 12, 2010 9:25 am
Year and Model: 2004 V70R GT, et al
Location: Ponder Texas
Has thanked: 4 times
Been thanked: 249 times
jimmy57

Re: P0108 - MAP reading HIGH after reinstalling 3.2 intake

Post by jimmy57 » Tue Nov 20, 2018 12:55 pm

Is it possible the ignition was on when the MAP sensor was unplugged?

xHeart
Posts: 2735
Joined: Sat Dec 03, 2011 8:05 am
Year and Model: 13XC90/01V70X/97N854
Location: Great Lakes - USA
Has thanked: 22 times
Been thanked: 44 times
United States of America
xHeart

Re: P0108 - MAP reading HIGH after reinstalling 3.2 intake

Post by xHeart » Tue Nov 20, 2018 1:31 pm

jimmy57 wrote:
Tue Nov 20, 2018 12:55 pm
Is it possible the ignition was on when the MAP sensor was unplugged?
No. The negative (-) terminal from the battery was removed before I started the cooling system service -- draining coolant for t-stat replacement, etc. What I understand now is that the connector was never plugged back on to sensor till last night.

But learned a lot about the workings of MAP sensor, and how-to test the wires and sensor.
--
Golden Retriever | 2014D VIDA DiCE | 2013A XC90 +144mi/231km | 2001 V70XC 1st Owner +200mi/ +322km | 1997 Volvo 850 NA 1st Owner +180mi/ +289km
Past: German Shepherd | 1989 Volvo 740 GL | 1979 Volvo 240

Post Reply
  • Similar Topics
    Replies
    Views
    Last post