IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

2008 3.2 stalls/dies/won't start Topic is solved

Help, Advice, Owners' Discussion and DIY Tutorials on Volvo XC90s. The XC90 proved to be very popular, and very good for Volvo's sales numbers, since its introduction in model year 2003 (North America).
xiphosm3
Posts: 5
Joined: Mon Feb 17, 2014 3:59 pm
Year and Model: 2007 XC90 V8 Sport
Location: United States
Has thanked: 0
Been thanked: 0
xiphosm3

Re: 2008 3.2 stalls/dies/won't start

Post by xiphosm3 » Mon Jun 10, 2019 10:10 pm

Let me know if you were able to fix this as I’m having the same repeated issues.



User avatar
dandan
Posts: 51
Joined: Fri Apr 18, 2014 10:27 am
Year and Model: 2008 Volvo XC90 3.2
Location: OKC
Has thanked: 17 times
Been thanked: 4 times
United States of America
dandan

Re: 2008 3.2 stalls/dies/won't start  Topic is solved

Post by dandan » Wed Jun 19, 2019 9:30 am

I did give up and take it to a local independent volvo tech. Turns out I had the bad luck of installing a faulty fuel pump the last time. So I purchased another and it started right up after they installed it. This will be the 5th fuel pump in this vehicle



User avatar
pgill
Posts: 143
Joined: Mon Aug 27, 2018 5:42 pm
Year and Model: 2010 S80, 2008 LR2
Location: California
Has thanked: 11 times
Been thanked: 21 times
United States of America
pgill

Re: 2008 3.2 stalls/dies/won't start

Post by pgill » Wed Jun 26, 2019 5:19 pm

Dan^2,

Five fuel pumps!!!!!!!!

That is true dedication.

You need to change your screen name from DanDan to XC90_Dan

Glad to hear that you got it fixed

Take care

Paul



User avatar
RickHaleParker
Posts: 2869
Joined: Mon May 25, 2015 2:30 pm
Year and Model: See Signature below.
Location: Kansas
Has thanked: 3 times
Been thanked: 317 times
United States of America
RickHaleParker

Re: 2008 3.2 stalls/dies/won't start

Post by RickHaleParker » Thu Jun 27, 2019 7:06 am

dandan wrote:
Wed Jun 19, 2019 9:30 am
This will be the 5th fuel pump in this vehicle
Five!

I would be looking for poor grounds that drop the voltage and up the current. The pumps need X amount of power to run. If the voltage drops the current must come up to get the required power.


Platform: P80 1998 C70, B5234T3, AW50-42, Bosch Motronic 4.4, Special Edition package, Plant: Uddevalla Sweden.

Platform: X40 (Nedcar) 2003 S40, B4204T3, AW55-50/51SN, Siemens EMS 2000. Plant: Born Netherlands.

Platform P2 2005 XC90 T6 Executive, B6294T, 4T65 AWD, Bosch Motronic 7.0, Plant Torslanda Sweden.
----------------------------------------------------------------
1997 S90, B6304S, AW30-42, Bosch Motronic 4.4 - Sold

User avatar
abscate
MVS Moderator
Posts: 18201
Joined: Sun Feb 17, 2013 5:54 pm
Year and Model: 99T5 ,99S70,2005V70
Location: NYC, ALBANY NY
Has thanked: 200 times
Been thanked: 647 times
Trinidad & Tobago
abscate

Re: 2008 3.2 stalls/dies/won't start

Post by abscate » Thu Jun 27, 2019 10:43 am

This is sparse data but the take home I get from these is that the

Electronic fuel pump parts >>>>>>> Mechanical parts reliability

It seems like time and time again we troubleshoot waveforms, PEMS. CEMS and then find a kinked line.

Guru jimmy has a great dirt add on in the shockwave thread about how you can go through 5 pumps getting the dirt out of the tank.


Empty Nester
A Captain in a Sea of Estrogen
1999-V70-T5M56 2005-V70-M56 1999-S70 VW T4 BMW

User avatar
dandan
Posts: 51
Joined: Fri Apr 18, 2014 10:27 am
Year and Model: 2008 Volvo XC90 3.2
Location: OKC
Has thanked: 17 times
Been thanked: 4 times
United States of America
dandan

Re: 2008 3.2 stalls/dies/won't start

Post by dandan » Thu Jun 27, 2019 12:25 pm

First fuel pump was the stock pump. The first replacement pump I was unaware of until it fail. Upon replacing the pump I noticed that it had already been replaced. (So 1st pump replaced by me was the 3rd pump in the vehicle.)

3rd pump failed due to user error in installation (kinked line)
4th pump installed great worked for a week and failed.
5th pump replaced by independent shop. Still seems to be running fine!

All pumps installed after original were delphi pumps.



Post Reply