Welcome to the world's #1 Volvo forum!

Volvo Fixes & Advice since 2001.

Login Register

Turning signal and wipers switch problem - mostly when it rains

A mid-size luxury crossover SUV, the Volvo XC90 made its debut in 2002 at the Detroit Motor Show. Recognized for its safety, practicality, and comfort, the XC90 is a popular vehicle around the world. The XC90 proved to be very popular, and very good for Volvo's sales numbers, since its introduction in model year 2003 (North America).
Post Reply
Estlander
Posts: 2
Joined: Sat Sep 05, 2020 8:05 am
Year and Model: 2007 XC90 V8
Location: Tallinn

Turning signal and wipers switch problem - mostly when it rains

Post by Estlander »

Hi Everyone,
I have 2007 XC90 V8, I'm first and only owner, currently 440 000 km's (270 000+ miles) and counting. No major issues.
Around two months ago, I noticed that my left turn indicator did not work (didn't click) when tried to turn left. It was one-time and on the next turns it worked. I thought, maybe one-time error. It happened again, 2 weeks later after first incident. Then it didn't work until I turned engine off, meanwhile went to gas station and came back, turned car back on and everything worked around week without problems. Later weeks it started fluctuating more often. It was sunny and dry on this period from the first incident, so I did not suspect any water. One day I had enough, I removed turning indicator, cleaned contacts and put it back together. First few attempts it did not work. I left and thought next steps but after few minutes I had to drive and suddenly, it worked perfectly next couple of weeks. I thought problem is solved now - unfortunately not. We had heavy rain for 30 minutes and then I noticed that also my wipers switch does not work (1st and 2nd position), 3rd position (the fastest one) worked, also rain sensor worked. Then I replaced turning switch, got it from scrap, sunny days, worked until rain started and stopped working, also wipers switch did not work (same positions, 1-2 fail, 3rd works + sensor). Driving in the rain for next 5 minutes, testing turn and wipers indicator - they both worked perfectly again.
I have checked ECM main cables, they were dry and no indications of water. Also inside drivers side, it is clean and dry, no water damage.
I also keep water channels (sorry I don't know correct word for that) clean, place where water falls from windscreen under bonnet, there are holes on left and right where water goes down. I also checked wires, that are under the bonnet and between windscreen, they are in place and covered with rubber and plastic, so water can't go through wires into ECM.

My thought is that, something is loose or gets wet somehow. After 5 minutes of driving in the rain and if turning indicator and wipers switch starts working again, it dries because engine gets hot or it (contact) expands due the heat. I will try to reproduce incident again with water, I will take hose and just spray water on the windscreen and see what happens. But if anyone had similar issue, I will be more that happy to hear Your suggestions. Somebody suggested that steering wheel module, where turning light and wipers modules are connected, is faulty but dealer did not find problems with that. Unfortunately same dealer who recommended to change turn indicator switch but what seems to be did not resolve the problems. So I'm open minded. Thank you in advance.
Last edited by Estlander on Tue Sep 08, 2020 2:00 pm, edited 1 time in total.
2007 XC90 V8 - in everyday use, 440k km and still running nice.
2006 XC90 D5 - sold
2005 S60 R5 - sold
2003 XC70 D5 - sold
2002 XC70 T5 - sold
2001 S60 T5 - sold

cn90
Posts: 7003
Joined: Wed Mar 31, 2010 9:54 am
Year and Model: 2004 V70 2.5T
Location: Omaha NE
Been thanked: 180 times

Post by cn90 »

I replaced the wiper stalk (inexpensive and very easy DIY) and it solved my problem on intermittent wiper.
2004 V70 2.5T 100K+
2005 XC90 2.5T 110K+

User avatar
Roger_850T
MVS Moderator
Posts: 305
Joined: Tue Dec 31, 2013 11:55 am
Year and Model: 854T 1995
Location: Frederick MD
Been thanked: 17 times

Post by Roger_850T »

I've replaced my turn signal stalk, and IIRC it was pretty straightforward and easy. With that many miles, I would not be surprised to learn you also needed replacement.
'05 XC90 V8 170k
'95 854T 329k
'02 V70 186k
'03 S80 111k (crashed)
'93 945T 217k (gone to be parted out)
'87 245 300k+ sold, still going
'84 264 Diesel, RIP at 160k
'78 242 manual everything.
'73 P1800ES, fun until the rust set in...

Estlander
Posts: 2
Joined: Sat Sep 05, 2020 8:05 am
Year and Model: 2007 XC90 V8
Location: Tallinn

Post by Estlander »

Thank you. As I said on first post, I already have changed turn signal stalk and unfortunately it did not change anything.
But yesterday, I noticed one thing, I were on junction and had to turn left, left turn signal to left was on but nothing happened, then rain started and I pulled wiper stalk - whoila, left turn started working. I managed to recall problem multiple times with this. If left turn did not work, I just pulled wiper stalk and it started working. So "cn90" thank you for the hint :) I ordered wiper stalk yesterday, it should be arrive this week and after that I can confirm, was malfunction in wiper stalk caused problems in turn signal stalk. Today we had heavy rain whole day and both, signal and wiper stalk worked perfectly. So it seems water is not the issue at all. That is a good relief.
I will keep you updated after changing wiper stalk.
2007 XC90 V8 - in everyday use, 440k km and still running nice.
2006 XC90 D5 - sold
2005 S60 R5 - sold
2003 XC70 D5 - sold
2002 XC70 T5 - sold
2001 S60 T5 - sold

Post Reply