IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy anything with this and it helps MVS!

2000 200,000 Mile S80 Issues

Help, Advice, Owners' Discussion and DIY Tutorials on the Volvo S80 model. Sometimes called an "executive car", the S80 was and continues to be Volvo's top-of-the-line passenger car.
cgw4jesus
Posts: 3
Joined: Sat Jun 16, 2012 11:36 am
Year and Model: 2012 C70 Convertible
Location: Nebraska
Has thanked: 0
Been thanked: 0
United States of America
cgw4jesus

2000 200,000 Mile S80 Issues

Post by cgw4jesus » Fri Apr 29, 2016 4:55 pm

Bought a $500 used 2000 S80 T6 to fix up for my son-in-law. Having some issues that are stumping me (yes, I have searched the forum):

* Surging on initial acceleration, more so when cold, almost none once warmed up. Throwing some codes, ECM-9150 (Throttle Module Faulty Signal), ECM-91A7 (Throttle Unit Faulty Signal), ECM-644A (Camshaft Reset Valve (two times)), and a Rear O2 Sensor. Going to have the throttle body and the Camshaft Valve cleaned. No RPM surging seen on the gauge at idle. Oh, and I get the occassional "gas cap loose" message, despite buying a brand new VOLVO gas cap; suspect J hose perhaps. Cruise control does not function. Have a Volvo programmed OBD-II code reader, no transmission codes. Car has no hesitation issues once up-to-speed and is not in limp home mode. I don't think these are symptoms a failing throttle body, but I could be wrong. Also, the car has the classic "won't shift out of Park" issue, for which I am replacing the shift cable and cleaning the shift interlock.

So, beside the throttle body, what might cause the acceleration/hesitation issues? And what might be causing the Park issue aside from the cable and/or the shift interlock?

cgw4jesus
Posts: 3
Joined: Sat Jun 16, 2012 11:36 am
Year and Model: 2012 C70 Convertible
Location: Nebraska
Has thanked: 0
Been thanked: 0
United States of America
cgw4jesus

Re: 2000 200,000 Mile S80 Issues

Post by cgw4jesus » Fri Apr 29, 2016 5:16 pm

Well, my mechanic just called me and found the shifting problem...the cable was partially crushed and the shift interlock has a busted part. One down...

Post Reply
  • Similar Topics
    Replies
    Views
    Last post