IPD sale XeMODeX - Experts in Volvo Electronics Volvo modules repair and programming
Please use the MVS Amazon link when you buy anything at all! It helps this site. Thanks very much!

Get email notification of topic replies. Log in or register (free). Amazon Link Buy anything with this and it helps MVS!

Car will not go over 10 mph, will not rev over 2000 RPM in park?

Help, Advice, Owners' Discussion and DIY Tutorials on the Volvo S80 model. Sometimes called an "executive car", the S80 was and continues to be Volvo's top-of-the-line passenger car.
Post Reply
ektrules
Posts: 7
Joined: Wed Mar 02, 2016 12:52 am
Year and Model: 2000 s80 2.9l
Location: Texas, US

Car will not go over 10 mph, will not rev over 2000 RPM in park?

Post by ektrules »

My 2000 S80 2.9l will not go faster than 10 mph, will not rev over 2000 RPM in park, is hard to start (need to press gas pedal), and once started, stumbles on idle. Does not make any weird noises besides the stumbling. Any idea what could cause this?

Codes I'm getting are:
- Cylinder 2 misfire (has been coming on and off for a week before the loss of all power).
- P0731 - Gear 1 Incorrect Ratio. This only started showing up after the loss of power. May only be because it was drove ~5 miles back home at 10 mph in first most the way (shifted to second once going down a hill)?

Could either one of these problems cause this?
- Would a consistent misfire of one cylinder have this dramatic of an effect?
- Would something wrong with the transmission cause it not rev over 2000 RPM in park?

Some more background on the car:
- I think the brake booster is going out, because I can hear a high-pitched noise when I let off the brake. It's been like this for 6 months.
- Car recently overheated very badly (due to losing coolant from a crack in the radiator). This caused head gasket failure and head warpage. Got the head shaved down, and replaced the head gasket, and all the other things you need to replace when you do that. Has only been about 3 weeks since I've got it running again. Everything seemed OK until the misfire on cylinder 2 this last week, and now the loss of all power. No coolant/oil mixing detected, and no smoke/steam coming out of the exhaust anymore.

My initial thought was that maybe the catalytic converter was plugged from all the coolant and oil from when it overheated. But, I unhooked the catalytic converter from the exhaust manifold, and now it only revs to 1500 RPM. Maybe I need to disconnect the O2 sensors as well? Not really sure how to test for catalytic converter restriction.

This car has been a nightmare, LOL. It's pretty obvious it has been worked on a lot before too. Tons of broken electrical connectors and plastic parts, radiator was JB welded, firewall is all scarred up, and some threads were stripped. Got it for $400 because it seemed to run well, but not really sure if it was worth that now :).
User avatar
June
Posts: 1950
Joined: Wed May 04, 2016 11:18 am
Year and Model: 2004 S80 T6
Location: Jacksonville, Florida
Has thanked: 363 times
Been thanked: 182 times

Re: Car will not go over 10 mph, will not rev over 2000 RPM in park?

Post by June »

Could the ETM be bad?
My Volvo cars owned
1989 740 GLT ordered
1994 850 4door standard shift ordered
1996 960 ordered
1998 S90 ordered totalled after 3 weeks
1998 V70 GT dealer stock car
2002 S80 T6 ordered totalled
2004 S80 T6 dealer stock car and current car owned
Cees Klumper
Posts: 290
Joined: Sat Dec 28, 2013 1:24 pm
Year and Model: C70 2008 T5
Location: Marina del Rey
Has thanked: 22 times
Been thanked: 14 times

Re: Car will not go over 10 mph, will not rev over 2000 RPM in park?

Post by Cees Klumper »

Try swapping the coil for cylinder two and see if the problem moves to the other cylinder. Perhaps the engine is in 'self-defense mode' from a bad coil or spark plug or what have you.
ektrules
Posts: 7
Joined: Wed Mar 02, 2016 12:52 am
Year and Model: 2000 s80 2.9l
Location: Texas, US

Re: Car will not go over 10 mph, will not rev over 2000 RPM in park?

Post by ektrules »

Just did a back pressure and compression test. Back pressure is good. All cylinders, except cylinder 5, tested ~125 psi dry. Cylinder 5 tested 90 psi dry, which is pretty low and 200+ wet, so there's a worn ring and/or cylinder. But, I don't think this is the problem.

So, I guess I'll do ignition and fuel pressure tests tomorrow.

How would somebody test the ETM?
ektrules
Posts: 7
Joined: Wed Mar 02, 2016 12:52 am
Year and Model: 2000 s80 2.9l
Location: Texas, US

Re: Car will not go over 10 mph, will not rev over 2000 RPM in park?

Post by ektrules »

Fuel pressure is fine, and spark is good.

Hooked up a bluetooth OBD2 reader, and monitored all the sensor values I could. But, not really sure what the values should be.
- MAF at idle is 8.5 - 9.5 g/s, and ~10 g/s if I floor it (engine tops out at 2000 rpm)
- Throttle values (pedal and intake) are always 0 even when I floor the accelerator. Not sure if I should be able to read these over ODB2 or if there is a bug in the software?
- Can only read Bank1 Sensor2 and Bank2 Sensor2 O2 sensor voltage. Not sure if I should be able to read sensor 1 values?
- B1 S2 O2 sensor moves smoothly around 0.8v at idle.
- B2 S2 O2 sensor graph is very volatile. The baseline seems to be around 0.7v, but frequently and quickly spikes down 0.2 and back up again.
- Bank 1 short-term fuel trim smoothly changes between 5-10%
- Bank 2 short-term fuel trim smoothly changes between 0-5%
- Timing advance stays around -6 degrees
- Somehow I'm reading turbo boost and vacuum gauge at -9 PSI, even though the car is not turbocharged...

Anybody with experience in OBD2 readers and these cars?
Post Reply
  • Similar Topics
    Replies
    Views
    Last post