IPD sale XeMODeX - Experts in Volvo Electronics Free shipping all USA - Experts in Brakes
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

2006 S80: Fuel Pressure Sensor code question - sensor or new fuel pump?

Help, Advice, Owners' Discussion and DIY Tutorials on the Volvo S80 model. Sometimes called an "executive car", the S80 was and continues to be Volvo's top-of-the-line passenger car.
CodyS80
Posts: 7
Joined: Sun May 15, 2011 10:26 pm
Year and Model: 2018 S90
Location: Cody, WY, USA
Has thanked: 0
Been thanked: 0
United States of America
CodyS80

2006 S80: Fuel Pressure Sensor code question - sensor or new fuel pump?

Post by CodyS80 » Sat Feb 17, 2018 10:31 am

I have a 2006 five cylinder S80 with the check engine light on. The code showed an error with the Fuel Pressure Sensor, so I bought a new Bosch sensor and installed it. I cleared the codes and thought that was the end of it. Then the CEL came back on and it was the same sensor code. A local shop said that the pressure in the fuel rail was holding steady at 44lbs though it fluctuated on acceleration and deceleration. I was wondering what I should be checking before I decide that I bought a faulty sensor, or that I need a new fuel pump?

I have attached a picture of my scanners graph of RPM and Fuel Pressure in case that helps.

And insights are greatly appreciated.
C90BF82C-3794-4BDE-981A-21214608B537.jpeg
You do not have the required permissions to view the files attached to this post.
Last edited by matthew1 on Sat Feb 17, 2018 11:06 am, edited 1 time in total.
Reason: improved title, added tag

User avatar
mrbrian200
Posts: 1547
Joined: Wed Jan 20, 2016 8:47 am
Year and Model: 2006 S60 2.5T FWD
Location: Northern Indiana/Chicago
Has thanked: 7 times
Been thanked: 80 times
United States of America
mrbrian200

Re: 2006 S80: Fuel Pressure Sensor code question - sensor or new fuel pump?

Post by mrbrian200 » Sat Feb 17, 2018 2:12 pm

PEM more than likely. Pressure is supposed to sit up around 58-60psi when you're starting, cruising, or accelerating. From the best I gather when the PEM internal circuitry fails to regulate based on the ECU input it defaults to a preset PWM modulated pulse width that generally results around 40-45psi at the rail and will fluctuate (usually below) that number during varying conditions. The actual fuel pump is PWM controlled. I would consider it more of a quickly modulated duty cycle (not a data link with a smart controller built into the pump). They do it this way because quick on/off pulses generates less heat in the control circuit as opposed to employing a variable DC control in which voltage drop x current = heat to deal with. If the pump is running at all it's usually going to be ok.

atman100
Posts: 15
Joined: Sat Jan 03, 2009 1:01 pm
Year and Model: 2005 S80 ,
Location: Arizona
Has thanked: 0
Been thanked: 0
Afghanistan
atman100

Re: 2006 S80: Fuel Pressure Sensor code question - sensor or new fuel pump?

Post by atman100 » Sun Feb 18, 2018 12:30 pm

I had this exact same issue that resulted in a new fuel pump side the plastic fuel tank of a 2005. I too replaced the sensor at the end of the rail

chrism
Posts: 986
Joined: Wed Jan 28, 2009 9:38 am
Year and Model: S80 / 2005
Location: Atlanta, GA
Has thanked: 0
Been thanked: 22 times
chrism

Re: 2006 S80: Fuel Pressure Sensor code question - sensor or new fuel pump?

Post by chrism » Sun Mar 04, 2018 6:40 pm

Did you replace the sensor with the same color part? (Gray for turbo / black for non-turbo)

atman100
Posts: 15
Joined: Sat Jan 03, 2009 1:01 pm
Year and Model: 2005 S80 ,
Location: Arizona
Has thanked: 0
Been thanked: 0
Afghanistan
atman100

Re: 2006 S80: Fuel Pressure Sensor code question - sensor or new fuel pump?

Post by atman100 » Fri Mar 09, 2018 3:52 pm

Yes I did . I put a new sensor on the rail, gray , but it did not solve the problem and eventually the fuel pump had to go . When that was done, no more codes and all was well except that the fuel pump has a gas gauge float on it and the gas gauge continued to be inaccurate as well as the "Distance to Empty" figure in the message window which are still inaccurate today, two years later . I think at the time, the pressure measured at 40 psi but I was told that was OK. It wasn't . There was 136 k miles on the vehicle, five cylinder.

CodyS80
Posts: 7
Joined: Sun May 15, 2011 10:26 pm
Year and Model: 2018 S90
Location: Cody, WY, USA
Has thanked: 0
Been thanked: 0
United States of America
CodyS80

Re: 2006 S80: Fuel Pressure Sensor code question - sensor or new fuel pump?

Post by CodyS80 » Sat Mar 31, 2018 12:17 pm

Well, I put in a new PEM and cleared the codes, praying that it would be the end of my problem, but no, the CEL is back on and has stayed on for days. I now notice that the idle is a little rough. So I am looking at getting a new fuel pump. Can anyone share experiences with the $150 Bosch pumps vs. the $400 Volvo OEM ones?

Post Reply
  • Similar Topics
    Replies
    Views
    Last post