IPD sale XeMODeX - Experts in Volvo Electronics Free shipping all USA - Experts in Brakes
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy anything with this and it helps MVS!

Upper radiator hose not seating fully to radiator flange

Help, Advice, Owners' Discussion and DIY Tutorials on the Volvo S80 model. Sometimes called an "executive car", the S80 was and continues to be Volvo's top-of-the-line passenger car.
t3yf5g
Posts: 13
Joined: Mon Jan 13, 2014 5:47 pm
Year and Model: 2001 S80 T6
Location: Vancouver, WA
Has thanked: 0
Been thanked: 0
United States of America
t3yf5g

Upper radiator hose not seating fully to radiator flange

Post by t3yf5g » Mon Mar 19, 2018 12:48 pm

Lurked around for a while but now I need some input.

I have had a slow coolant leak on my 2001 S80 T6 for a good while now and have just topped off the reservoir as I need too. It sprays out the bottom half of the flange slipping past the hose. Last evening I discovered I can't milk it any longer due to not getting any heat out of the vents in the cabin.

I took the hose off and found some silicone in the hose. Seems like the previous owner (used car dealer) tried to seal it up but obviously failed. I felt around the flange to see if I could locate a crack but nothing (might need to grab and endoscope though) from what I could feel.

I got the new hose on and noticed like the last hose, the top bottoms out before the bottom of the hose can get fully seated. Doesn't leave really much room for the clamp when tightening. Furthermore, the hose gets bent upwards slightly beyond the molded curve giving it a kink. I want to cut an angle off the hose at the flange end to see if I can seat it fully but I shouldn't have to, right?

I have the right hose and matches the previous one. Not Volvo branded though. Is there something the aftermarket brands are lacking with these hoses?

User avatar
oragex
Posts: 4697
Joined: Fri May 24, 2013 6:20 am
Year and Model: S60 2003
Location: Canada
Has thanked: 94 times
Been thanked: 242 times
Contact:
Canada
oragex

Re: Upper radiator hose not seating fully to radiator flange

Post by oragex » Mon Mar 19, 2018 2:06 pm

Could it be an aftermarket radiator? I don't see many options, the coolant system is pressurized so it will leak if not properly sealed. Maybe try to find a nylon piece of pipe to fit tight and glue it with some epoxy to the radiator to make a 1-2 in extension.

User avatar
SuperHerman
Posts: 1385
Joined: Mon Dec 01, 2014 1:28 pm
Year and Model: 2004 & 2016 XC90
Location: Minnesota
Has thanked: 0
Been thanked: 144 times
United States of America
SuperHerman

Re: Upper radiator hose not seating fully to radiator flange

Post by SuperHerman » Mon Mar 19, 2018 10:01 pm

I had this same issue with my XC90. The dealer installed the hose and all other relevant parts were new so I never thought to check their work. I had a slow leak for a number of years and tens of thousands of miles. Every 3-5 months I would have to top off the bottle with a few ounces. I figured it must be dumping the coolant as part of its normal operation as nothing was apparent.

While doing the PCV system I found the culprit.

I don't recall my work around, but the trick was to seat the hose fully and make sure the hose clamp stays straight. I think I went through the removed headlight - you need to position the clamp properly on the hose, not what you visually see. Just push the hose in until it stops and keep it there. Maybe release the other end, tightening it last. As my hose had the compression mark this was a good reference that made it easier to see how the hose needed to be aligned. I suppose you could dry install the hose clamp where you think it should fit then mark the outside all the way around the clamp with a sharpie or masking tape. Using this as a guide install the hose, make sure the clamp is as it should be and tighten it up.
Attachments
hose.jpg

t3yf5g
Posts: 13
Joined: Mon Jan 13, 2014 5:47 pm
Year and Model: 2001 S80 T6
Location: Vancouver, WA
Has thanked: 0
Been thanked: 0
United States of America
t3yf5g

Re: Upper radiator hose not seating fully to radiator flange

Post by t3yf5g » Wed Mar 21, 2018 1:26 pm

Thanks for the photo SuperHerman. I can see your clamp marks where similar with my previous hose but I am quite sure the clamp wasn't past the lip on the flange.

Taking out the headlight cap could get me some more visual room. I could also get a heat gun on the hose and see if I can push it in some more.

Plus you mentioning the PCV system is my next issue to solve my oil leak. The amount of money I have spent on oil and coolant in the last 2 years.... Course since I don't have freezing temperatures other than few days in winter, I have been topping off with water. Too bad I can't pour in my used cooking oil as well :/

Post Reply
  • Similar Topics
    Replies
    Views
    Last post