IPD sale XeMODeX - Experts in Volvo Electronics
Marking "Topic Solved" is functional again. It's the green check next to your post. BTW, please do use this when your question is answered and verified. Thanks!
MVS-Amazon link helps MVS!

Get email notification of topic replies. Log in or register (free). Amazon Link Buy anything with this and it helps MVS!

1999 Volvo S80 T6 no spark

Help, Advice, Owners' Discussion and DIY Tutorials on the Volvo S80 model. Sometimes called an "executive car", the S80 was and continues to be Volvo's top-of-the-line passenger car.
Post Reply
Barbarosa0943
Posts: 1
Joined: Tue May 15, 2018 12:37 pm
Year and Model: 1999 S80 T6
Location: Iowa

1999 Volvo S80 T6 no spark

Post by Barbarosa0943 »

This vehicle ran when I purchased it and after I changed the the speed output sensor however, it no longer starts. This accorded after the sometime after a new alarm siren module was put in and the vehicle fell off of the awful jack that came with the vehicle three times before we switched to a better one. When I went to start the vehicle it seemed unwilling but on the third trying it had started but didn't idle right then proceeded to die out. The battery was new however it kept dying even with the vehicle off so it now needs replaced. The only code remaining on the reader is p1618 volvo which it says is something to do with the CAN bus. However the vehicle only cranks NO SPARK. The spark plugs, camshaft sensor, and crankshaft sensor have all been changed. If it is relavent the lights on the dash dont work except the hazard, and turn signal. Does anyone even have an idea on where to start to fix this?
User avatar
SuperHerman
Posts: 1626
Joined: Mon Dec 01, 2014 1:28 pm
Year and Model: 2004 & 2016 XC90
Location: Minnesota
Been thanked: 176 times

Re: 1999 Volvo S80 T6 no spark

Post by SuperHerman »

Backing up - why did you replace the speed output sensor? How did you determine this was the cause of the no start? Are you sure that was the cause of the non-start? The speed output sensor is transmission related and I may be wrong, but it shouldn't cause a non-start.

Air-fuel and spark - that is what makes a car run. You need to check that you have these items. I would start with your fuel pump and fuel pump relay and electronics. Not sure if the car has a fuel filter, but check that out. When you put the key to POSII do you hear the fuel pump turn on? Can you check fuel pressure at the rail?

Another easy item to look at is your timing belt. Pull off the upper cover, two torx screws, and look at it to make sure it looks like all is in order.

It is unclear what your battery issue is. Are you saying you have a drain in the system? How does this relate to the siren module? Could you have created a parasitic drain here? When did it start? I believe you can just disconnect the siren module for testing purposes, you will lose several features, but the car will start and run. I think you can get to it by taking out the headlight and disconnecting just the plug. Once you have the other items sorted you can go back and look into the siren module issues (hopefully this is the cause of your battery drain - if that is what you are saying).

Disconnect the negative cable and put a charger on the battery until it is full - if it is a new one it should hold a charge.

As I understand a generic P1618 code is transmission related - I would not worry about it until after you get the car started. It will most likely need to be cleared with a proper scan tool if it clears at all (may be low battery related) or it may be that you also have transmission solenoid issues. Too early to tell until you get the car started and the battery situation resolved.
Post Reply
  • Similar Topics
    Replies
    Views
    Last post