IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy anything with this and it helps MVS!

2000 volvo s80 t6 rough idle and stalls

Help, Advice, Owners' Discussion and DIY Tutorials on the Volvo S80 model. Sometimes called an "executive car", the S80 was and continues to be Volvo's top-of-the-line passenger car.
Cmanner59
Posts: 7
Joined: Tue Jul 03, 2018 2:51 pm
Year and Model: 2000 s80 t6
Location: Indiana
Has thanked: 1 time
Been thanked: 0
United States of America
Cmanner59

2000 volvo s80 t6 rough idle and stalls

Post by Cmanner59 » Thu Dec 27, 2018 8:02 am

So ive rebuilt top end of motor as well as turbos, car starts and idles just fine every time but if I let idle a few minutes it begins to have a rough idle and stalls, will start right back up but do the same thing unless I pump gas pedal to rev rpms which sometimes will cause a slight misfire but goes away. No engine light but a code for bank 2 sensor 1 if I remember correct. Only problem I can find is the brake booster check valve is breaking apart and does leak. Would that cause rough idle and stalling? Also would a bad o2 sensor cause a whole bank to misfire? Ive searched hours and hours for a solution but it seems like no one has had these same symptoms. Thanks in advance

User avatar
SuperHerman
Posts: 1463
Joined: Mon Dec 01, 2014 1:28 pm
Year and Model: 2004 & 2016 XC90
Location: Minnesota
Has thanked: 0
Been thanked: 157 times
United States of America
SuperHerman

Re: 2000 volvo s80 t6 rough idle and stalls

Post by SuperHerman » Thu Dec 27, 2018 12:20 pm

First thing is to fix the brake booster leak. For now get some electrical tape or similar and do your best to seal it up. Goal is to eliminate the obvious as you work through to a solution. You can order a new part or a permanent alternative fix once you have eliminated your engine running issues.

What exactly are the codes? How many miles have you put on the car since the rebuild? Depending on whether it is a front or rear sensor could help in figuring out your issue. You most likely have an air leak or leaks - so that needs to sorted and then see what codes you have. Did you have the codes b/4 the rebuild? Why the rebuild?

Cmanner59
Posts: 7
Joined: Tue Jul 03, 2018 2:51 pm
Year and Model: 2000 s80 t6
Location: Indiana
Has thanked: 1 time
Been thanked: 0
United States of America
Cmanner59

Re: 2000 volvo s80 t6 rough idle and stalls

Post by Cmanner59 » Thu Dec 27, 2018 1:43 pm

Thanks for responding, Last winter timing belt tensioner failed and bent a couple intake valves didnt have much in the car at the time so i decided to rebuild it. Car had 170,xxx miles when i got it and tensioner failed at 205,xxx. since the rebuild ive only driven it around the parking lot car would bog down and stall when i let off throttle to brake. Car ran solid before the rebuild and had no codes that im aware of, i planned on replacing check valve and doing smoke leak test this weekend. i dont have the exact code right now but will scan it again when i do leak test.

User avatar
SuperHerman
Posts: 1463
Joined: Mon Dec 01, 2014 1:28 pm
Year and Model: 2004 & 2016 XC90
Location: Minnesota
Has thanked: 0
Been thanked: 157 times
United States of America
SuperHerman

Re: 2000 volvo s80 t6 rough idle and stalls

Post by SuperHerman » Thu Dec 27, 2018 4:23 pm

As the car ran well before the head work the best approach is to assume your O2 sensors and similar are good.

That said you need to check your work - start with the timing as this is always a tricky part.

See here: viewtopic.php?f=10&t=87735

Then look at every other item you touched and reconnected. On the 2.9T there are some hard plastic pipes that like to leak air - hit these with a heat gun or hair dryer so they snug up tight.

Power issue see here: viewtopic.php?f=11&t=87527

You are going to do a smoke test for leaks. The aluminum runners need to seal well, and sometimes the plastic piping cracks at the seams. Look at all of these closely. Did you do a compression test (as you removed the head this is a good double check of your work)? Fuel pressure test?

Check your ETM - pay close attention to the harness wiring. Recently a forum member had all sorts of issues and in the end it was a faulty connection I believe at the harness to ETM connection point. Make sure all the pins are good and the female side provides proper contact.

Keep updating as you narrow down the issue.
These users thanked the author SuperHerman for the post (total 2):
Cees KlumperCmanner59

Cmanner59
Posts: 7
Joined: Tue Jul 03, 2018 2:51 pm
Year and Model: 2000 s80 t6
Location: Indiana
Has thanked: 1 time
Been thanked: 0
United States of America
Cmanner59

Re: 2000 volvo s80 t6 rough idle and stalls

Post by Cmanner59 » Sat Dec 29, 2018 7:27 pm

Update - went and fired her up earlier today and checked fuel pressure at rail which was solid 55 psi. car began to idle rough after 15 min or so but never stalled out this time. revved it up a few times to try an set off engine light, eventually got codes for front and rear o2 sensors on both banks as well as a 644A code for camshaft control. Tested vvt solenoid and could hear it click and i used special tool to lock cams and the crankshaft when i did the timing belt the first time however, i had removed the gear pulley from the vvt hub, an didnt mark them, during rebuild to have camshafts and head cleaned, didnt think it would matter as long as the vvt was rotated all the way an timing marked lined up with cover or am i wrong? anyway didnt have the tools with me to re do timing belt so hooked up scan tool an watched engine data as it was running. as follows..

revving at 1000 rpm
adaptation cam opening 1 - (-16.19)
adapt cam opening 2 - (-16.68)
adapt cam opening 3 - (-16.66)
adapt cam opening 4 - (-16.11)

soo.. gonna lock cams an re do timing on tuesday if that dont solve it i have a spare vvt hub i can replace. any way to tell if hub on it now is bad??

Post Reply
  • Similar Topics
    Replies
    Views
    Last post