IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

Slow Start, Initially No Clicks

Help, Advice, Owners' Discussion and DIY Tutorials on the Volvo S80 model. Sometimes called an "executive car", the S80 was and continues to be Volvo's top-of-the-line passenger car.
magister
Posts: 2
Joined: Wed May 08, 2019 6:17 am
Year and Model: 2001 S80
Location: Pennsylvania
Has thanked: 0
Been thanked: 0
United States of America
magister

Slow Start, Initially No Clicks

Post by magister » Wed May 08, 2019 6:24 am

Hello everyone,

I recently acquired a 2001 Volvo S80 that I've begun working on over the past year: replacing the radiator, A/C blower, fuel flap actuator, and some other minor parts.

In the past three days, a new problem arose: when I turn the key into the third position, initially there are no clicks for about 5 seconds, then a very slow turn-over as the car starts. Momentarily the dash lights with dim as the car turns over.

I haven't been able to find any topic on this forum or elsewhere where there's initially no click and an eventually turn-over.

I check the starter wire for any corrosion (none), as well as the battery hook-ups for loose fittings or corrosion (none).

Thank you for your time.



User avatar
RickHaleParker
Posts: 3090
Joined: Mon May 25, 2015 2:30 pm
Year and Model: See Signature below.
Location: Kansas
Has thanked: 3 times
Been thanked: 354 times
United States of America
RickHaleParker

Re: Slow Start, Initially No Clicks

Post by RickHaleParker » Wed May 08, 2019 6:57 am

Start with the battery.
1. Make sure the battery terminals are clean.
2. Make sure the battery it not defective and fully charged.


Platform: P80 1998 C70, B5234T3, AW50-42, Bosch Motronic 4.4, Special Edition package, Plant: Uddevalla Sweden.

Platform: X40 (Nedcar) 2003 S40, B4204T3, AW55-50/51SN, Siemens EMS 2000. Plant: Born Netherlands.

Platform P2 2005 XC90 T6 Executive, B6294T, 4T65 AWD, Bosch Motronic 7.0, Plant Torslanda Sweden.
----------------------------------------------------------------
1997 S90, B6304S, AW30-42, Bosch Motronic 4.4 - Sold

magister
Posts: 2
Joined: Wed May 08, 2019 6:17 am
Year and Model: 2001 S80
Location: Pennsylvania
Has thanked: 0
Been thanked: 0
United States of America
magister

Re: Slow Start, Initially No Clicks

Post by magister » Wed May 08, 2019 2:28 pm

Hello,

Thank you, Rick.

Battery terminals are clean. Multimeter read 12V before starting the car, then jumped to over 13V, so the battery seems fine.

This afternoon, the car started three times without a problem.



Post Reply