IPD sale Volvo Parts

ETM rebuilt unit issue Topic is solved

Do you have a failing Electronic Throttle Module? What steps to take if you do, plus the latest ETM news. Volvo 1999-2002 models only please.
Post Reply
michalz
Posts: 3
Joined: Sun Dec 10, 2017 12:32 pm
Year and Model: 2000 v70xc
Location: Warsaw
Poland

ETM rebuilt unit issue

Post by michalz » Sun Dec 10, 2017 12:53 pm

Hi All!
Last days I have changed ETM in my car. I had some error codes with ETM and my mechanic was sure that it is Magneti Morelli faulty
ETM issue. So I have bought a rebuilt unit from the professional workshop. The car is running almost perfect, but after it catches a
proper temperature it has some strange idle behavior. It is hard to tell, so please find below two links which will take to YT.
The first situation is when I am going to stop before the lights and second is on the stop while I am moving the steering wheel.

I was wondering is it a case that I need to do something with car computer settings like some upgrade or set higher idle rpm's? Maybe
the ETM wasn't rebuilt correctly? Please share your thoughts.





Thanks :) ,
Michal
Last edited by michalz on Tue Dec 12, 2017 6:15 am, edited 2 times in total.
V70XC, B5244T3, m56

User avatar
RickHaleParker
Posts: 1629
Joined: Mon May 25, 2015 2:30 pm
Year and Model: See Signature below.
Location: Kansas
Has thanked: 2 times
Been thanked: 164 times
United States of America

Re: ETM rebuilt unit issue  Topic is solved

Post by RickHaleParker » Sun Dec 10, 2017 1:10 pm

The ECM may be relearning the ETM. Take it out and drive it for 50 - 100 km, see if it clears up.
1997 S90, B6304S, AW30-42, Bosch Motronic 4.4
1998 C70, B5234T3, AW50-42, Bosch Motronic 4.4
2003 S40, B4204T3, AW55-50/51SN, Siemens EMS 2000.

michalz
Posts: 3
Joined: Sun Dec 10, 2017 12:32 pm
Year and Model: 2000 v70xc
Location: Warsaw
Poland

Re: ETM rebuilt unit issue

Post by michalz » Mon Dec 11, 2017 1:11 am

Since change I have made around 300km and still the same.

ps. by mistake I have made post as solved but it isn't, can someone change it?
V70XC, B5244T3, m56

User avatar
RickHaleParker
Posts: 1629
Joined: Mon May 25, 2015 2:30 pm
Year and Model: See Signature below.
Location: Kansas
Has thanked: 2 times
Been thanked: 164 times
United States of America

Re: ETM rebuilt unit issue

Post by RickHaleParker » Mon Dec 11, 2017 6:03 am

can someone change it

On your end you should see a red check mark, click to set topic unsolved.

You might try cleaning out the Idle Air Control valve (ICA)
1997 S90, B6304S, AW30-42, Bosch Motronic 4.4
1998 C70, B5234T3, AW50-42, Bosch Motronic 4.4
2003 S40, B4204T3, AW55-50/51SN, Siemens EMS 2000.

michalz
Posts: 3
Joined: Sun Dec 10, 2017 12:32 pm
Year and Model: 2000 v70xc
Location: Warsaw
Poland

Re: ETM rebuilt unit issue

Post by michalz » Tue Dec 12, 2017 6:16 am

I do not have any red mark. This model doesnt have IAC valve, it is integrated with ETM.
V70XC, B5244T3, m56

Post Reply

Who is online

Users browsing this forum: No registered users and 14 guests