82 242 cold start issue; surging idle then dies.

Help, Advice, Owners' Discussion and DIY Tutorials on all Volvo's "mid era" rear wheel drive Volvos.

1975 - 1993 240
1983 - 1992 740
1982 - 1991 760
1986 - 1991 780
1990 - 1998 940
1990 - 1998 960
1997 - 1998 V90/S90

Post Reply
taylor98v70xcharris
Posts: 17
Joined: Wed Feb 22, 2012 12:47 pm
Year and Model: V70 XC, 1998
Location: Norman Oklahoma

82 242 cold start issue; surging idle then dies.

Post by taylor98v70xcharris »

Starting my car in the morning or anytime its cold is a real chore. I have to crank it several times (10-15) before it tries to start and when it finally does the idle surges like its hunting for an idle. Once the motor is warmed up everything smooths out and she runs perfect. Ive narrowed it down to three things: cold start injector, Thermal time switch, or CPR. Im pretty sure the thermal time switch gives the cold start injector a signal to fire, correct? Im just at a dead end and would love some input, Thanks!

jimmy57
Posts: 6674
Joined: Fri Nov 12, 2010 9:25 am
Year and Model: 2004 V70R GT, et al
Location: Ponder Texas
Has thanked: 4 times
Been thanked: 276 times

Post by jimmy57 »

Thermal time switch allows spray for a little more than a second and after you release key from start position the power for the heater is gone and it cools down again in a few seconds for a another attempt but the next cycle will be shorter.
CPR has almost no bearing on initial firing but can make for poor running after it starts.
One terminal of TTS is to the CSI and the other is hot from the 50 terminal for starter. The other terminal of the CSI is also from terminal 50 for starter solenoid. TTS is ground for CSI. On an 82 the CSI is also powered by a relay for hot start vapor lock purge. After starter runs for about a second the CSI is pulsed for .5 sec by the relay with an off time of .4 sec and then another .5 on, etc (times approximate from memory of training this injection system 25+ years back.

Unplug the oxygen sensor wire at firewall (single green wire on car side/black on O2 sensor side) and see how cold start behaves. There is supposed to be a switch for coolant temp above starter that will make the Lambda control unit ignore o2 sensor until coolant temp gets over 100F. If it is unplugged the car will surge initially until it warms. fuel mixture (CO) adjustment being off can also do this. Teace wiring for CSI and TTS for starting issues and then try the things listed for cold running issues.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post