IPD sale XeMODeX - Experts in Volvo Electronics Free shipping all USA - Experts in Brakes
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

Charging System

Help, Advice, Owners' Discussion and DIY Tutorials on all Volvo's "mid era" rear wheel drive Volvos.

1975 - 1993 240
1983 - 1992 740
1982 - 1991 760
1986 - 1991 780
1990 - 1998 940
1990 - 1998 960
1997 - 1998 V90/S90

cracra
Posts: 22
Joined: Sat Apr 28, 2018 6:45 pm
Year and Model: 1991
Location: Portland, Oregon
Has thanked: 0
Been thanked: 0
United States of America
cracra

Charging System

Post by cracra » Tue May 01, 2018 5:02 pm

Hello,

I am new here and women, however, I do know a little bit about cars, but this one I can't figure out. So please go easy on me as I try my best to describe my problem.

I have a 1991 940 Turbo, I was driving it awhile back drove approx, 15 miles everything was fine then I noticed as I was making turns my car wanted to die. My lights, stereo where cutting out, flickering I thought maybe running out of gas. Went to gas station put gas in, but then my car would not start. Yet when I turned the key there was nothing, no click click click like normal when the battery is dead. And lights and stereo still worked so I did not think battery. However a man stopped and asked if I needed a jump, I explained to him what was happening and that I did not think it was the battery, but I figured what the hell. He got jumper cables out hooked them up and after 3-4 min my car started. Drove it home turned off the car and would not start. I got a reconditioned alternator and replaced the old one. At first, alternator was putting out 14.5 so I thought great car is fixed. Drove it for two days and the car left me stuck again same problem. Get the car home ordered a brand new alternator put it in and again the same problem. What I have been doing is putting car on battery charger at night and as long as I don't drive far everything is fine. As long as the battery has a full charge. It's like the alternator is still not charging battery when driving. Could I really get 2 bad alternator in a row? Or could it be something else? Please help I am stuck..

Thank you so much

User avatar
June
Posts: 1645
Joined: Wed May 04, 2016 11:18 am
Year and Model: 2004 S80 T6
Location: Jacksonville, Florida
Has thanked: 256 times
Been thanked: 139 times
United States of America
June

Re: Charging System

Post by June » Tue May 01, 2018 5:22 pm

Welcome to MVS! I believe the parts store can test the charging system and the battery for you. Perhaps the battery is bad? June
My Volvo cars owned
1989 740 GLT ordered
1994 850 4door standard shift ordered
1996 960 ordered
1998 S90 ordered totalled after 3 weeks
1998 V70 GT dealer stock car
2002 S80 T6 ordered totalled
2004 S80 T6 dealer stock car and current car owned

cracra
Posts: 22
Joined: Sat Apr 28, 2018 6:45 pm
Year and Model: 1991
Location: Portland, Oregon
Has thanked: 0
Been thanked: 0
United States of America
cracra

Re: Charging System

Post by cracra » Wed May 02, 2018 5:22 am

Thanks, June

I took it to a battery exchange and they tested it and they said battery good. Said it was the alternator. However, this is the second one and I find it unlikely that 2 would be bad. I am thinking something else.

lummert
Posts: 1330
Joined: Tue Jan 29, 2008 5:39 pm
Year and Model: 760 1988
Location: Portland Indiana, USA
Has thanked: 0
Been thanked: 17 times
United States of America
lummert

Re: Charging System

Post by lummert » Wed May 02, 2018 5:11 pm

Alternator belt tension? Crankshaft pulley slipping?
1988 Volvo 760 Turbo Wagon

cracra
Posts: 22
Joined: Sat Apr 28, 2018 6:45 pm
Year and Model: 1991
Location: Portland, Oregon
Has thanked: 0
Been thanked: 0
United States of America
cracra

Re: Charging System

Post by cracra » Thu May 03, 2018 8:03 pm

Thank you, I am going to try those..

cracra
Posts: 22
Joined: Sat Apr 28, 2018 6:45 pm
Year and Model: 1991
Location: Portland, Oregon
Has thanked: 0
Been thanked: 0
United States of America
cracra

Re: Charging System

Post by cracra » Wed May 09, 2018 2:16 pm

So, we have checked all the grounds, checked the belts. Still same problem. Any other ideas would be greatly appreciated

Post Reply
  • Similar Topics
    Replies
    Views
    Last post