IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy anything with this and it helps MVS!

1990 Volvo 240 DL Wagon - Wipers and Horn Not Working - Fuse IS Good

Help, Advice, Owners' Discussion and DIY Tutorials on all Volvo's "mid era" rear wheel drive Volvos.

1975 - 1993 240
1983 - 1992 740
1982 - 1991 760
1986 - 1991 780
1990 - 1998 940
1990 - 1998 960
1997 - 1998 V90/S90

HereWeGoAgain
Posts: 2
Joined: Fri Dec 06, 2019 5:30 am
Year and Model: 1990 240 DL Wagon
Location: North Carolina
Has thanked: 0
Been thanked: 0
United States of America
HereWeGoAgain

Volvo Repair Database 1990 Volvo 240 DL Wagon - Wipers and Horn Not Working - Fuse IS Good

Post by HereWeGoAgain » Fri Dec 06, 2019 5:40 am

So we're rehabing a badly neglected 240 Wagon.

Both the horn and wipers are not working at the moment. Obviously first thought was the check and replace the 2nd fuse. That doesn't appear to be the issue. Neither of them appear to have power at all when the car is running, however checking the horn individually, etc. things work.

From what I'm seeing Volvo doesn't use relays on the horns, but there is a wiper relay under the dash.

What I think I'm looking for is a short somewhere that would effect the power to both the horn and the wipers at the same time? Unless you guys think that just sounds not feasible and these have to be unrelated?

This is my first Volvo. Not particularly familiar with any of the fun/eccentric things Volvo does with the wiring yet. Any ideas on where I should start? Best places to find diagrams?

User avatar
93Regina
Posts: 2813
Joined: Sat Jan 18, 2014 7:11 pm
Year and Model: 93:240/940
Location: Sunflower State
Has thanked: 0
Been thanked: 64 times
93Regina

Re: 1990 Volvo 240 DL Wagon - Wipers and Horn Not Working - Fuse IS Good

Post by 93Regina » Fri Dec 06, 2019 6:15 pm


HereWeGoAgain
Posts: 2
Joined: Fri Dec 06, 2019 5:30 am
Year and Model: 1990 240 DL Wagon
Location: North Carolina
Has thanked: 0
Been thanked: 0
United States of America
HereWeGoAgain

Re: 1990 Volvo 240 DL Wagon - Wipers and Horn Not Working - Fuse IS Good

Post by HereWeGoAgain » Mon Dec 09, 2019 7:54 am

Ok so, update.

Did some work on this yesterday.

Figured out that our fuse panel is fine.

We have a short to fuses 1 through 3 (obviously on the same power source), and also fuse 4 (which explains some other issues we were having, another topic entirely).

We were able to hardwire them (for testing purposes) to double check the functionality of the horn, wipers, heater blower, and the rear fuel pump. Found out I'll also need a wiper motor, fun stuff. At least we know we have power on both sides of box. Now I just need to chase the shorts on those two power sources.

And so the journey begins I guess?

Post Reply
  • Similar Topics
    Replies
    Views
    Last post