IPD sale XeMODeX - Experts in Volvo Electronics
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy anything with this and it helps MVS!

P0402 (bad catalytic converter) AGAIN after replacing catalytic converter?

Help, Advice, Owners' Discussion and DIY Tutorials devoted to the second generation C70, S40 and V50 Volvos -- awkwardly model year 2004 ½ onwards -- plus where to go for advice and discussion on Volvo's sporty C30 Coupe powered by Volvo's ubiquitous inline 5-cylinder power plant.
viaVolvo
Posts: 1
Joined: Wed Nov 16, 2016 8:54 pm
Year and Model: 2005 S40 2.4i
Location: Kearney, Nebraska
Has thanked: 0
Been thanked: 0
United States of America
viaVolvo

P0402 (bad catalytic converter) AGAIN after replacing catalytic converter?

Post by viaVolvo » Thu Nov 17, 2016 8:47 am

A short bit of background. This question is for a 2005 S40 2.4i (manual transmission) that I just picked up for less than 1/2 of book and I'm thrilled with it. It is gorgeous, in wonderful shape, and I have repair receipts for the last 3 years or so which is very helpful. (More about that in a bit.) The previous owner lived in a rural area and had his mechanical work done by a small town shop (not at a Volvo dealership).

I'm actually getting two codes right now and they may be related (?)

Code 1 is P2407
Exercising my Google Fu I come up with this:
Image

Code 2 is P0402 (most commonly, a bad catalytic converter) as seen here:
Image


I just took delivery of this car on Sunday. Receipts tell me that on 10-10-16 the owner had the Catalytic Converter replaced along with Oxygen Sensor 1 and Sensor 2. (With an oil change, the bill was $1091.) The owner told me that since listing it on Craigslist, the Check Engine light had come on again and so he slashed the price for me to take it as is. Between my negotiations and picking up the car, the owner took it in to get the codes read and told me that it was an EVAP code and indicated a cracked fuel cap. He offered me the good price along with a New Fuel Cap and a full tank of gas. He said that the light was now off, which it was when I looked at and drove the car. I bought it and drove it 233 miles to my folks' place. The CEL was still off and the gas tank was half full. I wanted to know what my gas mileage on the trip was so I filled it up. (Got 32.5 mpg mostly 65 mph). The next day I started for home from my folks'. I did a bit of city driving on the way, but about 170 miles into the trip (100 of which was interstate/79 mph) the fuel gauge was slightly below 1/2 and the CEL came on. I can not tell any difference in the way the car runs/sounds.

So, looking at those two images (above) of the possible culprits:
Is there something that could cause both codes?
What order would you try checking/fixing? (For example, I think that checking/blowing out/cleaning the Purge Valve is a no-cost thing to try.)
I put in gas with 10% ethanol (87 or 89 octane, which is common around here.) Is it important to use higher octane premium to help avoid this issue?
Any other words of wisdom or insight would be greatly appreciated.

PS... this S40 is going to be my daily driver (it has 126K and is replacing a Jetta with 179K). Our "good" car is a 2013 XC70 that has been superb so far (40K).

Thanks in advance and I will report back with what I do (what works and what doesn't).

Darren

User avatar
matthew1
Site Admin
Posts: 10532
Joined: Sat Sep 14, 2002 11:03 am
Year and Model: 850 T5, 1997
Location: Denver, Colorado, US
Has thanked: 573 times
Been thanked: 225 times
United States of America
matthew1

Re: P0402 (bad catalytic converter) AGAIN after replacing catalytic converter?

Post by matthew1 » Fri Nov 18, 2016 8:39 am

Darren, welcome. I shared this on the MVS Facebook page to get more ideas. (I don't know the answer.)
Help keep MVS on the web -> click sponsors' links here on MVS when you buy from them.
Also -> Amazon link
. Click that when you go to buy something on Amazon and MVS gets a kickback.

1997 850 T5, MSD ignition coil, Hallman manual boost controller, injectors, R bumper, OMP strut brace [gone]
2004 V70 R [gone]

Image

MadeInJapan
MVS Moderator
Posts: 13424
Joined: Thu Mar 31, 2005 7:14 am
Year and Model: '98 S70 T5 '07S40T5
Location: Knoxville, TN American but born in Japan
Has thanked: 7 times
Been thanked: 25 times
United States of America
MadeInJapan

Re: P0402 (bad catalytic converter) AGAIN after replacing catalytic converter?

Post by MadeInJapan » Sun Nov 20, 2016 2:55 pm

I'm wondering if they went with generic Oxy sensors (or even Bosch but still the wrong ones)...they are culprits on other Volvos- I would think they would reak havoc on our cars as well.
'98 S70 T5 Emrld Grn Met/Beige Tons of Upgrades Mobil-1
'04 V70 2.5T Red/Taupe Some Upgrades Mobil-1
'07 S40 T5 AWD 6 speed manual! Silver/Black Stage1 Heico & Elevate
'07 S60 2.5T Blue/Taupe- my kid's Volvo

User avatar
oragex
Posts: 4881
Joined: Fri May 24, 2013 6:20 am
Year and Model: S60 2003
Location: Canada
Has thanked: 97 times
Been thanked: 276 times
Contact:
Canada
oragex

Re: P0402 (bad catalytic converter) AGAIN after replacing catalytic converter?

Post by oragex » Tue Nov 22, 2016 2:36 pm

as above... was it original O2 sensor and cat.. ? even then, the CEL light doesn't mean you need replacing the cat again. Several things can trigger a CEL light, of which some are important - such as a misfire, while others don't require an urgent repair, such as an exhaust or vacuum leak

jimmy57
Posts: 6584
Joined: Fri Nov 12, 2010 9:25 am
Year and Model: 2004 V70R GT, et al
Location: Ponder Texas
Has thanked: 4 times
Been thanked: 241 times
jimmy57

Re: P0402 (bad catalytic converter) AGAIN after replacing catalytic converter?

Post by jimmy57 » Tue Nov 22, 2016 3:34 pm

Octane of fuel has zero bearing on this.
DOes the engine run smooth and idle smooth?
A common cause of that code is a partially clogged injector tip. That, and a few other 2001 and later volvo non turbo engines, use a multiple hole spray tip with extra fine holes. The holes can plug easily and when this happens the fuel mixture is off on that cylinder (lean) and the ECM will correct until oxygen level is read as correct. the problem is that the lean cylinder(s) will have too much O2 and the richening will drive the OK injector cylinders rivh and the O2 level average will be fine as far as O2 sensor can read. BUT the catalyst will not process exhaust correctly with the errant exhaust gas and rear O2 sensor will not read the correct value for properly functioning catalyst.

MadeInJapan
MVS Moderator
Posts: 13424
Joined: Thu Mar 31, 2005 7:14 am
Year and Model: '98 S70 T5 '07S40T5
Location: Knoxville, TN American but born in Japan
Has thanked: 7 times
Been thanked: 25 times
United States of America
MadeInJapan

Re: P0402 (bad catalytic converter) AGAIN after replacing catalytic converter?

Post by MadeInJapan » Tue Nov 22, 2016 4:04 pm

After reading the last response, I would be tempted to first put something in the gas that would clean the injectors- maybe Seafoam? Then, if that doesn't work, maybe even re-working the injectors to see if that might makes a difference.
'98 S70 T5 Emrld Grn Met/Beige Tons of Upgrades Mobil-1
'04 V70 2.5T Red/Taupe Some Upgrades Mobil-1
'07 S40 T5 AWD 6 speed manual! Silver/Black Stage1 Heico & Elevate
'07 S60 2.5T Blue/Taupe- my kid's Volvo

Post Reply
  • Similar Topics
    Replies
    Views
    Last post