IPD sale Volvo Parts
Did you know? 🤔
Logged in users can get email notification of topic replies Log in or register (free).
Amazon Link Buy your stuff using this and it helps MVS!

13 S60 T5 AWD engine swap

Help, Advice, Owners' Discussion and DIY Tutorials for the groundbreaking new Volvo S60 2011+, V60 and XC60.
cdretc
Posts: 23
Joined: Thu Feb 15, 2018 11:54 am
Year and Model: 13 S60 T5 AWD
Location: Ottawa, ON
Has thanked: 0
Been thanked: 0
Canada
cdretc

Re: 13 S60 T5 AWD engine swap

Post by cdretc » Sun Jan 20, 2019 11:43 am

Just for completeness, here are the other errors that pop up: "Immobilizer Try start again", DSTC Service Required", plus the dreaded "shift to P". Thanks



cdretc
Posts: 23
Joined: Thu Feb 15, 2018 11:54 am
Year and Model: 13 S60 T5 AWD
Location: Ottawa, ON
Has thanked: 0
Been thanked: 0
Canada
cdretc

Re: 13 S60 T5 AWD engine swap

Post by cdretc » Sun Jan 20, 2019 12:00 pm



I found this. It's pretty much the same problem, but I have less errors (but some are the same). Is there any way to test ECU? How can it get fried?



cdretc
Posts: 23
Joined: Thu Feb 15, 2018 11:54 am
Year and Model: 13 S60 T5 AWD
Location: Ottawa, ON
Has thanked: 0
Been thanked: 0
Canada
cdretc

Re: 13 S60 T5 AWD engine swap

Post by cdretc » Sun Jan 20, 2019 12:17 pm

Another piece of the puzzle. The gear selector is definitely in P and so is the transmission, as judged at the linker. But the transmission/wheels are not locked. The front wheels still spin. Argh.... Is the locking electronic or mechanical?



jimmy57
Posts: 6233
Joined: Fri Nov 12, 2010 9:25 am
Year and Model: 2004 V70R GT, et al
Location: Ponder Texas
Has thanked: 1 time
Been thanked: 144 times
jimmy57

Re: 13 S60 T5 AWD engine swap

Post by jimmy57 » Sun Jan 20, 2019 1:51 pm

Take the cable end off trans and push the lever forward and then check to see if the wheels lock. The cable end at shifter has a yellow part you lift and that allows it to move the lever attachment part relative to cable end for adjustment. You take off console side by shifter inside on left side. Maybe that slipped. If the lever is pushed fully forward and wheels lock you know it is in park. The sensor for gear position built into the TCM doesn't care bout cable or inside lever. It measures position on the trans. Once it has wheels locked then it is in park. The wheels will roll in Park off the ground. You turn one and the other goes opposite direction so moving wheel is not an indication of not in park if the wheels move opposite directions.



cdretc
Posts: 23
Joined: Thu Feb 15, 2018 11:54 am
Year and Model: 13 S60 T5 AWD
Location: Ottawa, ON
Has thanked: 0
Been thanked: 0
Canada
cdretc

Re: 13 S60 T5 AWD engine swap

Post by cdretc » Sun Jan 20, 2019 2:47 pm

Jimmy, you rock. I'm so overwhelmed that I forgot about that. The wheels were still off ground... I dropped one side and she is definitely in park. I lifted the linker again and there is no pull on the tranny shifter, so the cable looks good. I had that side open to get car out of park, so I checked and everything looks ok. There is a green plug there that doesn't have anything attached. Is that OK?

I still don't get where the green led light of the shifter knob went. Do you know what controls that? I have no light in the knob, no matter what position the knob is in.



jimmy57
Posts: 6233
Joined: Fri Nov 12, 2010 9:25 am
Year and Model: 2004 V70R GT, et al
Location: Ponder Texas
Has thanked: 1 time
Been thanked: 144 times
jimmy57

Re: 13 S60 T5 AWD engine swap

Post by jimmy57 » Sun Jan 20, 2019 5:34 pm

There is an unused connector on lots of P3s in that area. The wires break to the knob light on ones with lit knobs.
So it still has the Shift to P message and will not start?



jimmy57
Posts: 6233
Joined: Fri Nov 12, 2010 9:25 am
Year and Model: 2004 V70R GT, et al
Location: Ponder Texas
Has thanked: 1 time
Been thanked: 144 times
jimmy57

Re: 13 S60 T5 AWD engine swap

Post by jimmy57 » Sun Jan 20, 2019 5:35 pm

There is an unused connector on lots of P3s in that area. The wires break to the knob light on ones with lit knobs.
So it still has the Shift to P message and will not start?
If you have ignition on and move it to R position do the reverse lights come on?



cdretc
Posts: 23
Joined: Thu Feb 15, 2018 11:54 am
Year and Model: 13 S60 T5 AWD
Location: Ottawa, ON
Has thanked: 0
Been thanked: 0
Canada
cdretc

Re: 13 S60 T5 AWD engine swap

Post by cdretc » Sun Jan 20, 2019 6:32 pm

Yes the same message. And no, the reverse lights don't come on when it's in R. I checked on the tranny that it's in the R position. What controls the rear lights?

I don't think I have a lit knob. I am interested more in the green LED that shows the gear on the knob. It's AWOL since the swap. All these things, the reverse lights, the AWOL green LED and the shift to P must be somehow related, but I can't figure out how. I wish someone near me had a VIDA. I have an Autel 808, but it's not helping much.

Can you suggest something how the things regarding the gear position relate to each other?



jimmy57
Posts: 6233
Joined: Fri Nov 12, 2010 9:25 am
Year and Model: 2004 V70R GT, et al
Location: Ponder Texas
Has thanked: 1 time
Been thanked: 144 times
jimmy57

Re: 13 S60 T5 AWD engine swap

Post by jimmy57 » Sun Jan 20, 2019 7:24 pm

The TCM sends gear position info on the network for any users to see. CEM runs reverse lights and allows starter depending in the correct gears. Back up camera and back up sensors if equipped work when the reverse gear signal is delivered. The gear indicator lights on the GSM panel (GSM is part of the panel that is where gear lever sticks out). It really seems the TCM is offline. DIsicnnect battery ground lead and leave it undone till tomorrow. The TCM is a module that the battery rest procedure will sometimes not reset. No way the connector on the TCM got bumped or damaged? The ground for TCM is on the frame member on driver's side under air cleaner. No disconnected or pulled wires there?



cdretc
Posts: 23
Joined: Thu Feb 15, 2018 11:54 am
Year and Model: 13 S60 T5 AWD
Location: Ottawa, ON
Has thanked: 0
Been thanked: 0
Canada
cdretc

Re: 13 S60 T5 AWD engine swap

Post by cdretc » Mon Jan 21, 2019 10:33 am

I removed the poles this am. I also disconnected the TCM specifically. I just wish someone could scan my car with VIDA...

Thanks for all your help so far Jimmy. What a disappointment this car has become...



Post Reply