2013 Volvo S60 T5 AWD Blower Motor Not Working

Help, Advice, Owners' Discussion and DIY Tutorials for the groundbreaking new Volvo S60 2011+, V60 2015+ XC60 2010-2018.
Post Reply
StevenStowik
Posts: 7
Joined: Sat Feb 23, 2019 11:22 am
Year and Model: 2009 S80
Location: Rhode Island

2013 Volvo S60 T5 AWD Blower Motor Not Working

Post by StevenStowik »

I have a 2013 Volvo S60 T5 AWD, blower motor is not turning on with the fan knob turned up to 100%. I was told to check the refrigerant, so I tried to check it, I believe it looked good but I don't think it was an accurate reading because the outside air wasn't passing through the evaporator coil to warm it up, due to the fan not turning on.

Now I am probably not supposed to do this but I noticed the blower motor right behind the low pressure service port. I stuck my arm in to move it, I gave it a quarter turn, it took, it continued spinning and there was cold air blowing through the vents. After a while, it stopped blowing air, and once again I had to give it another quarter turn.

What does this mean? Do I have a bad blower motor? Or is there an underlaying issue here with my refrigerant level?

jlh3rd
Posts: 17
Joined: Mon Nov 26, 2018 7:08 am
Year and Model: 2012 s60
Location: pennsylvania
Been thanked: 1 time

Post by jlh3rd »

whoever told you to check refrigerant level for a non working blower motor doesn't need to be working on your volvo. Refrigerant levels have nothing to do with a blower motor running or not. Refrigerant levels can only be properly checked by reading the high side/ low side pressure readings. Does the blower motor work without a/c on? Does it work with heat selected on? Or do you have to spin it also. ( i don't know how your spinning it by hand but, ok.)
Short answer, your blower motor is bad.

Post Reply
  • Similar Topics
    Replies
    Views
    Last post