Amazon Black Friday deals
IPD sale XeMODeX - Experts in Volvo Electronics

Get email notification of topic replies. Log in or register (free). Amazon Link Buy anything with this and it helps MVS!

[2013-XC60] USB port not functional

Help, Advice, Owners' Discussion and DIY Tutorials for the groundbreaking new Volvo S60 2011+, V60 2015+ XC60 2010-2018.
Post Reply
Posts: 10
Joined: Sat Nov 02, 2019 12:06 pm
Year and Model: 2013 XC60
Location: Texas

[2013-XC60] USB port not functional

Post by 2013volvoxc60 »

I've been trying to figure out why the USB port seemingly doesn't work. I checked some fuses, found one that was blown that corresponded to the 12 volt outlets, I was kind of hoping that'd fix it but I don't have the luck of the Irish.

I've tried a USB flash drive, formatted it to FAT32 and that didn't work. We have an old old ipod classic and tried that with the original cable and they didn't work, no sign of charging. Wife tried her iPhone and same thing.

Interestingly, my phone, a S10+ showed a charging sign but I had a notification saying to check and make sure it was properly connected on the phone. I'd speculate that the USB port isn't compromised then because my phone actually showed a connection.

But I'm stumped, not sure what it wrong with it. Any ideas?
Posts: 4
Joined: Sat Aug 06, 2011 10:12 am
Year and Model: 2013 XC60 T6 AWD
Location: Los Angeles, CA

Re: [2013-XC60] USB port not functional

Post by prendrefeu »

I experienced something similar a long while ago (about a year I think?) on a long road trip: the iPod was not responding at all anymore, and I through the powers of reductive deduction I found out it was the USB port itself.

The easiest fix: took it into Volvo. The dealer installed a new one for less than $100 and only an hour or so of turnaround time.

Done, haven't had a problem since.
Post Reply
  • Similar Topics
    Last post